Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: TEC Diver on March 29, 2011, 10:55:22 PM

Title: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on March 29, 2011, 10:55:22 PM
Hello

Yesterday I had the problem that Avast did not run as usual - Antispam was off and I could not activate or fix it. Avast showed up a message that a package was damaged. Today Avast does not start any more after it downloaded and installed something automaticly. Now I get this message and Avast is not running:

Failed to load language dll [1031\UILangRes.dll]

My OS is Win 7 Ultimate - 64 Bit

How can I fix this???
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: JuninhoSlo on March 29, 2011, 11:19:26 PM
Hello

Yesterday I had the problem that Avast did not run as usual - Antispam was off and I could not activate or fix it. Avast showed up a message that a package was damaged. Today Avast does not start any more after it downloaded and installed something automaticly. Now I get this message and Avast is not running:

Failed to load language dll [1031\UILangRes.dll]

My OS is Win 7 Ultimate - 64 Bit

How can I fix this???



Did you try a complete clean uninstall/reinstall of Avast? ,also you can try Avast beta ver 6.0.144. ;)

Bye. Lep pozdrav :)
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on March 30, 2011, 03:00:04 AM
Hi

How can I make a "clean uninstall/reinstall" of Avast and what happens with the license?
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: DavidR on March 30, 2011, 03:08:29 AM
Just use the license again it isn't limited to a number of installs, just the number of systems it can be installed on.

Ensure that you have saved a copy of your license file license.avastlic so it can be used in the new install.

- Download the latest version of avast, 6.0.1000 and save it to your HDD, somewhere you can find it again (if you didn't save your last download). Use that when you reinstall.

- Download the avast! Uninstall Utility, aswClear.exe find it here (http://www.avast.com/uninstall-utility) and save it to your HDD (it has uninstall tools for both 5.x and 6.0.x).
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on March 30, 2011, 07:36:10 AM
How can I find out which one is the correct one for my licence file?

avast! Pro Antivirus 6.0

avast! Internet Security 6.0
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: nmb on March 30, 2011, 08:32:31 AM
Just open the avast GUI, you can see which version of avast you have (see pic - nmbY)

I see that you have mentioned antispam in your first post and antispam is present only (http://www.avast.com/free-antivirus-download) in Avast internet security(AIS).(see pic - nmbZ)

You can find the required(AIS) installer here : http://files.avast.com/iavs5x/setup_ais.exe
or if it is Avast pro, its here : http://files.avast.com/iavs5x/setup_av_pro.exe
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: DavidR on March 30, 2011, 04:00:52 PM
If it is mentioned that anti-spam is off and avast could not fix it, then it must be an available function, it must be the AIS program.

However, that doesn't really matter too much, as with the three separate problems mentioned, to me it indicates program corruption. So a clean reinstall of whatever avast version they have installed is the best way to go. Though personally I would have gone for an avast Repair as the first option.
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on March 30, 2011, 10:18:38 PM
I also tried the repair first by klicking it but nothing happend! I tried it around 5 to 6 times buy absollutly nothing happend so I tried to turn Antispam back on but also nothing happend. Next day Avast did not start up after trying to install something.

I try now to reinstall Avast. Thanks for the help so far!!!
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: DavidR on March 30, 2011, 10:59:15 PM
You're welcome.
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on March 31, 2011, 03:47:18 AM
After the reinstallation Avast is running again. I now get from the Windows the (flag) message that "avast! Internet Security" is not up to date. If I try to update Avast, Avast tells me it´s up to date and no more updates are availible. What can I do that the white Flag with the red X disappears again from the taskbar next to the clock?
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: DavidR on March 31, 2011, 04:40:33 AM
First ensure that your system date is correct, day/month/year and adjust as required. If correct move to the next step below.

Now try a repair of avast. Control Panel, Programs & Features, uninstall a program, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow. You may need to reboot after the repair. This has in the past resolved this out of sync issue between reported and actual version.
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on April 01, 2011, 02:42:30 AM
Thank u, now the flag is gone again!
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: DavidR on April 01, 2011, 03:57:18 AM
You're welcome.

Which option was it that resolved the problem ?
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: TEC Diver on April 02, 2011, 02:27:53 AM
Windows made an update and I had to reboot the PC after the update was installed. After the reboot I wanted to repair the avast because day and time was correct but after the reboot the flag was gone!  :o
Title: Re: Failed to load language dll [1031\UILangRes.dll]
Post by: DavidR on April 02, 2011, 02:33:15 AM
OK, thanks for the feedback.