Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: aldz on September 22, 2011, 06:52:15 AM

Title: avast free blocking internet access in windows 7
Post by: aldz on September 22, 2011, 06:52:15 AM
I installed avast free to a new netbook with window 7 OS. The wifi connection was fine when the avast free was not yet registered. But once I registered the avast free online, the wifi connection indicates that it has no internet access but could still browse the local area network.

Can anybody please help on how to resolve this. I have tried uninstalling the avast just to make sure that it is the cause of the problem and it is really the cause of the blocking of the internet access.
Title: Re: avast free blocking internet access in windows 7
Post by: DavidR on September 22, 2011, 01:14:00 PM
I have avast 6.0.1289 on my win7 acer netbook and no problems connecting using its integrated wifi.

What errors are being displayed ?

What is your firewall ?
Does it allow avastSvc.exe internet access ?
- If it does delete the entry for it and reconnect to the internet, this should force the firewall to ask permission again.

Rather than uninstall avast, you could Stop the Web Shield as a workaround until this is resolved as you will have the other avast protection from the file system shield.

If it worked before you registered, it should still work after registration as essentially nothing has changed in the programs functionality.
Title: Re: avast free blocking internet access in windows 7
Post by: aldz on September 23, 2011, 03:08:29 AM
Thanks for the reply.

There are no error messages that appear. It just show on the wifi icon "no internet connection".
That happens after I registered the avast. I will try your suggestion to disable the web shield.

Regarding the firewall I am using, the Win7 firewall is "on".
Title: Re: avast free blocking internet access in windows 7
Post by: DavidR on September 23, 2011, 04:05:42 AM
There have been a few instances of that in the forums, but so far they have been umable to pin it down and they have found that even with avast uninstalled in certain circumstances this still happens.

All I can suggest for now id try a forum search for wifi, it is after 3am here and I'm about to call it a night.
Title: Re: avast free blocking internet access in windows 7
Post by: Saulius on September 23, 2011, 07:04:03 AM
I can confirm what DavidR has said about this problem that it can occur even without Avast!, although it may be a case an aspect of Avast! can be agitating this problem of randomly losing internet connections and yes it is being both discussed here and looked into by Avast!.

I don't recommend disabling the Avast! Web Shield strait up, but may be only as a last resort.

@aldz Since this can happen without Avast! I assume it is something happenning with your Windows 7 OS, personally I blame MS.

However Windows does provide a few tools to try and get things working again in these situations even though it seems no one is exactly certain about the problem.

You can troubleshoot your network connection and home group by Opening Network and Sharing Center and in the central list at the bottom is "Troubleshoot Problems", click on it to get to that and you'll see a few things you can do. Of them the 3rd one, "Homegroup" I find the most effective to use in resolving this problem, although I also do the first one, "Internet Connections' and the forth one, "Network Adaptor" if "Homegroup" fails to.

I suggest right clicking "Homegroup" in Troubleshooting Problems and choose to run it as administrator and on the Homegroup pop up window click Advanced (written in blue) to apply fixes, shortly after running a few seconds it will stop and ask you if you want to "Troubleshoot Network Problems" and yes click on it to do that also.

You might have to do this several times to finally get it to correct things and allow you to connect to the internet, if it doesn't there are several other things you can try to do.

I'll tell you my next thing and that is from the Network and Sharing Center screen, in the top left corner click on "Change adapter settings" which will show you an image icon of you LAN or WLAN connection, now right click on that and on the drop down menu pop up click on the top option "Disable" and it will disable your Local Area Connection. After a moment right click on the image icon again and choose to "Enable" LAN connection. Right click on the image icon again and choose "Diagnose" or if it isn't there "Status" and on the pop up that comes up click on the "Diagnose" button, sort of bottom right IIRC.

After that diagnostic runs it may have fixed the connection, but not your Homegroup setting, so usually I troubleshoot the "Homegroup" again as above, may be twice! After all that I check that the internet is connecting by going back to the Network and Sharing Center and clicking on the "See full map" (written in blue top upper right of screen) and it should only take a moment to create a diagram of your LAN Network connection in a tree, if it doesn't and says that it can't create it or cannot find any device you'll have to try and do all of the troubleshooting again or just give up and shutdown and reboot your computer.

There is one thing in Avast! that seems to help prevent this loss of internet connection from happenning and that is to open Avast! go to Web Shield, choose Expert Settings and put a tick in the box for "Scan traffic from well known browsers only", but while it slightly reduces your protection, there are other parts of Avast! that should hopefully pick up any of the slack. This is the best thing you can do with Avast! to try to prevent this problem at the moment, but as I said this isn't entirely a problem caused by Avast! it is a Windows 7 issue, that may be a hangover from Vista at least that is what stuff I read at Microsoft community help boards say about this problem.
Title: Re: avast free blocking internet access in windows 7
Post by: aldz on September 27, 2011, 05:33:02 AM
Saulius, thanks for that lengthy reply. It was informative.
However, before i decided to make a post in this forum and searched for a solution regarding this problem, I have checked and done what you have recommended. I am pretty sure that it was the avast that causes the problem and not the win7. Inasmuch as I would like to use avast, this problem lead me to use another antivirus for the mean time. And I didn't experience that problem anymore. But again how i wish I could use avira sans that problem regarding internet connection. I am still trying to figure out what is wrong with this avast free and win7 and hope to share it also with others.
Title: Re: avast free blocking internet access in windows 7
Post by: ady4um on September 27, 2011, 12:05:55 PM
I don't know if this is still relevant (after you uninstalled Avast), but you can try:

Avast main GUI -> settings -> troubleshooting -> "load avast service only after other system services".

If you decide to uninstall the other security tool and reinstall Avast, please download the adequate removal utility for that other security software (http://thewebatom.net/uninstallers/security-software/ (http://thewebatom.net/uninstallers/security-software/)).
Title: Re: avast free blocking internet access in windows 7
Post by: avast-fanatic on September 27, 2011, 10:41:37 PM
I'm experiencing the same problem since a couple of updates ago.
What I did was first to install Network Activity Indicator by itsamples.com. The icon shows activity (like in Windows XP) instead of just successful connection. 
Then after boot up I disable Avast, then I take the network off and on.  When the icon shows successful connection I reactivate AVAST.  I even created a shortcut to the Network Connections for easy accessibility.

Per this behavior the ady4um suggestion seems to be the logical approach but it doesn't work for me.

I hope this bug is fixed soon.
 
Title: Re: avast free blocking internet access in windows 7
Post by: aldz on September 29, 2011, 02:15:43 AM
I think I now know the cause of this problem. The owner of the netbook I am troubleshooting regarding this problem didn't tell me that she (or someone on her behalf) installed a pirated copy (cracked) of avast pro. And when the avast detected that it was a pirated copy maybe the avast pro was automatically shutoff (as per her account) and probably disabled internet access. She asked someone to uninstall it and install the free version.

So when she told me this, I already suspected that there was still some registry entry left by avast that disables internet access. So what I did is search the registry for any avast entry and deleted them. I could have used the aswclear utility from avast but I didn't have internet access in my place. Voila! internet access was restored.

Thanks to all who replied.
Title: Re: avast free blocking internet access in windows 7
Post by: ady4um on September 29, 2011, 10:13:57 AM
@aldz,

Thank you very much for reporting your solution.
Title: Re: avast free blocking internet access in windows 7
Post by: Deego on September 29, 2011, 04:05:51 PM
I also have this problem on my desktop. I discovered that by stopping "Web Shield" and restarting it again after I have opened Chrome, I have internet access until I reboot. Then I have to do the same again!! It's annoying but at least I have a work-around until the bug is fixed.
Title: Re: avast free blocking internet access in windows 7
Post by: LucianM on January 09, 2015, 07:24:59 PM
I have the same problem with my laptop (windows 7 64bit, Avast! free 2015.10.0.2208). After 3 minutes or so, Avast! web shield is blocking my internet connection. As soon I deactivate the web shield, everything works. I tried to uninstall and install a fresh copy, but the same results. Any ideas? Thanks!
Title: Re: avast free blocking internet access in windows 7
Post by: bob3160 on January 11, 2015, 10:36:27 PM
I have the same problem with my laptop (windows 7 64bit, Avast! free 2015.10.0.2208). After 3 minutes or so, Avast! web shield is blocking my internet connection. As soon I deactivate the web shield, everything works. I tried to uninstall and install a fresh copy, but the same results. Any ideas? Thanks!
See if this helps:
(http://www.screencast-o-matic.com/screenshots/u/Lh/1421012035842-93202.png)
Title: Re: avast free blocking internet access in windows 7
Post by: loveorchards on January 12, 2015, 05:11:19 PM
I'm having that problem too.  Windows 7 computer with Avast internet security.  With me, Avast would cause the computer to completely lock up when an internet browser was opened.  The only solution was to turn off the computer and then restart it.  This started around the end of September.  We limped through October then took Avast off and put on AVG.  Everything then worked perfectly.  Just yesterday tried Avast again to see if there was any improvement or maybe a later release, but no.  It immediately horsed up the computer, so I took it off again.  What happened to Avast?  I've been using it for years.
Title: Re: avast free blocking internet access in windows 7
Post by: Para-Noid on January 12, 2015, 05:37:52 PM
You do realize this thread is four years old and you probably should have started your own topic.

That said did you use the AVG uninstaller?
Find it here https://singularlabs.com/uninstallers/security-software/

After that do a clean install of avast...

Download and save http://files.avast.com/iavs9x/avastclear.exe
Download and save your choice...
http://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_internet_security_setup.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup.exe
Run the uninstaller from above. When prompted to reboot into safe mode click "yes".
Reboot.
Install choice from above.
Reboot and either register or insert license.

If you are still having issues untick the "https scanning" as Bob showed above.

edit: added screenshot.
Title: Re: avast free blocking internet access in windows 7
Post by: thekochs on January 12, 2015, 10:17:50 PM
Besides unchecking HTTPS scanning, on "install" use CUSTOM and uncheck "NG" in the Tools section of the Avast installer.
You can do a Forum search on NG but here is summary: https://forum.avast.com/index.php?topic=154857.msg1125734#msg1125734
It definitely impacts performance.
The combo of not having the HTTPS & NG your system should run fine.....you can always go back and change.
Title: Re: avast free blocking internet access in windows 7
Post by: LucianM on January 24, 2015, 06:59:47 PM
I reinstalled Avast! using uninstall tool. A few days worked, but now it's blocking internet access again after a few minutes even if "Enable HTTPS scanning" is unchecked. Do you know if I can disable NG from settings?