Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: holgerkaengu on November 15, 2004, 12:49:57 PM

Title: Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 12:49:57 PM
Hello,

I use avast for quite some time now and no problems occured so far. But after the latest automatic update I experience big problems. I have already changed the mail account settings back to standard (so I do not use the 127.0.0.1 settings). Small emails can be fetched as normal. But if I try to send or receive emails larger than 10kb I have no success. The result is a timeout. I tried it with different providers and the result is allways the same. It seems that it is due to a problem within avast beacause the ashmail fetcher in the task list does not close as usual but stays there for quite some time and shows a timeout. Seems that avast do not get large mails through. Is there a size limitation or something or other problems with the new 4.5 Version reagarding emails?

I need some help. Thanks in advance for your advices.

Yours

Holger
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Vlk on November 15, 2004, 12:56:20 PM
Please add the following line to the [MailScanner] section of <avast>\data\avast4.ini:

Log=20

Then generate some traffic, simulate the problem (i.e. force the avast mail scanner to time out by sending an email with attachment) and then post the contents of the file <avast>\data\log\aswMaiSv.log


Thanks
Vlk
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 01:17:47 PM
11/15/04 13:08:35:   --POP ReadFromPop ...
11/15/04 13:08:35:   <-POP  +OK 0 0
11/15/04 13:08:35:   --XXX testing second-side connection
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   ->POP QUIT
11/15/04 13:08:35:   --POP Before ReadFromPop
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --XXX sleep
11/15/04 13:08:35:   --POP ReadFromPop ...
11/15/04 13:08:35:   <-POP  +OK closing connection
11/15/04 13:08:35:   --XXX testing second-side connection
11/15/04 13:08:35:   --POP  Finishing connection handler
11/15/04 13:08:36:   SMTP accept connection from: 127.0.0.1
11/15/04 13:08:36:   --SMTP command REDIRECT
11/15/04 13:08:37:   --XXX sleep
11/15/04 13:08:37:   --XXX sleep
11/15/04 13:08:37:   --XXX sleep
11/15/04 13:08:37:   --XXX sleep
11/15/04 13:08:37:   --XXX sleep
11/15/04 13:08:37:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX testing second-side connection
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   ->SMTP MAIL SIZE=20276
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   <-SMTP 250 Command MAIL OK
11/15/04 13:08:38:   --XXX testing second-side connection
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   ->SMTP RCPT
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:38:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   <-SMTP 250 local recipient ok
11/15/04 13:08:39:   --XXX testing second-side connection
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   ->SMTP DATA
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:39:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:40:   --XXX sleep
11/15/04 13:08:41:   --XXX sleep
11/15/04 13:08:41:   --XXX sleep
11/15/04 13:08:41:   --XXX sleep
many xxx sleep between
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:18:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:19:   --XXX sleep
11/15/04 13:10:25:   Timeout in RecvTimeout - closing connection due to user
11/15/04 13:10:25:   --SMTP Finishing connection handler
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Vlk on November 15, 2004, 01:45:14 PM
If you change the account in Pegasus back to 127.0.0.1, does it work again? Or the same problem appears?

Thanks.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 02:10:21 PM
I configured it back to 127.0.0.1 but same error occurs. It can fetch small mails but cannot handle mails larger than 10kb. I cannot send the mail with the attachment before and after it same error occurs. It seems that nothing is wrong with the configuration of the pc or programmes due to the fact that it can handle small mails very fast but as I mentioned bigger mails lead to timeouts.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Spiceworm on November 15, 2004, 03:11:51 PM
Hi, i had the same problem here with Mozilla Thunderbird after the update to version 4.5.x???

This is what i found in the FAQ:

Q: After updating to version 4.5 I can no longer send/receive emails.

A:

The following text applies to Windows NT/2000/XP/2003 systems only.

Mail scanning in avast 4.5 is implemented differently than in previous versions. In avast 4.5, mail filtering works transparently. That is, no reconfiguration of mail clients of any kind is required for the mail scanning function to work.

If you have, in the past, manually reconfigured your e-mail client program to route all traffic through the avast! Internet Mail provider (by changing the server addresses to 127.0.0.1 and the username value - as described in the avast help files), you should remove these extra settings (i.e. revert them to the original state; in other words, have the accounts set up exactly as if there was no avast installed). This will allow the avast transparent mail proxy to be used.

And it worked for me :D

edit: hmmm didn't read that well, you already tried  :-[
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 04:18:39 PM
Thanks for your answer Spiceworm but it is as you edited I already tried that but unfortunately it does not work. The problem stays the same it does not affect Pegasus it works to fetch both with 127.0.0.1 configuration and with normal setting just as pop.provider.com and smtp.provider.com

Small mails pass through but bigger ones lead to timeouts.

Do not know why but this occurs since it automatic update to 4.5.xxx before there was no such problem and it worked fine even with huge emails.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 05:38:56 PM
Seems that other users experience same problems under Thunderbird and others. i think it is a problem with handling large emails not with receiving or sending I think it depends on the size of the mail. Small come through (under 10kb) large does not. Any suggestions? Think that this is a bug. Any proposals to solve that? Is there a file limitation that leads to timeouts? It is really anyoing as before the update everything worked fine.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: vojtech on November 15, 2004, 06:04:32 PM
There is no limit on mail size in the mail scanner.

I made a test version, please download it here:
http://www2.asw.cz/~peterka/4.5.523/ashMaiSv_2.exe (http://www2.asw.cz/~peterka/4.5.523/ashMaiSv_2.exe)
Save it to Avast4 folder, terminate 'Internet Mail' provider and start this ashMaiSv_2.exe as an application. Try to send big mail and when the timeout occurs, press NO. Then go to your %TEMP%\_avast4_ folder, there should be a file with name beginning with 'unp' and having the current time. It should contain the whole mail you sent. Could you send me that file by email ?
Thank you.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 06:59:45 PM
Hello,

thank you for your assistance and efforts but it does not work. I made everything as you telled and the timeout comes using the "new" ashmaisv_2.exe quit the timeout with no (comes not automaically as under normal. The _avast4_ folder exist under temp but it is empty no unp or something within the folder. So I can not send you something unfortunately. Seems it does not work.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Lisandro on November 15, 2004, 10:36:18 PM
Holgerkaengu, I do not see any problem with my Thunderbird...  :-\
After you use the 127.0.0.1 trick, did you add AutoRedirect=0 to MailScanner section? See details on 'Settings' in my signature.

Anyway, I do not have to use this with my TB. avast! 4.5 works like a charm with it...
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 15, 2004, 11:28:35 PM
I have made it but nothing changes.

But I have an idea:

If I disable avant mailscanner everything works fine after reinitalizing it it hangs up again larger mail downloads. I experiment with the avast.ini in the data folder seems this is the key. There are some changes within which sometimes lead to peer error when changing to 127.0.01 I think a solution would be to have that ini and especially the settings under mailscanner before the update to 4.5 so can you publish a old setting table of this ini (perhaps of version 4.1 or 4.4?

Thanks in advance.

I published this idea in some other related threads hopefully that one pickes that up and publish it. It is a little biut sad that we have not one big thread for email related problems as it seems this is a big trouble avast sees since updating not only with Pegaus as I have learned from the other threads also with picomail, Thunderbird and so on.

Resolving that problem would be a great feature. I would put it on the top of the wishlist for an update of 4.5.x :-)
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Lisandro on November 16, 2004, 01:16:26 AM
Can you publish a old setting table of this ini (perhaps of version 4.1 or 4.4?

Sure, here it is (there isn't any 4.4 version, only 4.1 and then 4.5):

[MailScanner]
DefaultPopServer=mypop.server.address
DefaultSmtpServer=mysmtp.server.address
DefaultImapServer=
SmtpListen=127.0.0.1:25
PopListen=127.0.0.1:110
ImapListen=127.0.0.1:143
ShowTrayIcon=0
UseDefaultSmtp=0
AutoSetProtection=0
Log=1
PassThrough=0
Trust=127.0.0.1
StartSmtp=1


Hope this helps...  :-\
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: robbo on November 16, 2004, 01:20:41 AM
I found that adding ashmaisv.exe to the allowed programmes in my firewall solved all the problems I was having. Apparently with the update my firewall (Norton) didn't recognise the programme and so it couldn't connect.
Give it a try and see what happens.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: S.Z.Craftec on November 16, 2004, 01:52:34 AM
Most dumb thing, Norton didn't alarm you about change... Sygate alarmed me without any problems. ZoneAlarm does the same thing, that's what I've heard from ZA users. That means your firewall is "watching" closely what's happening in your PC, and if something is changed, firewall must inform you... not just deny access to some programs without your permission...
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 16, 2004, 10:35:29 AM
Thanks all for the tipps and tricks suggested so far.

Here are the results: Nothing worked so far. The error that occurs is remaining the same. Large mails (over 10kb) did not come through.

Here are the facts:
a) It cannot be the firewall because when I shut it down the same happens
b) It can not be Pegasus because when I shutdown the avast internet mail scanner everything works perfectly
c) It can not be wrong settings in some programmes because small mails come through even with enabled avast mail scanner

I tried with the 127.0.0.1 as well as pop.provider.com settings. I believe it is either depending on special settings of the avast.ini in the data folder or changes to ashmaisv.exe itself who has problems handling larger emails.

I tried very much but nothing helped so far. The error stays the same. Has someone a donwload link (URL) vor me that I can download an earlier version of avast before 4.5.xxx? so a 4.1 +x (e.g. 4.4.x) Version (published before 09.11.04) as the "old" avast worked very fine with Pegasus on my computer. Perhaps I can make some compares (settings and other things) to find a solution (perhaps I find what is wrong then I will publish it here immediatelly as a tryout tip). That would be great.  

Thanks in advance

Yours

Holger
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 16, 2004, 12:08:06 PM
Hello I have made all setting change proposals but the result stays the same. Meanwhile I believe it is due to the ashmaisv.exe that causes the problems (setting changes have no effect to the error). So I would be glad to have a URL to download the "old" 4.1 version. Can anyone help me to get a download URL. Thank you.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: S.Z.Craftec on November 16, 2004, 12:12:33 PM
Well, I don't have alink, but going back to older version is not the permanent solution. I'm sure someone will find a solution for you. It's working here without any problems, so that means nothing is wrong with 4.5

It's just compilation of all those settings in programs you are using. Wait a little bit and someone will come up with something.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: W on November 16, 2004, 12:34:02 PM
holgerkaengu,

I just wondered if you had tried:-

1, making sure that you do not have a download limit set under 'Download Controls' in Pegasus's POP3· settings?.

2, increasing the 'time-out' values in Pegasus's POP· and SMTP settings?.

I can understand the frustration when it worked prior to the Avast update, but I am taking a big guess that it is to do with time-outs because prior to the update mail would be routed through the localhost (127.0.0.1) and this would pass through very quickly and/or possibly form a buffer that masked any time-out settings.

Good luck.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Lisandro on November 16, 2004, 12:37:51 PM
Holgerkaengu, listen to our master in Pegasus  8)
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 16, 2004, 01:07:29 PM
Sure I listen to the master :-)

but there is no limitation which depends on Pegasus as if I switch off avast mail scanner everything works fine and fast. So if there is a general setting in Pegasus regarding limitation it would not work every time. But that is not the fact: Switching mail scanner off = everything works, switching avast mail scanner on = nothing works anymore.

I also tripled the time of timeouts in Pegasus but even after 5minute snothing happens.

I really tried several settings in the ini (under data folder) but the result stays the same. So I really think it is the ashmaisv.exe that causes the problem. Perhaps I can restore it to the old one. Can someone send me an "old" ashmaisv.exe just for testing purposes. Would be grat to know if I think in the right direction. Perhaps someone from alwil can post it.

Thanks all of you for your efforts.

Yours

Holger
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Lisandro on November 16, 2004, 01:12:11 PM
Maybe you can:

Add the following line to the [MailScanner] section of <avast>\data\avast4.ini:

Log=20

Then generate some traffic, simulate the problem (i.e. force the avast mail scanner to time out by sending an email with attachment) and then post here the contents of the file <avast>\data\log\aswMaiSv.log
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: holgerkaengu on November 16, 2004, 01:22:14 PM
Have a look at the first page of this thread I have already mad and published shows a lot (perhaps little bit to much) sleep.

Would be fine to have an old version download just for testing purposes.

Bye
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: W on November 16, 2004, 01:39:01 PM
holgerkaengu,


Quote
but there is no limitation which depends on Pegasus as if I switch off avast mail scanner everything works fine and fast.

Well actually there is (or more correctly, can be) ;)

I thought I had read that you had returned to the 127.0.0.1 POP/SMTP settings. Apologies if I misread this.

Quote
So if there is a general setting in Pegasus regarding limitation it would not work every time. But that is not the fact: Switching mail scanner off = everything works, switching avast mail scanner on = nothing works anymore.

What I was trying to say was,going through localhost (with or without Avast! scanning) might have masked any time-out settings in Pegasus. Purely because sending to localhost is very quick and buffered.

However, sorry if it does not resolve the problem.
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: namaste on November 17, 2004, 03:53:14 PM
Hi, the same problem of holgerkaengu happens to me with OE 6.
Initially I thought it was an attachment problem (and I posted this wrong problem), but now I try to send an e-mail of 67 Kb without attachment and OE is not able to send it.
First appears the usually OE's message of no reply in 60 seconds by SMTP server and then the window of OE which explain that a timeout error (0x800CCC19) happens; after 300 seconds an Avast!'s message of no reply by SMTP server ... but with an ADSL line it's impossible wait 5 minutes to send a 67 Kb mail!
When I switch off Avast!'s mail provider all works fine and fast ... so I think it's an Avast! problem :'(
See you
Title: Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
Post by: Vlk on November 17, 2004, 05:06:44 PM
Is this only a problem with outbound mail? Or inbound mail as well?

Thanks
Vlk