Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Philbee on February 26, 2012, 01:14:46 AM

Title: Streaming Updates not connected...
Post by: Philbee on February 26, 2012, 01:14:46 AM
my streaming "cloud" updates have been working fine on avast 7 until just a few moments ago.  now it is saying "not connected".  is this a server malfunction on avast's end? or do i need to re-install avast free.  i am running windows 7 home premium.
Title: Re: Streaming Updates not connected...
Post by: Philbee on February 26, 2012, 01:30:12 AM
now all of a sudden it is connected again.  must be a server issue...i hope. 
Title: Re: Streaming Updates not connected...
Post by: FlyingRobot on February 26, 2012, 01:52:18 AM
I've been meaning to ask something related (I may have overlooked it being asked before, if so I apologize).  Is the local avast program *supposed* to maintain a *truly* persistent connection to the avast cloud?  Say the user's system is idling.  They aren't running some new program, opening some new file, visiting some new URL, etc.  Lets assume assume the system just received the latest streaming update.  Will the local avast program maintain a persistent TCP connection to the avast cloud when there is (that I can think of, feel free to correct) nothing to do for awhile? 
Title: Re: Streaming Updates not connected...
Post by: Philbee on February 26, 2012, 03:09:20 AM
i haven't received any streaming updates now for a few hours.  it's connected, but no streaming updates.  all i have is --- where an update should be.  is there something wrong with my installation? or are there just no streaming updates currently?
Title: Re: Streaming Updates not connected...
Post by: Lisandro on February 26, 2012, 03:10:37 AM
Easy. The infraestructure is rising little by little. We will see up to 20 updates a day when it is ready. Right now, easy.
Title: Re: Streaming Updates not connected...
Post by: Philbee on February 26, 2012, 03:25:59 AM
thank you tech.  for now i'll just be patient and wait.  i sure wouldn't have to uninstall and re-install all over again.
Title: Re: Streaming Updates not connected...
Post by: Jack 1000 on February 26, 2012, 06:20:47 AM
Easy. The infraestructure is rising little by little. We will see up to 20 updates a day when it is ready. Right now, easy.

I was forced to reinstall Avast 7,

But for the last 48 hours, the cloud protection is enabled  as well as file reputation.  I got my four-hour definition updates, but have yet to receive any cloud updates.

Thanks Tech.  We will just have to wait I guess.

Jack
Title: Re: Streaming Updates not connected...
Post by: Orangge on February 26, 2012, 08:28:47 AM
I get my last two days not connected when I installed recently was fine.

 It's a server problem or I have to reinstall Avast?
Title: Re: Streaming Updates not connected...
Post by: Gopher John on February 26, 2012, 04:28:11 PM
I get my last two days not connected when I installed recently was fine.

 It's a server problem or I have to reinstall Avast?

It's not the servers, at least not now.  See http://forum.avast.com/index.php?topic=94249.msg751031#msg751031 (http://forum.avast.com/index.php?topic=94249.msg751031#msg751031).

Try a Windows restart.  Sometimes that helps.
Title: Re: Streaming Updates not connected...
Post by: Jack 1000 on February 26, 2012, 08:28:31 PM
Easy. The infraestructure is rising little by little. We will see up to 20 updates a day when it is ready. Right now, easy.

I was forced to reinstall Avast 7,

But for the last 48 hours, the cloud protection is enabled  as well as file reputation.  I got my four-hour definition updates, but have yet to receive any cloud updates.

Thanks Tech.  We will just have to wait I guess.

Jack

Cloud Service updates are coming in today!   Thanks Avast! ;D

Jack

Title: Re: Streaming Updates not connected...
Post by: selen on February 26, 2012, 08:42:20 PM
i haven't received any streaming updates now for a few hours.  it's connected, but no streaming updates.  all i have is --- where an update should be.  is there something wrong with my installation? or are there just no streaming updates currently?

I'm in your same situation. It's connected but it doesn't receive any updates since yesterday
Title: Re: Streaming Updates not connected...
Post by: Coolmario88 on February 26, 2012, 08:54:35 PM
I just noticed this also.. on the Update page in avast it saying Streaming updates: enabled..  but Connection: Connection not established..  see pic maybe the connection will be established again later.  ;D
Title: Re: Streaming Updates not connected...
Post by: Gopher John on February 26, 2012, 08:58:19 PM
I received several today.  When the standard VPS updated from 120226-2 to 120226-3, the C:\Program Files\Alwil Software\Avast5\defs\12022602_stream directory was removed by Avast and the "Latest update received" now shows --- again, until the next streaming update comes.
Title: Re: Streaming Updates not connected...
Post by: Sputnik.RU on February 26, 2012, 09:01:22 PM
I just received a streaming update for 120226-3, received one for 120226-2 today as well. Looks like the systems are getting phase  :)
Title: Re: Streaming Updates not connected...
Post by: Coolmario88 on February 26, 2012, 09:04:57 PM
Connection is back now.. With streaming updates should i get a virus definition has been updated popup also?  If yes, than i only get 3 of the auto update popups a day.. not several but just like 3.
Title: Re: Streaming Updates not connected...
Post by: Sputnik.RU on February 26, 2012, 09:08:27 PM
@Coolmario88cp
As far I'm informed you shouldn't receive a popup notification for streaming updates.
Title: Re: Streaming Updates not connected...
Post by: Gopher John on February 26, 2012, 09:11:05 PM
Connection is back now.. With streaming updates should i get a virus definition has been updated popup also?  If yes, than i only get 3 of the auto update popups a day.. not several but just like 3.

I don't think that we'll see popups for streaming updates, only the regular VPS updates.

@Sputnik.RU
Yes, also just got the first for 120226-3.  I had over 10 for 120226-2.
Title: Re: Streaming Updates not connected...
Post by: reisender on February 26, 2012, 09:37:44 PM
Hi,

the connection to the cloud on my two systems (WIN7-64 and WIN7-32) is very unstable today too. In one minute it is connected at the next it is disconnected for a long period. It connects and disconnects the hole day.

I hope it is only a server overload.

Greetings
Christian
Title: Re: Streaming Updates not connected...
Post by: kev797 on February 26, 2012, 10:17:46 PM
hello, i sometimes get connected and then disconnected and then connected again with the streaming updates, is this as it should be thankyou ?
Title: Re: Streaming Updates not connected...
Post by: Ludiq94 on February 27, 2012, 10:11:40 AM
hello, i sometimes get connected and then disconnected and then connected again with the streaming updates, is this as it should be thankyou ?

I have the same problem. Where is the problem - in Avast's server or in me?
Title: Re: Streaming Updates not connected...
Post by: Orangge on February 27, 2012, 11:44:40 AM
I'm still the same, reinstall Avast and still will not connect, I think it's a problem with Avast servers.
Title: Re: Streaming Updates not connected...
Post by: Jack 1000 on February 27, 2012, 11:51:47 AM
Connection is back now.. With streaming updates should i get a virus definition has been updated popup also?  If yes, than i only get 3 of the auto update popups a day.. not several but just like 3.

From what I understand, the streaming cloud updates are instantaneous and have definitions that stop zero day malware BEFORE the Updated Virus Definitions Signatures "Virus DataBase has been updated." pop up and voice comes.

The pop up with the voice has all the cloud based definitions between the last cloud update and the last pop up.

The cloud is the emergency malware prevention system that always connects to the virus lab to stop threats that may start BEFORE the database has a chance to update with the definition signatures.

Therefore, lets say that it's 2PM and you got the "Virus Database Has Been Updated" message.  Under old Avast versions, if new malware was discovered and a cure was found by the virus lab, you would have to wait till 6PM to get the cure with the next definitions update.

If you have the cloud turned on and suddenly at 2:15PM there's new malware, they could probably get a definitions cure out by 2:30PM  and apply it around the world to all Avast 7 users much faster.  The Avast cloud in version 7, is like the 9-1-1 emergency for malware protection.  You will get everything in the traditional 4 hour slot or maybe later,  But with the cloud you should get it instantly to within minutes, not hours.

Someone can clarify what might be wrong here.  But this is as much as I know in understanding how the Cloud works.  The servers might be overloaded with so much information and with version 7 being so new, that it might take time to get the cloud features in sync with all Avast users.  The goal is for the cloud to communicate and release zero day malware protection up to 20 times a day.

Jack
Title: Re: Streaming Updates not connected...
Post by: reisender on February 27, 2012, 05:14:04 PM
Hello,

my question is: Is it normal, that in one minute the connection is established and in the next it is not established or does the system have to be permanently connected?

Greetings
Christian
Title: Re: Streaming Updates not connected...
Post by: archer1 on February 27, 2012, 06:46:42 PM
I have the problem with streaming update. Connection not established, no cloud services, no updates! I reinstalled Avast but problem not gone. I need help
Title: Re: Streaming Updates not connected...
Post by: Vlk on February 27, 2012, 07:04:44 PM
my question is: Is it normal, that in one minute the connection is established and in the next it is not established or does the system have to be permanently connected?

It may be normal, but it really comes down to the way you're connected to the Internet, whether your router doesn't close connections on which there hasn't been any activity in the last N minutes etc. Generally, avast should try to reconnect relatively soon after it sees the connection closed.
Title: Re: Streaming Updates not connected...
Post by: psikofunkster on February 27, 2012, 07:13:22 PM
I have the problem with streaming update. Connection not established, no cloud services, no updates! I reinstalled Avast but problem not gone. I need help

Not only you.
Title: Re: Streaming Updates not connected...
Post by: Vlk on February 27, 2012, 07:21:26 PM
BTW what does the "Last update received" field on the MAINTENANCE -> UPDATE page of the UI say? (the last line in the "Update engine and virus definitions" section).

Thanks
Vlk
Title: Re: Streaming Updates not connected...
Post by: reisender on February 27, 2012, 07:24:53 PM
Hi Vlk,

the router is not the problem. I have a permanent DSl Line and no connection closed.

Today, for example, I start my PC, Avast says: Connection established, but ca. 45sekonds later I lost the connection.
At this moment I have no connection for ca 30 minutes. The first few days the connection was stable.

In this moment: Last update received: ----
PC is online since 17.00 clock

Greetings
Christian

Title: Re: Streaming Updates not connected...
Post by: Charyb on February 27, 2012, 07:25:45 PM
BTW what does the "Last update received" field on the MAINTENANCE -> UPDATE page of the UI say? (the last line in the "Update engine and virus definitions" section).

Thanks
Vlk

General question or directed toward reisender? Anyway...

See attached
Title: Re: Streaming Updates not connected...
Post by: stevejrc on February 27, 2012, 07:39:30 PM
Do the cloud "reputation services" still work when "Connection not established" is showing ?

If not, could that cause timeouts and system slow downs when executing unknown files ?
Title: Re: Streaming Updates not connected...
Post by: Vlk on February 27, 2012, 07:43:31 PM
Do the cloud "reputation services" still work when "Connection not established" is showing ?


There may (but don't necessarily have to be).


If not, could that cause timeouts and system slow downs when executing unknown files ?

The timeout for FileRep requests is 1 second, so it really depends on what kind of slowdowns you're talking about.
Maybe avast is autosandboxing the files?

Thanks
Vlk
Title: Re: Streaming Updates not connected...
Post by: reisender on February 27, 2012, 07:49:24 PM
Hi,

now (19.44 German time) I have connection.

Greetings
Title: Re: Streaming Updates not connected...
Post by: Vlk on February 27, 2012, 08:39:25 PM
I have been told that some of the servers were having some issues today - the ETA for a fix is tomorrow.
Please check back tomorrow evening, and if the problem isn't resolved please tell us.

Thanks
Vlk
Title: Re: Streaming Updates not connected...
Post by: Jack 1000 on February 27, 2012, 09:59:51 PM
my question is: Is it normal, that in one minute the connection is established and in the next it is not established or does the system have to be permanently connected?

It may be normal, but it really comes down to the way you're connected to the Internet, whether your router doesn't close connections on which there hasn't been any activity in the last N minutes etc. Generally, avast should try to reconnect relatively soon after it sees the connection closed.

Would Avast Cloud Services not work, or not work very well, using a dial up modem?

Jack
Title: Re: Streaming Updates not connected...
Post by: Vlk on February 27, 2012, 10:08:44 PM

Would Avast Cloud Services not work, or not work very well, using a dial up modem?

Jack

As the bandwidth usage is pretty low, there shouldn't be any problems on dial-up.

Thanks
Vlk
Title: Re: Streaming Updates not connected...
Post by: happy avast user on February 27, 2012, 10:11:01 PM
Hello all,

I am also having problems with Cloud Services, Reputation Services ENABLED, Streaming Updates ENABLED.

I went to Maintenance update and then it says Streaming Updates Enabled under that it says Connection  Connection NOT ESTABLISHED

Glad I am not the only one with this problem. I DO HOPE this problem and issue will be resolved soon.

happy avast user :)

Title: Re: Streaming Updates not connected...
Post by: ZbynekS on February 28, 2012, 04:52:23 PM
Hi,

Some information on our cloud update servers performance: After releasing Avast7 several hundreds of small update packages had accumulated in the update repository and got ready for being pushed to clients. However, once the clients began connecting to the cloud they attempted to receive all update packages at once. It caused some performance problems on the cloud infrastructure and some clients couldn't either connect to the cloud or get updates. Therefore we've made some optimization of load balancing and tuned the distribution strategy. It seems now that the clients should able to connect to the cloud and get updates much easier.

Regards

Zbynek
Avast Cloud developer
Title: Re: Streaming Updates not connected...
Post by: selen on February 28, 2012, 05:22:55 PM
Hi,

Some information on our cloud update servers performance: After releasing Avast7 several hundreds of small update packages had accumulated in the update repository and got ready for being pushed to clients. However, once the clients began connecting to the cloud they attempted to receive all update packages at once. It caused some performance problems on the cloud infrastructure and some clients couldn't either connect to the cloud or get updates. Therefore we've made some optimization of load balancing and tuned the distribution strategy. It seems now that the clients should able to connect to the cloud and get updates much easier.

Regards

Zbynek
Avast Cloud developer

now I receive streaming updates after lot of days of no-working updates. Thanks :)
Title: Re: Streaming Updates not connected...
Post by: reisender on February 28, 2012, 06:02:39 PM
I have been told that some of the servers were having some issues today - the ETA for a fix is tomorrow.
Please check back tomorrow evening, and if the problem isn't resolved please tell us.

Thanks
Vlk

Hello,

The connection is unfortunately still unstable.
Systemstart at 17.00: Connection OK, control at 17.50 o'clock: No connection (see attatchmend) :(
But the the connection keeps longer and the reconnection to the server is faster than yesterday. :)

Greetings
Christian
Title: Re: Streaming Updates not connected...
Post by: selen on February 28, 2012, 06:07:41 PM
I have been told that some of the servers were having some issues today - the ETA for a fix is tomorrow.
Please check back tomorrow evening, and if the problem isn't resolved please tell us.

Thanks
Vlk

Hello,

The connection is unfortunately still unstable.
Systemstart at 17.00: Connection OK, control at 17.50 o'clock: No connection (see attatchmend) :(
But the the connection keeps longer and the reconnection to the server is faster than yesterday. :)

Greetings
Christian

Unfortunatly you're right, I have lost the connection about 5 minutes ago and it doesn't reconnect...
Title: Re: Streaming Updates not connected...
Post by: Orangge on February 28, 2012, 06:50:18 PM
In my case unstable, it connects minutes and then switched off again and so on.
Title: Re: Streaming Updates not connected...
Post by: boombastik on February 28, 2012, 07:04:05 PM
Here in greece it works very well today. Every time i checked the programme, i was with conection established and also i take several staming updates.
Title: Re: Streaming Updates not connected...
Post by: isobarman on February 28, 2012, 07:51:09 PM
I'm new to Avast Internet Security 7 and having troubles with both manual and automatic virus updating on my XP box.  The Window 7 laptop seems to be fine however?  Any ideas on what to do to get the updates working???
Title: Re: Streaming Updates not connected...
Post by: Charyb on February 28, 2012, 08:15:12 PM
I'm new to Avast Internet Security 7 and having troubles with both manual and automatic virus updating on my XP box.  The Window 7 laptop seems to be fine however?  Any ideas on what to do to get the updates working???
You could try the fix utility:

IMPORTANT! Fix utility for corrupted avast! v6/v7 installations
http://forum.avast.com/index.php?topic=94514.0
Title: Re: Streaming Updates not connected...
Post by: isobarman on February 28, 2012, 08:57:52 PM
Charyb,

Thanks I'll try it!
Title: Re: Streaming Updates not connected...
Post by: Orangge on February 29, 2012, 01:36:08 AM
Now it seems to be going well, not disconnected for several hours, just need to get an Update Streaming, where it says "Last update received" is so far empty.
Title: Re: Streaming Updates not connected...
Post by: skay_baltimore on February 29, 2012, 01:39:50 AM
I "bit the bullet" and updated avast 6 to avast 7, after having gotten caught up in the mess a couple of night ago and doing a total uninstall/reinstall of avast 6. No problems; no hangs during the update process. Everything is working, including the streaming updates and the ability to open the program in Add/Remove programs, which was generating errors before the uninstall/reinstall. It took a while (I did the upgrade several hours ago) and it's now showing that an update was received 6:17 pm (it's now 7:38 pm here).
Title: Re: Streaming Updates not connected...
Post by: Orangge on February 29, 2012, 06:07:44 PM
In my case all fixed, connected and receive updates.
Title: Re: Streaming Updates not connected...
Post by: reisender on February 29, 2012, 06:12:58 PM
In my case all fixed, connected and receive updates.

+1

Greetings
Christian
Title: Re: Streaming Updates not connected...
Post by: nigel mansel on March 03, 2012, 01:43:24 PM
No streaming update here recently last one was 25th feb.

It does say enabled and connection established.

Any thoughts  :)
Title: Re: Streaming Updates not connected...
Post by: True Indian on March 03, 2012, 01:48:48 PM
No streaming update here recently last one was 25th feb.

It does say enabled and connection established.

Any thoughts  :)


do a repair via control panel and reboot and check again. :)
Title: Re: Streaming Updates not connected...
Post by: Lisandro on March 03, 2012, 02:22:48 PM
No streaming update here recently last one was 25th feb.

It does say enabled and connection established.

Any thoughts  :)
Are you using the latest 7.0.1414 version?
Title: Re: Streaming Updates not connected...
Post by: nigel mansel on March 03, 2012, 03:34:33 PM
No its 7.0.1407.

I have tried manually updating the program but it says there is no update.

Is the 1414 still in Beta ?

If so might wait for a little while as its working fine otherwise.
Title: Re: Streaming Updates not connected...
Post by: DavidR on March 03, 2012, 03:51:44 PM
Yes 7.0.1414 is the beta build which is in testing.
Title: Re: Streaming Updates not connected...
Post by: nigel mansel on March 03, 2012, 05:55:12 PM
Upgraded with the new Beta David and its working great  8)

Streaming has updated 3 times already  :)

Keep up the good work chaps.
Title: Re: Streaming Updates not connected...
Post by: reisender on March 04, 2012, 10:26:58 PM
Hi,

for me the connection problem seems to be back.
No cloud connection and no streaming update the whole day :(

Definition updates are working normal.
I am using Avast free 7.0.1414

Greetings
Christian
Title: Re: Streaming Updates not connected...
Post by: selen on March 04, 2012, 10:37:52 PM
Hi,

for me the connection problem seems to be back.
No cloud connection and no streaming update the whole day :(

Definition updates are working normal.
I am using Avast free 7.0.1414

Greetings
Christian

I'm in your same situation again, no connection since 4 hours. I use avast 7.0.1407
Title: Re: Streaming Updates not connected...
Post by: nigel mansel on March 04, 2012, 10:40:59 PM
 :( same here,lost streaming updates today,connection not established.

The streaming folder is missing in the program !
Title: Re: Streaming Updates not connected...
Post by: happy avast user on March 04, 2012, 11:27:16 PM
+1 NO streaming updates or connection at all CONNECTION NOT ESTABLISHED :( :(
Title: Re: Streaming Updates not connected...
Post by: Tigerlad on March 05, 2012, 10:05:31 AM
Am having the same problem for last few days. Running Avast Internet Security ver 7.01.1407 and cloud services worked fine initially. Now see that CONNECTION NOT ESTABLISHED all the time. Have tried repair and run latest fix but still no joy. Bought and installed Avast because of excellent reviews but am concerned that version 7 appears unstable.
Title: Re: Streaming Updates not connected...
Post by: Asyn on March 05, 2012, 10:12:01 AM
Running Avast Internet Security ver 7.01.1407 and cloud services worked fine initially. Now see that CONNECTION NOT ESTABLISHED all the time. Have tried repair and run latest fix but still no joy.

Don't worry, if you see that it's most likely just a server issue. You are still safe though..!!
Also at disconnected here right now, guess they're working on the server infrastructure. ;)
Title: Re: Streaming Updates not connected...
Post by: ralf123 on March 05, 2012, 10:17:43 AM
last defs is 120304-0  ????

grazie
Title: Re: Streaming Updates not connected...
Post by: Asyn on March 05, 2012, 10:20:33 AM
last defs is 120304-0  ????

grazie

120304-1 is the latest, but that's not related to stream updates..!! ;)
Title: Re: Streaming Updates not connected...
Post by: nigel mansel on March 05, 2012, 12:47:01 PM
 ;D streaming decided to work today  :)
Title: Re: Streaming Updates not connected...
Post by: selen on March 05, 2012, 01:30:49 PM
;D streaming decided to work today  :)
I confirm :) today it works good
Title: Re: Streaming Updates not connected...
Post by: avast_155995 on April 28, 2012, 12:07:50 PM
Hi!
If this is not a server error, this is likely to be because you haven't set virus definitions and programs to "Automatic Update". Streaming Updates only works when virus def is automatically updated.
Title: Re: Streaming Updates not connected...
Post by: DavidR on April 28, 2012, 01:38:31 PM
You don't have to have the Program Update set to Auto (Ask is the default action), only the Virus Definitions have to be on Auto (also the default).
Title: Re: Streaming Updates not connected...
Post by: RejZoR on April 28, 2012, 11:39:52 PM
Cloud is again not connected most of the time. Not cool.
Title: Re: Streaming Updates not connected...
Post by: DavidR on April 29, 2012, 12:46:46 AM
I must admit I haven't noticed any problems with mine. I'm finding the streaming updates are happening within a minute or so of switching on my system.

If anything, I don't want that as I have set my regular auto-update delayed for 10 minutes after boot and the streaming updates ignore the AlwaysConnectedWaitSeconds avast5.ini setting.
Title: Re: Streaming Updates not connected...
Post by: HS2234 on April 29, 2012, 04:03:03 AM
It stopped workinng for me..
Title: Re: Streaming Updates not connected...
Post by: RejZoR on April 29, 2012, 07:17:08 AM
Laptop won't even connect to cloud for a day. If i reboot system, it will connect sometimes but then it just goes off again. Weird and not cool.
Same problem was soon after launch...