Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Engineeringtech on May 28, 2012, 11:57:52 PM

Title: "entry point freeaddrinfo could not be located in... WS2_32.DLL"
Post by: Engineeringtech on May 28, 2012, 11:57:52 PM
I was looking for a new anti-virus program for an old machine.   I installed Avast! 6.0.1270 (free) on an Windows 2K Pro SP4 machine, thinking if I liked it, I might buy the pro version.   The program installed ok, but does not work.  I'm getting the error message, "The procedure entry point freeaddrinfo could not be located in the dynamic link library WS2_32.DLL."   

I am not a software expert what do I have to do to resolve this and start using Avast!?
Title: Re: "entry point freeaddrinfo could not be located in... WS2_32.DLL"
Post by: Kwartet! on May 29, 2012, 06:58:04 AM
Hi Engineeringtech,

Avast 6.x is not compatible with Win2000.

Freeaddrinfo has been added to ws2_32.dll in windows xp. According to google ("freeaddrinfo could not be located") you might solve this dll-problem by having avast recompile their product with just another header file, or by copying a newer ws2_32.dll to avast's program directory. But I am rather sure that even if you succeed, many more incompatibilities would show up on Win2000.

You could use avast 5.x though, see
https://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=455#idt_01

Regards
Title: Re: "entry point freeaddrinfo could not be located in... WS2_32.DLL"
Post by: INGBEAN on May 29, 2012, 08:46:48 AM
Hello Engineeringtech!

First of all: Welcome to the forum.

Why do you install a BETA version of avast! 6? This bug is already solved for a long time.
Just take a look to this topic:
http://forum.avast.com/index.php?topic=83583.msg682776#msg682776

So if you really want to install version 6, then please take the latest official release (V6.0.1367).
Or you use the latest version (V7.0.1426).
More information: http://www.avast.com/release-history

I am working with avast! on 2 PC's with Windows 2000.
You must install Service Pack 4 and Update Rollup 1 before installing avast!.
I use avast! V7 Free on one PC, the other has avast! V6 Free (but I will update as soon as possible).
And BOTH PC's are working without problems. So I recommend to install avast! V7.

Just for information: You can use avast! Free or Pro, but the "Internet Security" is incompatible with Win2k (due to a firewall driver).

Forget this:
Avast 6.x is not compatible with Win2000.

Have a nice day!

INGBEAN