Author Topic: Not able to protect outgoing mail  (Read 17694 times)

0 Members and 1 Guest are viewing this topic.

Offline plangway

  • Newbie
  • *
  • Posts: 5
Not able to protect outgoing mail
« on: October 24, 2003, 12:46:46 PM »
I'm getting Error: 10048 which states "Not able to protect Outgoing mail (SMTP Protocol). Port 25 is already in use, specify another port value

I'm using Outlook 2000 on Windows 2000 Prof operating system. I did a netstat -an and port 25 shows in listening mode, not open??

Can you give me any suggestions?

Paul L.

Offline whocares

  • Super Poster
  • ***
  • Posts: 1698
  • I'm not a llama! :-)
« Last Edit: October 24, 2003, 12:59:14 PM by whocares »

Offline plangway

  • Newbie
  • *
  • Posts: 5
Re:Not able to protect outgoing mail
« Reply #2 on: October 24, 2003, 01:20:10 PM »
I can send e-mails with attachments no problem. I looked at both the reference post, but could not find a solution. Port 25 appears to be in listening mode, but Avast is reporting that it is in use?

Paul L.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11805
    • AVAST Software
Re:Not able to protect outgoing mail
« Reply #3 on: October 24, 2003, 01:23:21 PM »
I may be wrong, but when it is in listening mode, doesn't it mean that it actutally is in use? (i.e. some other program is listening there)?
Or are you sure that it's avast that is listening?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Not able to protect outgoing mail
« Reply #4 on: October 24, 2003, 01:26:51 PM »
If you use Outlook 2K there is no need to use the Internet Mail plugin at all. Please see e.g. http://www.avast.com/forum/index.php?board=2;action=display;threadid=1441#msg8414 for details.
If at first you don't succeed, then skydiving's not for you.

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:Not able to protect outgoing mail
« Reply #5 on: October 24, 2003, 02:00:04 PM »
You can disable the Internet Mail scanner if you use only Outlook 2000: start the Mail Protection Wizard (menu Start->Programs->avast! Antivirus) and choose to remove protection. The Outlook protection will remain active and the warning will not be displayed.

Offline plangway

  • Newbie
  • *
  • Posts: 5
Re:Not able to protect outgoing mail
« Reply #6 on: October 26, 2003, 06:22:40 PM »
I disabled internet mail in avast, but I'm still receiving the following error meesage upone start up of win 2000 Prof:


"Avast will not be able to protect outgoing mail (SMTP protocol) Error 10048. Port 25 is already in use, specifiy another port value (see section Cooperation with other software in manual setting of mail protection in help)'

I'm using Outlook 2000 and have run the avast mail wizard. I also ran a port scan on my desktop and Port 25 does not indicate being open. In addition, I disabled "Internet Mail" in avast.

Can anyone give me a clue as to why this message is coming up?

Thank You,

plangway

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Not able to protect outgoing mail
« Reply #7 on: October 26, 2003, 06:30:30 PM »
You need to start the avast Mail Protection Wizard (in the avast group in the Start Menu) and select 'Remove the protection'.

Your Outlook 2K will still be protected.

Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re:Not able to protect outgoing mail
« Reply #8 on: October 27, 2003, 01:27:53 AM »
You need to start the avast Mail Protection Wizard (in the avast group in the Start Menu) and select 'Remove the protection'.

Your Outlook 2K will still be protected.

Vlk

I cannot believe the user must choose between Outlook 2k and Outlook Express (Internet Mail)  >:(
And what happens if the user want to use both?  ::)
I think that must be another solution  :(
The best things in life are free.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Not able to protect outgoing mail
« Reply #9 on: October 27, 2003, 08:08:25 AM »
Quote
I cannot believe the user must choose between Outlook 2k and Outlook Express (Internet Mail)  
And what happens if the user want to use both?  
I think that must be another solution  


Of course it works together, it's just that on plangways' computer the Internet Mail module cannot work without reconfiguration because some other program is already listening on port 25 (i.e. plangway already has a similar program installed on the machie).

Since plangway is only using Outlook 2000 to access his mail, I suggested to prevent the Internet Mail module at all (since it's unnecessary in his Outlook-only scenario, anyway). If he was using some other e-mail client, I'd suggest reconfiguring the SMTP ports of the Internet Mail module instead...

I hope this makes things clearer.

Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re:Not able to protect outgoing mail
« Reply #10 on: October 27, 2003, 01:42:05 PM »
I hope this makes things clearer.
Vlk

For me, complete clear. Thanks Vlk.
Btw, could you tell us the range for port numbers, I mean, what is the range (from... to...) the user can set for listening ports to use Internet Mail...
Remember I am stupid in these questions...  ;)
« Last Edit: October 31, 2003, 01:46:17 AM by Technical »
The best things in life are free.

Offline plangway

  • Newbie
  • *
  • Posts: 5
Re:Not able to protect outgoing mail
« Reply #11 on: October 30, 2003, 12:58:55 PM »
As far as I can tell there is no other internet mail module open on my computer. I checked all process in task manager and ran the following Netstat report:

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:21             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:25             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:443            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1025           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1026           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1028           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1036           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1099           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1101           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:1107           0.0.0.0:0              LISTENING
  TCP    127.0.0.1:110          0.0.0.0:0              LISTENING
  TCP    127.0.0.1:143          0.0.0.0:0              LISTENING
  TCP    127.0.0.1:1028         127.0.0.1:1258         TIME_WAIT
  TCP    127.0.0.1:1028         127.0.0.1:1261         TIME_WAIT
  TCP    192.168.2.3:139        0.0.0.0:0              LISTENING
  TCP    192.168.2.3:1099       80.15.249.120:80       CLOSE_WAIT
  TCP    192.168.2.3:1101       80.15.249.118:80       CLOSE_WAIT
  TCP    192.168.2.3:1107       209.51.177.40:443      CLOSE_WAIT
  UDP    0.0.0.0:135            *:*
  UDP    0.0.0.0:445            *:*
  UDP    0.0.0.0:1035           *:*
  UDP    0.0.0.0:3456           *:*
  UDP    192.168.2.3:137        *:*
  UDP    192.168.2.3:138        *:*
  UDP    192.168.2.3:500        *:*
  UDP    192.168.2.3:4500       *:*
  UDP    192.168.2.3:17985      *:*

The only thing I see above is port 25 in listening mode?

plangway

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:Not able to protect outgoing mail
« Reply #12 on: October 30, 2003, 01:32:12 PM »
You can use tcpview to find out what program is listening on which port.

http://www.sysinternals.com/ntw2k/source/tcpview.shtml

Offline Hornus Continuum

  • Full Member
  • ***
  • Posts: 119
  • If you only remember one thing, it's this ...
Re:Not able to protect outgoing mail
« Reply #13 on: October 30, 2003, 01:32:56 PM »
plangway,

Use the command netstat -ano to add the process IDs to the output list.  Then use Task Manager to identify the process that is listening on port 25.

Regards,
Hornus

"Quote me as saying I was misquoted." -- Groucho Marx  ;D

Offline plangway

  • Newbie
  • *
  • Posts: 5
Re:Not able to protect outgoing mail
« Reply #14 on: October 30, 2003, 01:59:38 PM »
Thanks to all that made suggestions. I ran TCPView and found Inetinfo.exe was running as a service using port 25. I disabled it and Avast appears to know be protecting my outgoing mail

Thanks again

plangway