Author Topic: Complete your avast! software update?  (Read 26525 times)

0 Members and 1 Guest are viewing this topic.

Offline MaggieQ

  • Newbie
  • *
  • Posts: 1
Complete your avast! software update?
« on: July 04, 2012, 01:45:55 PM »
OK

So not a big problem, but this is getting annoying. Avast just updated software, but never finishes.

I keep getting the "Complete your avast! software update" popup at computer start up.


Even when I click finish, it will popup again at start up.

--avast! Free Antivirus--
7.0.1456


EDIT:

Well this problem seems to have fixed it's self for me.

What I did was hit the update button couple of times.

-------------------------------------------------------------


Then restarted pc, hit update restarted, etc. Popup seems to be gone now for me.
« Last Edit: July 05, 2012, 03:12:31 PM by MaggieQ »

Offline IvanM

  • Avast team
  • Jr. Member
  • *
  • Posts: 55
  • QA
    • Avast Software a.s.
Re: Complete your avast! software update?
« Reply #1 on: July 04, 2012, 01:49:29 PM »
Hello MaggieQ,
does it occur on every system start? This screen should show only after 1st restart.
If so, give me please more information about your system and computer.

Thank you,
Ivan.

Offline vab220

  • Newbie
  • *
  • Posts: 2
Re: Complete your avast! software update?
« Reply #2 on: July 04, 2012, 02:03:06 PM »
I've got the same issue, along with the "your software is about to expire/renew now" popup appearing every hour or so.
I've updated the license, "inserted"  the license file twice now, but I'm still getting the popup and I can't update my files.
HELP!

Offline kd5

  • Jr. Member
  • **
  • Posts: 95
  • Computer Geek
Re: Complete your avast! software update?
« Reply #3 on: July 04, 2012, 02:09:49 PM »
I was starting to wonder how many times I had to install 1451 before Avast! finally acknowledged that it's installed???  My wife & I got the same "Complete your Avast! software update" prompts this morning as well (Windows XP SP3).  Weird thing is.....I'd already manually installed 1451 on both our computers several days ago!  Unchecked Google Chrome, clicked Finish, then restarted our computers, and the "Complete the update" box popped up AGAIN!  Checked Avast! program status and 1451 was showing in red.  Decided to manually check for an update on my computer again, this time 1456 downloaded, installed, then prompted me to reboot, which I did.  Got the "Complete your update" box, unchecked Google Chrome again, clicked Finish, rebooted, everything appears to be back to normal on my computer now.  Apparently I'll have to do the same on my wife's computer or she'll just get that same "Complete your update" box every time she starts her computer even though technically, nothing's been updated yet.... ::)       -kd5-

« Last Edit: July 04, 2012, 02:21:42 PM by kd5 »
Getting old ain't for sissys.

Offline RazorLan

  • Newbie
  • *
  • Posts: 13
Re: Complete your avast! software update?
« Reply #4 on: July 04, 2012, 02:22:39 PM »
I have the identical problem.  I uncheck the box for "install Google Chrome" and click finish.  Then on every single restart of my computer, the box pops up again.  I even went into Avast and told it to check for updates this morning.  It did no good.  The problem still exists.  How do we fix it?  We should not be required to install Google Chrome if we do not want to in order to make this work properly.  This is quickly turning from "annoying" to "annoying spam."

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11678
    • AVAST Software
Re: Complete your avast! software update?
« Reply #5 on: July 04, 2012, 02:29:20 PM »
Weird... is avast! service (AvastSvc.exe) running?

Offline RazorLan

  • Newbie
  • *
  • Posts: 13
Re: Complete your avast! software update?
« Reply #6 on: July 04, 2012, 02:39:38 PM »
I checked in the Windows Task Manager for the running programs, and that program (AvastSvc.exe) is running.  The program seems to be running normally except that the "finish" window with the Google Chrome option, which I do not want and keep opting out of, will not stop coming back.  Current version in the program is listed as 7.0.1456.
« Last Edit: July 04, 2012, 02:42:07 PM by RazorLan »

Offline RazorLan

  • Newbie
  • *
  • Posts: 13
Re: Complete your avast! software update?
« Reply #7 on: July 04, 2012, 02:58:32 PM »
I restarted my computer moments ago to test for the problem.  The problem did not repeat itself this time, but my Windows profile did take significantly longer to finish loading up this time than it did the other times.  My current hypothesis is that perhaps something failed to finish properly the other times which, for whatever reason, did finish this time.

Offline unfair.cece.it

  • Newbie
  • *
  • Posts: 9
Re: Complete your avast! software update?
« Reply #8 on: July 04, 2012, 03:45:36 PM »
i reboot now to test ...
after update reboot i got no popup
after 2nd reboot i got popup .. now  i go for 3rd reboot

edit: 3rd and 4th reboot ok , no popup
« Last Edit: July 04, 2012, 04:40:42 PM by unfair.cece.it »

Offline RazorLan

  • Newbie
  • *
  • Posts: 13
Re: Complete your avast! software update?
« Reply #9 on: July 04, 2012, 04:06:39 PM »
hmmm, so much for my theory.   :-\  So, if its intermittent, I imagine it will eventually pop up again at some point until this version is patched again to a newer one.

Offline StudioKraft

  • Newbie
  • *
  • Posts: 1
Re: Complete your avast! software update?
« Reply #10 on: July 04, 2012, 04:29:20 PM »
Hello all,

Just wanted to add to the list of people who are experiencing this intermittent issue of the "Finish" window appearing at boot.  I have Windows 7, and already have Chrome installed so I suppose that is why I am not seeing that part of the window about installing Chrome, but the window will appear on every other boot or so. 

I ran the program update from the avast! taskbar icon again, and it downloaded the program and appeared to install it, but the "Finish" window I received was the same as before, with the same release notes.  It seems like the latest version of the avast! program doesn't know it is the latest version and doesn't know that the installation has been completed (registry key not being cleared?)


Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2081
Re: Complete your avast! software update?
« Reply #11 on: July 04, 2012, 04:36:01 PM »
Can you please, who has still this problem, send me (kurtin@avast.com) your avast5.ini and behavshield log file, thanks.

Offline demonperformer

  • Newbie
  • *
  • Posts: 9
Re: Complete your avast! software update?
« Reply #12 on: July 04, 2012, 06:10:01 PM »
pk
yes I still have this problem - running on Windows 7 avast v7.0.1451.402, I cannot see AvastSvc.exe in the process list, only AvastUI.exe.
did a search for the two files, but they do not come up on the search.  can you provide a path so I can find them manually then i will send them to you.
thanks

Offline demonperformer

  • Newbie
  • *
  • Posts: 9
Re: Complete your avast! software update?
« Reply #13 on: July 04, 2012, 07:55:50 PM »
Actually, having read this thread properly, I have now updated to version 1456, and it seems to have solved the problem ....  so far:)

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2094
Re: Complete your avast! software update?
« Reply #14 on: July 04, 2012, 08:23:42 PM »
I had Avast Free 7.0.1451 installed.  I read on the forum about v7.0.1456 being available, so checked the AvastUI to verify that it showed there and it did.  Without triggering the update, I restarted Windows and logged into my Admin account.  When Windows came up, I was greeted with the same Avast requester that MaggieQ shows in the first post.  I don' know why as no update was attempted.  I clicked thru that after deselecting the Google Chrome options.  AvastUI was still showing 7.0.1451 as the current version, and that the update to 7.0.1456 was available.  To be safe, I restarted Windows again, and was not shown the "Complete update" requester on restart.  I then triggered the update, and restarted when it was requested.

The "Complete undate" requester came up one last time on restart and hasn't appeared since.  What triggered the first "Complete update" requester for me.  Avast did update properly when triggered, all settings were preserved, and Avast is running fine.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: AIS 19.6.2383, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68, MBam Free, MCShield, CCleaner