Author Topic: SSL/TLS connection detected!  (Read 81712 times)

0 Members and 1 Guest are viewing this topic.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: SSL/TLS connection detected!
« Reply #15 on: August 10, 2012, 11:43:29 AM »
/etc/hosts is the full path of the file. The directory is /etc. To get the content, simpy write
Code: [Select]
cat /etc/hosts into the Terminal.

Offline Stephen Scheaffer

  • Newbie
  • *
  • Posts: 6
Re: SSL/TLS connection detected!
« Reply #16 on: August 10, 2012, 04:46:04 PM »
/etc/hosts is the full path of the file. The directory is /etc. To get the content, simpy write
Code: [Select]
cat /etc/hosts into the Terminal.

is the space after cat correct? this was returned:

127.0.0.1   localhost
255.255.255.255   broadcasthost
::1   localhost
fe80::1%lo0   localhost
173.194.68.109   imap.gmail.com   # Added by avast!
173.194.68.108   imap.gmail.com   # Added by avast!
2001:4860:800a::6c   imap.gmail.com   # Added by avast!
173.194.68.109   pop.gmail.com   # Added by avast!
173.194.68.108   pop.gmail.com   # Added by avast!
2001:4860:800a::6c   pop.gmail.com   # Added by avast!

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: SSL/TLS connection detected!
« Reply #17 on: August 14, 2012, 09:12:35 AM »
You really do use both protocols (POP3 & IMAP) on gmail? If not, delete either all the pop.gmail.com or all the imap.gmail.com entries and it will start working. Otherwise it won't be possible to use the mailshield in this configuration due to technical limitations.

Offline Stephen Scheaffer

  • Newbie
  • *
  • Posts: 6
Re: SSL/TLS connection detected!
« Reply #18 on: August 14, 2012, 01:19:54 PM »
You really do use both protocols (POP3 & IMAP) on gmail? If not, delete either all the pop.gmail.com or all the imap.gmail.com entries and it will start working. Otherwise it won't be possible to use the mailshield in this configuration due to technical limitations.

Actually I do. I won't go into why but the reasons were valid years ago. I may rethink this. Thanks for all your probing.

Steve

Offline LeSpace

  • Newbie
  • *
  • Posts: 14
Re: SSL/TLS connection detected!
« Reply #19 on: August 25, 2012, 02:29:19 AM »
I have the red message for certificates...

My log :
Aug 25 02:21:48 wn2000rptv2.home proxy[757]: Certificate verification failed: SSL_get_verify_result(): unable to get local issuer certificate

My hosts :
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1   localhost
255.255.255.255   broadcasthost
::1   localhost
fe80::1%lo0   localhost
65.55.162.199   pop3.live.com   # Added by avast!
17.158.10.200   p03-imap.mail.me.com   # Added by avast!

When i follow your instruction for certificates on the system keychain, when i click on the "+", there is a box ask me to choose a file. Which file ??

thx

Offline rfwolf

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #20 on: August 31, 2012, 01:42:54 AM »
On the Mac, this method works with the Mail application, but not with Sparrow. I cannot get Sparrow to connect to gmail with the SSL turned off. Will there ever be a fix for this from Avast?

Offline alexclopes73

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #21 on: August 31, 2012, 03:11:02 PM »
Hi,

I have the same problem with RED messages of avast.

I did all procedures given :

- Move the Gmail's and Hotmail certificades to system in keychain
- I disable SSL in Apple Mail client to all accounts
- I  add is the value of the "Incoming Mail Server" field on the "Account Information"in Mail Shield of Avast (see below )

But the RED message foi GMAIL doesn't stop.

How do I proceed ?

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1   localhost
255.255.255.255   broadcasthost
::1   localhost
fe80::1%lo0   localhost
74.125.45.109   imap.gmail.com   # Added by avast!
74.125.45.108   imap.gmail.com   # Added by avast!
2607:f8b0:400c:c03::6c   imap.gmail.com   # Added by avast!
65.55.172.253   pop3.live.com   # Added by avast!




Offline sammanjac

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #22 on: September 05, 2012, 09:48:12 AM »
Same problem for me and its taking hectic time for me and overall i have disable mail shield

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: SSL/TLS connection detected!
« Reply #23 on: September 05, 2012, 10:33:17 PM »
The certificate check is broken in the legacy 0.9.7 openssl library (we use it to be Mac OS X 10.5 compatible) on Mac OS 10.8. We are working on a workaround/fix of the issue which will be soon available.

Offline GMoGH

  • Newbie
  • *
  • Posts: 2
Re: SSL/TLS connection detected!
« Reply #24 on: September 07, 2012, 11:52:38 PM »
I had the "SSL certificate check failed" error for imap.gmail.com and here is what I did to fix the problem. I removed the entries for imap.gmail.com, and I restarted the service by unchecking and then rechecking the box for Mail Shield. In my mail client, mac mail, I unchecked "Use SSL" on the advanced tab of the email account settings and that's it. It worked fine after those changes. To be clear, in avast preferences, mail shield, advanced, SSL, the box is empty, nothing listed and gmail works correctly now.

If people are uncomfortable with that option, I tested another option with gmail.com in the SSL tab of avast preferences and it works great. This is probably a better solution since the developers want something listed but I wanted to present both incase one option did not work for someone.

Offline haros

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #25 on: September 08, 2012, 02:40:52 AM »
Hi Tumic,

I have disabled SSL in my Mail 6.0 client but cannot enable it in avast. When I go to the SSL tab in my avast preferences, the "+" and "-" buttons are greyed out and cannot be clicked. Please see screen shot below.



What's the deal and how do I fix it? It is a Gmail account if that helps.

Cheers,
Haros

Offline LeSpace

  • Newbie
  • *
  • Posts: 14
Re: SSL/TLS connection detected!
« Reply #26 on: September 08, 2012, 11:42:36 AM »
Hi Tumic,

I have disabled SSL in my Mail 6.0 client but cannot enable it in avast. When I go to the SSL tab in my avast preferences, the "+" and "-" buttons are greyed out and cannot be clicked. Please see screen shot below.

What's the deal and how do I fix it? It is a Gmail account if that helps.

Cheers,
Haros
^^

You must to enter your admin password of your Mac. Look you can see in the background of your picture a padlock in the bottom right. Click on it.  ;D

Offline swandy

  • Newbie
  • *
  • Posts: 4
Re: SSL/TLS connection detected!
« Reply #27 on: September 10, 2012, 03:35:45 PM »
I have been trying to follow this thread but I am using the installed Mail and iCloud as my mail server for my email and whenever I uncheck the SSL box in the preferences, I get a message that I need to enter an incoming mail server.
And reading on Apple's website it states that to use iCloud for emails you MUST enable SSL. So what - if any - is the solution to the SSL pop-up warnings???
Thanks,

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: SSL/TLS connection detected!
« Reply #28 on: September 13, 2012, 06:09:14 PM »
If you configure the mailshield correctly, you will connect using SSL to the iCloud server.

If your setup is the one described here: http://support.apple.com/kb/HT4864, but with the SSL box unchecked, Apple Mail does not allow You to close the configuration dialogue?

Offline swandy

  • Newbie
  • *
  • Posts: 4
Re: SSL/TLS connection detected!
« Reply #29 on: September 14, 2012, 02:13:19 AM »
If you configure the mailshield correctly, you will connect using SSL to the iCloud server.

If your setup is the one described here: http://support.apple.com/kb/HT4864, but with the SSL box unchecked, Apple Mail does not allow You to close the configuration dialogue?

Correct. If I leave the SSL box unchecked and try to save the settings, I get a message that the "incoming mail server box" cannot be left empty. It is not actually empty, but it is greyed out - I guess because it is set up that way automatically when you set up the Mac using iCloud.