Author Topic: SSL/TLS connection detected!  (Read 91005 times)

0 Members and 1 Guest are viewing this topic.

Offline mwg2

  • Newbie
  • *
  • Posts: 7
Re: SSL/TLS connection detected!
« Reply #75 on: January 25, 2013, 02:46:01 AM »
Thank you kind sir.  I appreciate you offering some assistance.  I think I am out of luck until Avast allows password input associated with the Mail Shield SSL table. 

Offline andy5501

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #76 on: January 25, 2013, 01:29:24 PM »
I am with White-Note, reply #44

Fresh 10.8.2 and Office2011, using Outlook. My mail server does NOT use SSL, and the shield was already active in Avast, yet I got these annoying pop-ups. So I disabled the shield in Avast, and within seconds I received all mails that were queued up in the mail server.

Hope to get information when there is an update on Avast that fixes this.

Offline mwg2

  • Newbie
  • *
  • Posts: 7
Re: SSL/TLS connection detected!
« Reply #77 on: January 25, 2013, 11:31:07 PM »
To the Moderators:  Do any of you happen to know how to send an email to Avast developers?  I think they should know about the GMAIL IMAP application specific password requirement (for those of us that use Gmail two-factor authentication.)  The fix should be relatively easy:  Just allow an optional input area on the SSL Table to add an IMAP specific password to be associated with the Mail Shield Proxy.   

Thanks so much!   

Offline specimen9999

  • Sr. Member
  • ****
  • Posts: 349
Re: SSL/TLS connection detected!
« Reply #78 on: January 26, 2013, 12:37:11 AM »
To the Moderators:  Do any of you happen to know how to send an email to Avast developers?  I think they should know about the GMAIL IMAP application specific password requirement (for those of us that use Gmail two-factor authentication.)  The fix should be relatively easy:  Just allow an optional input area on the SSL Table to add an IMAP specific password to be associated with the Mail Shield Proxy.   

Thanks so much!

I think you should try the Beta announced on this forum.
Most likely they won't 'fix' it, in the new beta this works in a completely different way exactly to avoid these and other problems.

Offline allanrisk

  • Newbie
  • *
  • Posts: 2
Re: SSL/TLS connection detected!
« Reply #79 on: January 26, 2013, 03:35:15 PM »
Whenever I try to add my gmail imap server, I get the attached message:

Offline allanrisk

  • Newbie
  • *
  • Posts: 2
Re: SSL/TLS connection detected!
« Reply #80 on: January 26, 2013, 03:46:46 PM »
Whenever I try to add my gmail imap server, I get the attached message:

Sorry - didn't see that this very problem had been posted earlier ... I'd delete my original post if I knew how ...  :-[

Offline Phimple

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #81 on: January 28, 2013, 09:50:03 AM »
I'm another person who can not get avast to work with gmail due to the server error when trying to add it in......

Please remedy for us.....

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: SSL/TLS connection detected!
« Reply #82 on: January 28, 2013, 10:20:40 AM »
I'm another person who can not get avast to work with gmail due to the server error when trying to add it in......

Please remedy for us.....

Use the beta (http://forum.avast.com/index.php?topic=112193.0), it fixes this issue.

Offline jimceez

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #83 on: February 02, 2013, 03:03:00 PM »
Hi,

I'm new to avast! am having the same issues as most others.  I turn off SSL in the mail accounts and try to add the servers into the avast! listing and I get the same errors of verification.  This is happening to both my comcast & gmail accounts. I've read most threads, found the keychains, moved them to system and still have issues.  I'm using the latest release of ML.

It is extremely frustrating.  Can you put the complete steps into a bullet point format so people can follow.  Thanks.

Offline joelw135

  • Jr. Member
  • **
  • Posts: 87
Re: SSL/TLS connection detected!
« Reply #84 on: February 05, 2013, 04:40:03 PM »
I'm another person who can not get avast to work with gmail due to the server error when trying to add it in......

Please remedy for us.....

Use the beta (http://forum.avast.com/index.php?topic=112193.0), it fixes this issue.

It fixes the issue, but doesn't allow access to IMAP gamil or POP. Also causes Thunderbird to become highly unstable if you turn off Mail Shield.

Offline Sfmsk

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #85 on: February 10, 2013, 12:32:15 PM »
Hey I have the same problem. I get the red warning (SSL certificate check failed!) :(
My mail worked just fine before where I had Norton, but it was only a trial version and it expired, so I went and got Avast.
I've done everything; disabled SSL, added the incoming mail server to the mail shield of Avast and added it to my keychain as well, but I still get that stupid message. I've got no clue what to do, would be lovely if somebody could help. :)

Thanks in advance
Sfmsk

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 70674
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: SSL/TLS connection detected!
« Reply #86 on: February 10, 2013, 12:34:48 PM »
Did you try the beta yet..??
Win 8.1 [x64] - Avast PremSec 21.5.6354.BCi [UI.646] - EEK - Firefox ESR 78.11 [NS/uBO/PB] - TB 78.11
Avast-Tools: Secure Browser 91.0 - Cleanup 21.1 - SecureLine 5.12 - Driver Updater 21.1 - CCleaner 5.82
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline esamax

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #87 on: February 11, 2013, 02:23:01 AM »
forget the 993 popups - according to GMail you should leave the SSL checked

Offline specimen9999

  • Sr. Member
  • ****
  • Posts: 349
Re: SSL/TLS connection detected!
« Reply #88 on: February 11, 2013, 01:47:45 PM »
forget the 993 popups - according to GMail you should leave the SSL checked

In the current stable release of Avast! (not the Beta, as it works differently there) this is not correct IF you want Avast! to scan your incoming email, as such Avast! acts as the email client itself and makes the secure (SSL) connection, and then routes it to the email client, so as far GMail is concerned (and they are correct) the email client is really Avast! proxy, which indeed has SSL enabled.

The confusion arises from the fact that in the email client you configure the actual server address instead of a local proxy, when in fact you are using a local proxy, albeit a so called 'transparent' one.
« Last Edit: February 11, 2013, 01:51:38 PM by specimen9999 »

Offline vladan

  • Newbie
  • *
  • Posts: 1
Re: SSL/TLS connection detected!
« Reply #89 on: February 18, 2013, 12:13:26 AM »
as mac user, i edited hosts file

sudo nano /private/etc/hosts
added
173.194.67.109  imap.gmail.com
(ctrl-o,ctrl-x) to save file

after that add secured server is successful

 if you open again hosts file you will noticed 2 entries:

173.194.67.109  imap.gmail.com  # Added by avast!

now all servers are there,but warnings are still popping up sometimes (not completely solved)

for gmail imap access i am using outlook for mac

hope this helps a little bit

rgds