Author Topic: Mail Shield "insert message" options - gone from 'Pro' and 'IS' or only 'Free'?  (Read 8351 times)

0 Members and 1 Guest are viewing this topic.

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
I probably should have started a new topic in the first place rather than burying this question in the other thread

I can't get my hands on a machine with 7.0.1456 IS right now in order to check for myself but can anyone tell me if the "insert message" options in the Mail Shield are removed from 'Pro' and 'IS' or only in 'Free'?
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84605
  • No support PMs thanks
In all honesty this is a greatly depreciated option (see below), so I would imaging that it isn't in any of the avast versions and as far as I'm aware the Mail Shield functionality is the same in all versions.

Greatly depreciated in that it is easy to fake and these fake 'email scanned by XXXX (insert AV of choice) and found to be clean have been used in malicious emails in the past and who trust tat anyway, I certainly don't.

Why is it needed when if an inbound email is infected avast will alert, brand the email Subject and remove any infected attachment, etc. For outbound email it too would alert if infected/suspicious, etc. the only real benefit is promotion of avast.

For me the thought of going backwards to an older version of avast with a lessor degree of protection, for something which provides zero extra protection for what are cosmetic reasons, is crazy.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
Hi DavidR
Thanks for the 'presentation' but it's not me you need to convince.
It's efficacy may be depreciated but it's presence is still appreciated by other users.

Anyway, I should be able to find out myself tomorrow.
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6721
  • When you think you know, Think Again
I probably should have started a new topic in the first place rather than burying this question in the other thread

I can't get my hands on a machine with 7.0.1456 IS right now in order to check for myself but can anyone tell me if the "insert message" options in the Mail Shield are removed from 'Pro' and 'IS' or only in 'Free'?

I noticed that a while back and was a little disappointed, as I did use those options.
However as DavidR pointed out, they could be viewed as redundant/useless.
I don't sweat the small stuff. ;) :)
***HP ENVY 15K LT W10 Pro 20H2 64Bit/750GB HD/16GB Ram/Avast Premium 21.2.2453b/Secureline VPN v.5.9b/ADU v.21.1b/ASB v.88.2b/ACP 21.1b/ SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/Avast Premium 21.2.2453b/ADU v.21.1b/ACP 21.1/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84605
  • No support PMs thanks
Hi DavidR
Thanks for the 'presentation' but it's not me you need to convince.
It's efficacy may be depreciated but it's presence is still appreciated by other users.

Anyway, I should be able to find out myself tomorrow.

Yes, but that really is what has to be made clear to those asking the question, it really is old hat and being used in some malicious emails. Who trusts it if the message is from other AVs so why would they trust it is from avast!.

It really doesn't bring any additional in the way of security, potentially the reverse as opening an email could actually initiate a remote attack. So looking inside an email for a clean note could potentially put you at more risk, it certainly isn't something I would rely on.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
Just checked. http://forum.avast.com/index.php?topic=102472.msg821239#msg821239

Agree that avast! messages in clean emails are not essential but that doesn't stop users who've noticed asking me how to get them back!
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4113
Just checked. http://forum.avast.com/index.php?topic=102472.msg821239#msg821239

Agree that avast! messages in clean emails are not essential but that doesn't stop users who've noticed asking me how to get them back!

Hi,
there're some users in italian board with the same problem.
Probably is stupid but is simple to get back the clean message in the mails:
just go under
C:\Documents and Settings\All Users\application data\AVAST Software\AVAST\EmailShield.ini (xp Os)
or
C:\ProgramData\AVAST Software\Avast\EmailShield.ini (seven or vista Os)

and under the voice
[EmailScanner]
change the value from 0 to 1 (o inserting these voices if they are not present)

Code: [Select]
InsertNoteCleanMsgIn=1
InsertNoteCleanMsgOut=1

when you save the file, avast selfdefense module ask to permit the change of file (must response Yes)

Work OK on my Xp SP3 & avast 7.0.1466 free.
« Last Edit: September 18, 2012, 05:26:00 PM by giogio »
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
Thanks for the tip.

Slight problem however. The XP machine I just looked at was a clean install of 7.0.1466 and has no 'EmailShield.ini' or even 'C:\Documents and Settings\All Users\application data\AVAST Software' path.

I did find a shortcut for a now non-existant "C:\Program Files\Alwil Software\Avast5\DATA\EmailShield.ini" in the "Recent" folder. I assume this was part of a previous version.
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6721
  • When you think you know, Think Again
I have edited/added both "insertnote clean" in and out.
Will see if the edit works with my AIS on XPSP3. :)

Edit: Not sure that has worked?? Nothing in the first email sent.
Will see when email returns.
« Last Edit: September 18, 2012, 05:34:43 PM by schmidthouse »
***HP ENVY 15K LT W10 Pro 20H2 64Bit/750GB HD/16GB Ram/Avast Premium 21.2.2453b/Secureline VPN v.5.9b/ADU v.21.1b/ASB v.88.2b/ACP 21.1b/ SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/Avast Premium 21.2.2453b/ADU v.21.1b/ACP 21.1/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84605
  • No support PMs thanks
Thanks for the tip.

Slight problem however. The XP machine I just looked at was a clean install of 7.0.1466 and has no 'EmailShield.ini' or even 'C:\Documents and Settings\All Users\application data\AVAST Software' path.

I did find a shortcut for a now non-existant "C:\Program Files\Alwil Software\Avast5\DATA\EmailShield.ini" in the "Recent" folder. I assume this was part of a previous version.


The 'C:\Documents and Settings\All Users\application data\AVAST Software' folder (or rather a lower level folder) may be hidden. So the user would need to modify the Windows Explorer, Tools, Folder Options, to Show hidden files and folders.
« Last Edit: September 18, 2012, 05:36:31 PM by DavidR »
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
Thanks David. No files are 'hidden'. It's slightly more serious than that.
There's no 'Avast' folder of any kind in that location.
.
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6721
  • When you think you know, Think Again
@DavidR.
Mine looks a bit different as there is no .ini after the Shield.
***HP ENVY 15K LT W10 Pro 20H2 64Bit/750GB HD/16GB Ram/Avast Premium 21.2.2453b/Secureline VPN v.5.9b/ADU v.21.1b/ASB v.88.2b/ACP 21.1b/ SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/Avast Premium 21.2.2453b/ADU v.21.1b/ACP 21.1/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6721
  • When you think you know, Think Again
Also, just to make sure: Does it matter 'where' (in the Configuration progression) the added 'Insertnotes' are placed?
Here's where I placed them.
Sreenshot.
***HP ENVY 15K LT W10 Pro 20H2 64Bit/750GB HD/16GB Ram/Avast Premium 21.2.2453b/Secureline VPN v.5.9b/ADU v.21.1b/ASB v.88.2b/ACP 21.1b/ SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/Avast Premium 21.2.2453b/ADU v.21.1b/ACP 21.1/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4113
Thanks for the tip.

Slight problem however. The XP machine I just looked at was a clean install of 7.0.1466 and has no 'EmailShield.ini' or even 'C:\Documents and Settings\All Users\application data\AVAST Software' path.

I did find a shortcut for a now non-existant "C:\Program Files\Alwil Software\Avast5\DATA\EmailShield.ini" in the "Recent" folder. I assume this was part of a previous version.

 :o
On 3 pc ( 2 XP and 1 Vista) I can find that file...
On my home system (where I did the test) I've also did a clean install..



@DavidR.
Mine looks a bit different as there is no .ini after the Shield.

You must enable the visibility of file extension  ;)
http://windows.microsoft.com/en-ZA/windows-vista/Show-or-hide-file-name-extensions
« Last Edit: September 18, 2012, 07:15:55 PM by giogio »
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84605
  • No support PMs thanks
Thanks David. No files are 'hidden'. It's slightly more serious than that.
There's no 'Avast' folder of any kind in that location.
.

Whilst it shouldn't be in a different location try looking in the C:\Documents and Settings\username\application data\ folder.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security