Author Topic: Avast Service Doesnt Start - HELP!!!  (Read 40518 times)

0 Members and 1 Guest are viewing this topic.

Offline koolx

  • Jr. Member
  • **
  • Posts: 37
Re: Avast Service Doesnt Start - HELP!!!
« Reply #30 on: August 21, 2012, 02:15:00 AM »
DNS cache is also called DNS Client
Shared Access is windows firewall
Wuauserv is Windows Update AutoUpdate Service

Once you have restarted those could you run FSS again please

i restarted those services and i ran FSS. look at the attached log from FSS. but again, after restarting all the requested services, the avast service doesnt start. at this point, i think this could be a permissions or group policy issue.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40631
  • Dragons by Sasha
    • Malware fixes
Re: Avast Service Doesnt Start - HELP!!!
« Reply #31 on: August 21, 2012, 04:03:17 PM »
What error does Avast give for not starting ? Does it mention a service ?

Download  Windows Repair (all in one)  from this site

Install the programme then run



Go to step 3 and allow it to run SFC



On the start repairs tab click start


Select the following  items and tick restart system when finished


Offline koolx

  • Jr. Member
  • **
  • Posts: 37
Re: Avast Service Doesnt Start - HELP!!!
« Reply #32 on: August 21, 2012, 04:43:14 PM »
What error does Avast give for not starting ? Does it mention a service ?

the error i get is:
"Could not start the avast antivirus service on Local Computer. Error 5: access is denied."

but also, i checked the dependencies of the avast service. and i see it depends on 2 services:
- Remote Procedure Call (RPC)
- aswMon2


i do have RPC enabled, but i dont see aswMon2 in my list of services. how can i get this service in my list to enable it?


Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40631
  • Dragons by Sasha
    • Malware fixes
Re: Avast Service Doesnt Start - HELP!!!
« Reply #33 on: August 21, 2012, 07:46:42 PM »
HAsve you tried a repair install of Avast ?

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: Avast Service Doesnt Start - HELP!!!
« Reply #34 on: August 21, 2012, 08:41:02 PM »
Hi koolx,

If I may interject for a moment or two:

It does appear as if you had a rootkit on your system, and several needed services were then disabled, some that Avast! needed to run properly, so merely uninstalling, removing remnants left over with aswclear.exe, would not ever allow Avast! to install properly and run.  This is the damage you are now trying to repair ATM.  That is why I brought essexboy in to assist you in fixing your issues.  Damage appears to be much more severe than first indicated here.

essexboy does know what he is doing here.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40631
  • Dragons by Sasha
    • Malware fixes
Re: Avast Service Doesnt Start - HELP!!!
« Reply #35 on: August 21, 2012, 08:44:50 PM »
Also ensure that you run windows repair as that will fix access problems

Offline koolx

  • Jr. Member
  • **
  • Posts: 37
Re: Avast Service Doesnt Start - HELP!!!
« Reply #36 on: August 21, 2012, 11:36:28 PM »
Hi koolx,

If I may interject for a moment or two:

It does appear as if you had a rootkit on your system, and several needed services were then disabled, some that Avast! needed to run properly, so merely uninstalling, removing remnants left over with aswclear.exe, would not ever allow Avast! to install properly and run.  This is the damage you are now trying to repair ATM.  That is why I brought essexboy in to assist you in fixing your issues.  Damage appears to be much more severe than first indicated here.

essexboy does know what he is doing here.

thanks mchain link..

Offline koolx

  • Jr. Member
  • **
  • Posts: 37
Re: Avast Service Doesnt Start - HELP!!!
« Reply #37 on: August 21, 2012, 11:41:46 PM »
Also ensure that you run windows repair as that will fix access problems

hi essexboy.. to answer your question, i tried a repair of avast 3 times last week but it didnt work. i did run the Windows Repair (all in one) and restarted my system.. but when i tried to start the avast service, it still gave me error 5. maybe i should try to uninstall then reinstall avast after doing the Windows Repair (all in one)? i'll try it and report back.

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: Avast Service Doesnt Start - HELP!!!
« Reply #38 on: August 21, 2012, 11:50:40 PM »
As essexboy lives in England, might be a bit before he is back online.  (Different time-zone)  You should do the proposed solution, that of repairing Avast! as essexboy requests, before going on to uninstall, aswclear, etc.,.  That way he knows exactly where you are with your system, and no further changes need to be looked for.  Makes the repair work a little bit easier for both of you. 

Please be patient, you are under his expert care.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline koolx

  • Jr. Member
  • **
  • Posts: 37
Re: Avast Service Doesnt Start - HELP!!!
« Reply #39 on: August 22, 2012, 12:01:39 AM »
As essexboy lives in England, might be a bit before he is back online.  (Different time-zone)  You should do the proposed solution, that of repairing Avast! as essexboy requests, before going on to uninstall, aswclear, etc.,.  That way he knows exactly where you are with your system, and no further changes need to be looked for.  Makes the repair work a little bit easier for both of you. 

Please be patient, you are under his expert care.

hi mchain link. thanks for the reassurance. i really appreciate all your help as well as essexboy. i'll be patient.