Author Topic: Cannot Use Skype After Installing Avast Internet  (Read 7855 times)

0 Members and 1 Guest are viewing this topic.

Offline TheAverageGenius

  • Newbie
  • *
  • Posts: 12
Cannot Use Skype After Installing Avast Internet
« on: September 19, 2012, 10:09:53 PM »
I'm still in the 30-day trial period here but running the Avast Internet program. For some reason when I open Skype, I get nothing...just a blank screen with the Skype header. Is there some setting or firewall block, some "shield" setting that can cause this conflict?

I've been trying to auto-sandbox various programs, and had Skype in that list. When I saw Skype wasn't working, I removed it from the sandbox list, but I have no idea how to add an exception to the firewall list. I only use Skype for client work, I don't think I have much danger coming in from Skype (correct me if I'm wrong).

What I need is to use Skype for running my online business, and I still need to protect my system: so what do I do?

Another "issue" but it may be related: I noticed in my Firewall Logs that "GoogleUpdate.exe" was trying time and again to update something on my PC...not sure if it's related to the Skype issue or not, but how do I add this as an exception to the firewall?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Cannot Use Skype After Installing Avast Internet
« Reply #1 on: September 19, 2012, 11:03:10 PM »
Just a thought based on another topic (not directly related but a possibility), I don't know if you have the avast firewall to allow internet connection sharing.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline TheAverageGenius

  • Newbie
  • *
  • Posts: 12
Re: Cannot Use Skype After Installing Avast Internet
« Reply #2 on: September 19, 2012, 11:37:37 PM »
I just checked. If I was in the right spot, the box is un-checked. It's unclear to me what most of these settings mean.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Cannot Use Skype After Installing Avast Internet
« Reply #3 on: September 20, 2012, 01:22:18 AM »
Well I don't use AIS, so I can't speak from personal experience, gust what I glean from the forums and of course if you check the avastUI, Support, Program Help, browse the help file and that should give an idea of the various settings.

In the meantime, check (as in select it) the internet connection sharing option and see if that resolves the problem.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline TheAverageGenius

  • Newbie
  • *
  • Posts: 12
Re: Cannot Use Skype After Installing Avast Internet
« Reply #4 on: September 20, 2012, 02:15:31 AM »
No, that didn't change anything.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67269
Re: Cannot Use Skype After Installing Avast Internet
« Reply #5 on: September 20, 2012, 02:46:21 AM »
I've used Skype since a long time ago... No problems with avast!... Yesterday, I've kept a 30 minutes conversation without trouble :)
The best things in life are free.

Offline TheAverageGenius

  • Newbie
  • *
  • Posts: 12
Re: Cannot Use Skype After Installing Avast Internet
« Reply #6 on: September 20, 2012, 02:51:04 AM »
It was working fine up until yesterday. Since I work entirely online, it's one way I keep in touch w/clients - but it's blank. I noticed Avast is blocking some Google technology from updating, and I'm not sure which program it is, but I have a feeling it has to do with my Skype problem.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67269
Re: Cannot Use Skype After Installing Avast Internet
« Reply #7 on: September 20, 2012, 03:06:53 AM »
Well, avast! firewall is not a manual firewall by default, i.e., it auto-decides.
Did you change the firewall settings and manually block any Google file to connect?
If you disable the firewall, will Skype work?
The best things in life are free.

Offline TheAverageGenius

  • Newbie
  • *
  • Posts: 12
Re: Cannot Use Skype After Installing Avast Internet
« Reply #8 on: September 20, 2012, 10:56:19 AM »
There is a Skype FAQ related to this question and apparently it has to do with IE being able to access JavaScript...when I read that I realized my mistake: I did give Javascript a low trust rating (not sure what to call it) in the Firewall settings under "Application Rules."

Once I followed the tutorial in Skype's help section, it worked fine. Then I adjusted the application rules in the Firewall settings.

But as to the Google script not being able to update: I'm not sure if it's due to the JavaScript issue or not, but I'd suspect that's what the problem was since they do use a lot of Java. I'm being paranoid after my rootkit infection and dealing with nearly 3 weeks of downtime.

If anyone wants to see the Skype post that helped me:

http://community.skype.com/t5/Windows/problems-with-screens/td-p/511703

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Cannot Use Skype After Installing Avast Internet
« Reply #9 on: September 20, 2012, 01:44:13 PM »
Thanks for coming back with the feedback and resolution.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/