Author Topic: Solution: Using GMail with Avast and a SPAM filter  (Read 56287 times)

0 Members and 1 Guest are viewing this topic.

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #15 on: April 24, 2005, 06:28:26 PM »
Glad to hear it is working for you.  If you have another ISP that supports secure email (besides gmail), you can adapt the gmail stuff by using ports like 11112 and 11027 in TB & avast!, adding lines to stunnel.conf for the new servers, and removing the protocol=smtp line from the smtp setup (gmail uses ssl and an unusual port, most ISPs use tls and port 25).  You can also do secure IMAP this way (with port 993 in stunnel ) if your ISP supports it.  Avast!/Stunnel/OpenSSL gives pretty good flexibility once you get through the initial setup.
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline rdsu

  • Avast Evangelist
  • Poster
  • ***
  • Posts: 534
  • ...
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #16 on: June 16, 2005, 02:57:58 PM »
With the new incoming version of Thunderbird, we will not need to have another program to avast! check virus in messages from POP3 with SSL ;D

See this post: http://forums.mozillazine.org/viewtopic.php?p=1543696#1543696

Regards
Avast Free Antivirus: Web Shield & Home Network Security.

Offline Ryu701

  • Newbie
  • *
  • Posts: 2
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #17 on: December 16, 2005, 08:48:13 PM »
Hello. I use Win XP Home, Avast 4.6.739 , Thunderbird 1.0.7 , Stunnel 4.11 and OpenSSL 0.9.8.a.

I want to check my gmail account with Avast and made these configurations as told above:

I changed TB configuration of gmail account as localhost, port 11111 and 11026 and no SSL.
I changed stunnel.conf as described here and I didnt forget the first line: "client=yes".
I added required ports, 11111 and 11026 to Avast! internet mail configuration and I am sure that they are in Avast.INI.

However I still have problems.

When Avast Internet Mail scanner is on, I can send emails but I can not get them. Thunderbird says that "Connected to localhost.." but nothing happens for long time. When I turn Internet Mail scanner off I can receive them.

Another strange thing is, although "add note to sent messages" option is checked in Avast there are not any note in sent messages.

Can you help me please? What can be wrong?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67250
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #18 on: December 17, 2005, 02:34:04 AM »
Hello. I use Win XP Home, Avast 4.6.739 , Thunderbird 1.0.7 , Stunnel 4.11 and OpenSSL 0.9.8.a.
I have Win XP Pro, avast 4.6.739, Thunderbird 1.5, Stunnel 4.14 (with OpenSSL library inside of it).

I use TB configuration of gmail account as 127.0.0.1, port 11110 and no SSL.
I changed stunnel.conf to

Code: [Select]
# GMail
client=yes

# POP3 service, listens on localhost:11110
[gmail-pop3s]
accept=127.0.0.1:11110
connect=pop.gmail.com:995

# SMTP service, listens on localhost:11025
[gmail-smtps]
protocol=smtp
accept=127.0.0.1:11025
connect=smtp.gmail.com:587

I added required ports, 11110 and 11025 to avast! Internet Mail provider settings (Redirection).

Just some questions, do you use any Spam killer application? Any local proxy filter (like an annonimizer)?
The best things in life are free.

Offline Ryu701

  • Newbie
  • *
  • Posts: 2
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #19 on: December 18, 2005, 01:40:34 AM »
Tech, thank you for your reply. I use neither a Spam killer application nor a local proxy filter. But I found the cause of my problem. 

Ignorelocalhost=0 line must be added to avast.ini.

But if Avast's version is 4.6, this setting must be changed by Avast interface; manually editing avast.ini has no effect.

Now, after trying many hours, I can finally scan my sending and receiving emails of both Gmail and non SSL mail accounts.  :D

This FAQ was helpful for me, anybody experiencing problems with these complex configurations may refer to it.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67250
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #20 on: December 18, 2005, 03:05:47 AM »
Manually editing avast.ini has no effect.
Oh... I should told you before...
The Mail Service must be stopped before the manual change.
Glad you've find another path to happiness  8)
The best things in life are free.

Offline whkrems

  • Newbie
  • *
  • Posts: 11
  • llama Extraordinare
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #21 on: December 25, 2005, 03:01:19 AM »
I finally got Avast to work with SSL\gmail using outlook Express. Posting my configuration in hope of helping someone.
Installed OpenSSL and Stunnel.
------------------------------------------

(Avast set the Listen ports.)
(I set log=20 for Max logging)

Avast4.ini:
-----------------------------------
[MailScanner]
DefaultSmtpServer=smtp.gmail.com
DefaultPopServer=pop.gmail.com
UseDefaultSmtp=0
AutoSetProtection=1
ShowTrayIcon=1
Log=20
SmtpListen=127.0.0.1:1245
PopListen=127.0.0.1:1244
ImapListen=127.0.0.1:143
PopRedirectPort=11110
SmtpRedirectPort=11125
ImapRedirectPort=143
NntpRedirectPort=119
IgnoreAddress=
IgnoreLocalhost=0
AutoRedirect=1
StartPop=1
StartSmtp=1
StartImap=1
StartNntp=1
====================================


Stunnel.conf:
-------------------------------------------------------------------------
# We're running as a client to SSLify the GMail POP connection
client=yes
debug=debug

# POP3 service, listens on localhost:11110
[gmail-pop3s]
accept=127.0.0.1:11110
connect=pop.gmail.com:995
#or the SSL port of your Secure POP server if you use another service.

# SMTP service, listens on localhost:11125
[gmail-smtps]
TIMEOUTconnect = 10
accept=127.0.0.1:11125
connect=smtp.gmail.com:465
#or the SSL port of your Secure SMTP server if you use another service.
===========================================

Outlook Express:
--------------------------------------------
Incoming mail server: 127.0.0.1
Outgoing mail server: 127.0.0.1
Server requires Authentication is checked.
Server Ports:
Outgoing (SMTP) 11125
Incoming (pop3) 11110
Server reqiures SSL: is Unchecked.
===========================================
(all other settings in Outlook Express left the way they were set by GmailConfig.exe.)

My Thanks to this forum.
« Last Edit: December 25, 2005, 03:15:59 AM by whkrems »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67250
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #22 on: December 26, 2005, 01:17:49 PM »
I finally got Avast to work with SSL\gmail using outlook Express. Posting my configuration in hope of helping someone.
We're glad with you...

I set log=20 for Max logging
You can downgrade the log capacity to avoid such a big log file  ;)
The best things in life are free.

Offline whkrems

  • Newbie
  • *
  • Posts: 11
  • llama Extraordinare
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #23 on: January 15, 2006, 03:33:09 PM »
Well, had Avast working with gmail using Outlook Express on Windows Xp SP2.
  Can not get it to work after doing complete restore and using Windows XP without service packs or updates.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67250
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #24 on: January 15, 2006, 03:52:06 PM »
Well, had Avast working with gmail using Outlook Express on Windows Xp SP2.
Can not get it to work after doing complete restore and using Windows XP without service packs or updates.

Maybe you have to install Stunnel again (the new versions include the OpenSSL drivers).
Taka look here: http://forum.avast.com/index.php?topic=10428.0 to see how to set up secure email with avast!.
Advanced configuration: please refer to this post http://forum.avast.com/index.php?topic=8775.msg97026#msg97026
The best things in life are free.

Offline CharleyO

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7085
  • Be alert for error code - ID 10T
Re: Solution: Using GMail with Avast and a SPAM filter
« Reply #25 on: January 15, 2006, 04:59:05 PM »
***

whkrems ... you should also update XP to SP2!

Otherwise, your computer is usafe from many exploits.  :(


***
Self-built desktop (8 years old) - AMD64 3200+_Gigabyte GA-K8NS Ultra-939_4 gb RAM_GeForceFX 5800w/256 ram_XP/SP3_Avast 7_MBAM_ZA Free __and__ Toshiba Satellite Laptop_W7-64bit_ 4 gb Ram_Avast 8_MBAM