Author Topic: after avast home installation: cannot acces neither internet nor LAN  (Read 24579 times)

0 Members and 1 Guest are viewing this topic.

yvhanoi

  • Guest
hello,

here is my home configuration:
1 desktop / WXP
1 labtop / WXP
1 linksys WAG54 gateway

all this used to work well together:
the 2 pcs dynamically get an IP address (192.168.1.x) from the DHCP  server of the gateway to sea eachother for file sharing and access the internet.

i have just downloaded AVAST! home on my labtop and installed it. as a result the network is down now on it:
cannot access the internet, cannot access the LAN.

in fact, the PC is no more able to found the DHCP server of the gateway, so an IP address 169.254.x.x is assigned by WXP IPAC  service.

I have installed AVAST! home with all the  default options,  no warning...

by now, the labtop is 1000% protected against viruses... but useless.

thanks for your help.

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #1 on: January 18, 2005, 10:07:12 AM »
forgot to say:
I have de-installed AVAST! and all is ok again.....

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31216
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #2 on: January 18, 2005, 10:12:01 AM »
Very strange...... ???

It could have been a conflict with another application or a bad install.
Was there any other av on the system before Avast?
If so was it completely removed (including registry keys) before installing Avast?
Can you install Avast again and see if it happens again?
If it happens again check the system log, event log and Avast log file. It may tell us more about what is going on.

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #3 on: January 18, 2005, 10:32:11 AM »
this is a fresh installation of WXP, AVAST is the second program i have installed on it after mozilla firefox.

what i can see is that the installation of AVAST (successfull with the default options) prevent me to access to the DHCP server of the gateway (even an ipconfig/renew does not work...).

just de-installing AVAST makes all working again.

so my understanding is that this is only AVAST that causes the trouble...

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31216
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #4 on: January 18, 2005, 10:34:06 AM »
I never have seen Avast blocking network access.
Not saying it can't happen, but it is very unlikely.
Since you connected to the net without all secrutiy patches installed and without av software, make sure your system isn't already infected with malware.

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #5 on: January 18, 2005, 10:40:31 AM »
how could the labtop be infected???
as i previously said, just only de-installed AVAST makes all working again: get a correct IP address, see the LAN, connect the internet...
or are you saying that my labtop was infected by AVAST?

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31216
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #6 on: January 18, 2005, 10:43:27 AM »
Read my post again.

Quote
how could the labtop be infected?
You went online without proper protection and like also without ALL security patches/updates installed.

Quote
or are you saying that my labtop was infected by AVAST?
No I said with MALWARE.
« Last Edit: January 18, 2005, 10:50:58 AM by Eddy »

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #7 on: January 18, 2005, 10:59:33 AM »
mmm...
i have reformated the disk yesterday and installed Windows XP
then get Firefox and Avast from my desktop (behind  gateway's firewall and auto protect by NAV)
then installed Firefox
then installed Avast
then cannot access neither LAN nor internet
then de-installed Avast
then able to access both LAN AND internet...

galooma

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #8 on: January 18, 2005, 11:13:11 AM »
Was it the current build 4.5.561 installed?
was avast! able to update?
Did you try selectively shutting down providers ?
windows firewall off?
re-boot after installation?

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #9 on: January 18, 2005, 02:32:57 PM »
Was it the current build 4.5.561 installed?
not sure. i have downloaded the kit yesterday.
was avast! able to update?
from the web? of course not...
Did you try selectively shutting down providers ?
what do you mean by "providers"?
windows firewall off?
yes of course, for file sharing on XP
re-boot after installation?
no

note that i am not currently at home.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #10 on: January 18, 2005, 06:54:17 PM »
Behind gateway's firewall and auto protect by NAV

What do you mean with NAV?
Did you install avast with NAV already installed?
The best things in life are free.

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #11 on: January 24, 2005, 10:02:15 AM »
I have tried again this week-end at home.

after having re-intalling AVAST (without restarting my labtop), my internet connection and LAN connection was OK.

then I restart my labtop and what I have seen is that AVAST is computing when I boot and connect on my Local Network preventing me to get an address from my gateway's DHCP server.

so is there a way to enable AVAST ONLY when i connect the internet and disable it at computer start up?

thanks.

galooma

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #12 on: January 24, 2005, 10:32:22 AM »
Hi and welcome back could you give us a log file generated from HJT as it will give us a list of what utilities you are running and system specs . You can download it here http://www.allsecpros.com/hjt.html there is also a tutorial at the site to read up on.

yvhanoi

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #13 on: January 24, 2005, 10:56:27 AM »
ok thanks, i'll do this this evening when i am at home. stay tuned...

watchthisspace

  • Guest
Re: after avast home installation: cannot acces neither internet nor LAN
« Reply #14 on: January 24, 2005, 11:00:38 AM »
Have you tried disabling the Network shield?
Go, Right click on the avast ball in the tast bar >>on-access protestion control>>Details (if it has less details leave it) >>Network shield>>Terminate>> no


Watchthisspace