Author Topic: Problema al instalar Avast (por primera vez)  (Read 37946 times)

0 Members and 1 Guest are viewing this topic.

thaumas

  • Guest
Problema al instalar Avast (por primera vez)
« on: August 30, 2012, 12:45:36 AM »
Hola, un saludo a todos los usuarios del foro.

"Ocurrio un error durante el proceso de instalación"

Este es el mensaje de error que recibo al intentar instalar el antivirus. No tengo ningún otro antivirus y he tratado de instalarlo con la configuración predeterminada, de forma manual y seleccionando los módulos que quería. He tratado de instalarlo en modo normal y en modo seguro.

No hay manera.

A ver si podéis echarme un cable con esto.

Saludos.


Offline Juanjo

  • Avast Reseller
  • Full Member
  • *
  • Posts: 158
    • Avast Antivirus España - Distribuidor y Mayorista Oficial
Re: Problema al instalar Avast (por primera vez)
« Reply #1 on: August 30, 2012, 05:07:17 PM »
Un aspecto importante a la hora de afrontar errores como este es saber si había otro antivirus instalado anteriormente a avast! y si éste ha sido desinstalado correctamente. ¿Es este el caso? También sería de mucha utilidad una captura de pantalla del problema, como suele decirse a veces una imagen vale más que mil palabras.

thaumas

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #2 on: August 30, 2012, 06:47:57 PM »
había otro antivirus instalado anteriormente a avast! y si éste ha sido desinstalado correctamente. ¿Es este el caso?
Sí, tenía otros dos antivirus (Mcafee y AVG... gran error por parte del dueño) y fueron desinstalados con los desinstaladores respectivos de cada antivirus.



Aquí te dejo también el informe que me da.

INFORME

Saludos

iroc9555

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #3 on: August 30, 2012, 10:57:23 PM »
Thaumas bienvenido al foro.

El consejo aportado por Juanjo tiene mucha validez. Es imperativo usar herremientas de desinstalacion de otros AV y el procedimiento adecuado antes de instalar Avast!

Mejor que hagas una reinstalacion limpia. Por favor sigue estas instrucciones:

1. Muy importante. Desinstalas todos los AVs que haz tenido anteriormente con sus desinstaladores. Los encuentras aqui:

http://singularlabs.com/uninstallers/security-software/

2. Baja y guarda  aswclear.exe en tu computadora ( escritorio )

3. Baja y guarda una copia fresca de tu Avast!

http://files.avast.com/iavs5x/avast_free_antivirus_setup.exe
http://files.avast.com/iavs5x/avast_internet_security_setup.exe
http://files.avast.com/iavs5x/avast_pro_antivirus_setup.exe


Si es un Avast! pagado asegurate de tener la licencia a la mano.

4.) Abre Avast > Opciones > Solucion de problemas > Desactiva el Modulo de Autodefensa.

5.) Desinstala Avast normalmente atraves de Windows " Agregar y Quitar Programas " si no pide reinicio, reinicia tu ordenador.

Si no puedes completar el paso 5 no importa sigue con el paso 6

6.) Aunque hayas completado el paso 5 exitosamente es imprecindible hacer esto: Reinicia La PC en Modo Seguro ( dale a F8 repetidamente cuando la PC empieza el inicio ).

Usa aswclear.exe en modo seguro por cualquier Avast! anterior y de ultimo por la V. 7.

7.) Reinicia en modo normal y reinstala Avast! y reinicia nuevamente.

Estate atento que puede que Avast! te ofresca Google Chrome. Si no lo quieres desmarca las casillas.

Suerte.

thaumas

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #4 on: August 31, 2012, 01:09:46 AM »
Quote from: iroc9555
El consejo aportado por Juanjo tiene mucha validez. Es imperativo usar herremientas de desinstalacion de otros AV y el procedimiento adecuado antes de instalar Avast!
Fui yo quien dijo que había usado los respectivos desinstaladores de los antivirus instalados para que no quedara ningún rastro.

He seguido parte del proceso que has comentado pero se trata de una versión gratuita.

Me sigue saliendo el mismo mensaje de error.

Saludos.

iroc9555

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #5 on: August 31, 2012, 01:48:44 AM »
¿ Que Windows tienes; Spk y arquitectura ?
¿ Que Cortafuegos usas ?
¿ Que otro programa de seguridad tienes instalado ?

He seguido parte del proceso que has comentado pero se trata de una versión gratuita.

¿ Que parte del proceso seguistes y que parte no seguistes ?

1. Importante desintalar con aswclear en Modo Seguro.
2. Descargar nuevamente el programa ( en tu caso el gratis ) de los enlaces que di que son directos a Avast!

Tambien podria ser algo en el registro o en el mismo Windows. Podrias correr un CHKDSK o sfc /scannow para estar seguros. Tambien limpiar temporales.

Otra razon seria que tienes un programa malicioso que esta evitando la instalacion de Avast!. Descarga, instala y actualiza Malwarebytes' ( MBAM ) y haz un analisis rapido solo para ver si tienes algo. Por supuesto podria ser un rootkit muy escondido que MBAM no detecte.






thaumas

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #6 on: August 31, 2012, 04:40:32 PM »
Quote from: iroc9555
¿ Que Windows tienes; Spk y arquitectura ?
Windows 7 Home premium 64 Bits

Quote from: iroc9555
¿ Que Cortafuegos usas ?
El propio de Windows.

Quote from: iroc9555
¿ Que otro programa de seguridad tienes instalado ?
Ninguno. Como ya comenté en mi anterior mensaje, me deshice de todos los antivirus que tenía el equipo instalado con sus respectivos instaladores pero que no hubiese problemas de incompatibilidad (Edito: Ahora tengo Microsoft Essentials Security porque es el único que me permite instalar).

Quote from: iroc9555
¿ Que parte del proceso seguistes y que parte no seguistes ?
Me dabas una serie de instrucciones en el caso de que el Avast que trataba de instalar fuese de pago. No es de pago, es gratuito. Por lo tanto solo hice la parte de pasar aswclear en Modo Seguro (aún sin tener Avast instalado)

Quote from: iroc9555
1. Importante desintalar con aswclear en Modo Seguro.
Así fué como lo hice.

Quote from: iroc9555
2. Descargar nuevamente el programa ( en tu caso el gratis ) de los enlaces que di que son directos a Avast!
Esto también lo hice de esta manera.

Quote from: iroc9555
Podrias correr un CHKDSK o sfc /scannow para estar seguros. Tambien limpiar temporales.
Todo eso también lo realice y me encontré con la sorpresa de que había ciertas librería que no podían ser reparadas. En concreto sale un mensaje de error con la librería Msvcr80.dll y Msvcr90.dll.

Ciertos programas (como por ejemplo el paquete Office) no me permite abrirlos y me salta ese error con la librería Msvcr80.dll. Sólo me ha permitido instalar Microsoft Essentials Security y le pase Kaspersky virus removal tool (iniciando desde el USB) porque tampoco me dejaba instalar ese antivirus (además de haber analizado el equipo en Modo Seguro con Superantispyware y Malwarebytes).

Ninguna de esas aplicaciones me encontró nada pero el comportamiento es el típico del destrozo ocasionado por un virus (aunque parece que el virus ya no está). No sé si coincides o no conmigo.

El tema de las librerías no consigo repararlo.

Saludos.
« Last Edit: August 31, 2012, 04:44:10 PM by thaumas »

iroc9555

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #7 on: September 01, 2012, 02:22:58 AM »
Thamus.

Me dabas una serie de instrucciones en el caso de que el Avast que trataba de instalar fuese de pago. No es de pago, es gratuito. Por lo tanto solo hice la parte de pasar aswclear en Modo Seguro (aún sin tener Avast instalado)

No. Las instrucciones son las mismas para todos los tipos de Avast!. Los enlaces son para Free, AIS, y Pro. Por supuesto, tengo que advertir que si el Avast! es pagado, que tengan la licencia a la mano. Lo importante es aplicar aswclear en modo seguro y tu lo hicistes y tambien descargar el Avast! directo de los servidores y no de otra pagina web para descartar un programa de instalacion corrupto.



Quote from: iroc9555
Podrias correr un CHKDSK o sfc /scannow para estar seguros. Tambien limpiar temporales.
Todo eso también lo realice y me encontré con la sorpresa de que había ciertas librería que no podían ser reparadas. En concreto sale un mensaje de error con la librería Msvcr80.dll y Msvcr90.dll

 ¿ Eso te lo encontro CHKDSK o sfc /scannow ?

¿ Te acuerdas que decia el error ?

1. "Msvcr80.dll Not Found"
2. "This application failed to start because msvcr80.dll was not found. Re-installing the application may fix this problem."
3. "Cannot find [PATH]\msvcr80.dll"
4. "The file msvcr80.dll is missing."
5. "Cannot start [APPLICATION]. A required component is missing: msvcr80.dll. Please install [APPLICATION] again."

Bueno las librerias, lo mas seguro son de Office, y no podran ser reparadas al menos que tengas el disco de Office y las reemplaces o reinstales Office.


....le pase Kaspersky virus removal tool (iniciando desde el USB) porque tampoco me dejaba instalar ese antivirus (además de haber analizado el equipo en Modo Seguro con Superantispyware y Malwarebytes).

Ninguna de esas aplicaciones me encontró nada pero el comportamiento es el típico del destrozo ocasionado por un virus (aunque parece que el virus ya no está). No sé si coincides o no conmigo.

No solo pudiera ser una infeccion sino muchos barridos con algun limpiador de registro o desinstalando programas con un desinstalador como RevoUninstaler que a veces desinstala librerias compartidas con otros programas que no son los que se van a desinstalar.

No se como es tu ingles o si sabes seguir direcciones en ingles pero si tu quieres puedes instalar y aplicar OTL y aswMBR.exe de aqui:

http://forum.avast.com/index.php?topic=53253.0

OTL es un programa que da una lista de todos los programas y servicios y archivos de tu systema. Tambien se usa para modificarlos o eliminarlos por medios de codigos.

aswMBR.exe es un programa diseñado por Essexboy, nuestro experto en malware, para conseguir servicios o programas escondidos en tu systema.

Solo haz lo que piden las instrucciones y nada mas. No le des a FIX. Los reportes los anexas ( No copiar y pegar por favor ) aqui en el hilo. Si decides hacerlo, yo puedo llamar a Essexboy y explicarle que esta pasando y que analice tus reportes. El tambien pudiera resolver el problema de las librerias si no tienes un Office DVD.

Por supuesto si sabes ingles solo tienes que seguir la guia del enlace y abre un topico en la seccion de viruses and worms aqui:

http://forum.avast.com/index.php?board=4.0


thaumas

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #8 on: September 02, 2012, 01:37:08 AM »
iroc9555, te agradezco enormemente el interés mostrado por el problema que me trajo aquí e igualmente te agradezco la ayuda prestada.

Este equipo me llegó en una condiciones lamentables y traté de ir poco a poco solventando los problemas que me iban saliendo al paso. Lo que me ha quedado totalmente claro después de todo lo que he hecho es que el equipo estuvo infectado y que como consecuencia de dicha infección, se vieron afectadas ciertas partes del sistema (Windows Update, librerías, Antivirus, etc).

Al final, tras haber solventado la mayoría, no he podido reparar ciertos errores y tampoco me he querido complicar la existencia mucho. He optado por restaurar, configurarlo todo tras esto y realizar una clonación y así se lo entrego a su dueño sin erroes de ningún tipo.

He instalado Avast! porque confío en este antivirus (motivo por el que decidí iniciar un hilo aquí) y como una manera de agradecer tu ayuda y la del forero Juanjo.

Así que un abrazo y hasta otra.

P.D: Me da hasta apuro no continuar este post abierto y más tras leer tu última respuesta (muy completa). Discúlpame por, en cierto modo, haberte hecho perder el tiempo (al menos así lo entiendo yo).

iroc9555

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #9 on: September 02, 2012, 04:10:11 AM »
De nada. No hay problema. Entiendo. Si estabas trabajando en ese ordenador para otra persona, debes de devolverla lo antes posible y en condicion operativa.

Una de los productos de seguridad que muchos usuarios pasan por alto, y hoy en dia muy necesario, es un buen programa para respaldar el sistema operativo. No estoy hablando de " Restaurar Windows a un Estado Anterior " sino de programas que puedan hacer una imagen del sistema o del HDD completo. Los que usan W7 tienen un programa incorporado que hace esto y aparentemente es de confiar, pero los que usan todavia XP o Vista deberian de buscar el que mas les convenga y hacer una imagen y rehacerla cada semana con un respaldo de seguridad de al menos un mes de viejo antes de hacer el proximo la semana siguiente.

Programas gratis para elaborar imagen o clonacion del disco:

http://www.techsupportalert.com/es/mejor-programa-gratuito-de-creaci-n-de-im-genes-de-disco.htm
« Last Edit: September 02, 2012, 04:12:26 AM by iroc9555 »

thaumas

  • Guest
Re: Problema al instalar Avast (por primera vez)
« Reply #10 on: September 02, 2012, 03:05:11 PM »
Suelo utilizar para hacer las clonaciones Macrium Reflect (salvo cuando el equipo no tiene lector ya que da problemas al iniciar por usb con este software. Todavía no sé el por qué). Si no posee lector de CDs/DVDs, utilizo Redo Backup and Recovery o Clonezilla.

En este caso me vi obligado a utilizar la partición de rescate.

Saludos.