Author Topic: mail servers keep getting set to 127.0.0.1  (Read 6003 times)

0 Members and 1 Guest are viewing this topic.

pep007

  • Guest
mail servers keep getting set to 127.0.0.1
« on: December 16, 2004, 09:12:14 PM »
I installed the free version of avast on my wife's machine and have to go in and reset the mail servers back to providers settings and reset user name also to get mail to work.  I have set up avast on several machines and never had this problem whats up !!!!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:mail servers keep getting set to 127.0.0.1
« Reply #1 on: December 17, 2004, 01:48:07 AM »
I installed the free version of avast on my wife's machine and have to go in and reset the mail servers back to providers settings and reset user name also to get mail to work.  I have set up avast on several machines and never had this problem whats up !!!!

No need to be worried  8)
If you have Windows XP\2k, avast 4.5 has a new mail detection that will work automatically. Please, set up your email account just as avast does not exists. It will detect the pop3/smpt/imap ports and scan your messages.
If you have Windows 98\Me you should change to 127.0.0.1 or run the Mail Protection Wizard.

Can you post more information about your system?  ;)
The best things in life are free.

chilipepper

  • Guest
Re: mail servers keep getting set to 127.0.0.1
« Reply #2 on: January 17, 2005, 10:27:13 PM »
[Did a little search to find this topic which is why this response is so late.]

I have the same problem.  Win98SE.  Avast doesn't support my e-mail server (freeway.net via corecomm).  So I ran the wizard and changed the setting so it would stop shoving the 127.0.0.1 settings in there and now, if I'm gathering correctly, Avast won't protect my e-mail?  Is that correct?  How do I get it to protect my mail without going through the Avast server?  I can at least download my e-mail now tho I can't send but I think that's because I just changed from dial-up to DSL on our home network and I haven't figured out the outgoing mail settings yet.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: mail servers keep getting set to 127.0.0.1
« Reply #3 on: January 18, 2005, 02:01:32 AM »
I just changed from dial-up to DSL on our home network and I haven't figured out the outgoing mail settings yet.

Did the smtp servers changed?
I mean, is your ISP the same on dial-up and on DSL?
Is your email something like this:
username@oldprovidername.com
and now you connect to:
smtp.newprovider.com
The best things in life are free.

chilipepper

  • Guest
Re: mail servers keep getting set to 127.0.0.1
« Reply #4 on: January 19, 2005, 02:47:04 AM »
I had dial-up with corecomm.  Switched to DSL with verizon via a wireless PCI card to my SO's DSL modem.  I can keep the old mail account and still download from corecomm's server.  Called Verizon today and got the SMTP (outgoing) settings so I can send out mail now too (incoming and outgoing all from oe and my e-mail addy remains the same). 
Now my only remaining question is whether or not Avast is still protecting my e-mail.  The way I read it, I got the impression that e-mail protection is through the avast server (127.0.0.1) and not truly resident in my computer.  That can't be right, can it?  But since I stopped it from shoving those settings in,  the message on the avast console says that for outlook exchange and internet mail "The provider is waiting for a subsystem to start".  Any way to get around this?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: mail servers keep getting set to 127.0.0.1
« Reply #5 on: January 19, 2005, 03:08:53 AM »
Now my only remaining question is whether or not Avast is still protecting my e-mail.  The way I read it, I got the impression that e-mail protection is through the avast server (127.0.0.1) and not truly resident in my computer.  That can't be right, can it?

To see if avast! is scanning emails, check one of these points:

1) Is the avast icon (the special one of email scanning) be shown in the system tray?

2) Is your email header with the lines X-Antivirus: avast! (VPS 0XXX-X, XX/XX/2004), Inbound message and X-Antivirus-Status: Clean? (Right click the message, choose Properties and Details)

To see the Standard Shield and other protection:
1) Is the 'a' blue icon swirling?
2) Right click the icon once and see what are the 'last scanned files'...
3) Use eicar virus test.

3) Are clean notes added at the bottom of the email? (Internet Mail provider settings)

You can test the security of your email system here: http://www.gfi.com/emailsecuritytest/

But since I stopped it from shoving those settings in,  the message on the avast console says that for outlook exchange and internet mail "The provider is waiting for a subsystem to start".  Any way to get around this?

Open the About box in Outlook, and click Disabled Items. Make sure the avast plugin is not on the list...
The message "The provider is waiting on the subsystem to start" will be shown there until you open MS Outlook   The plugin will be enable automatically.
But, are you sure that the Internet Mail provider (for OE) is showing the same message?

If you have Windows 98\Me, the change of the login settings is normal while using avast. See http://forum.avast.com/index.php?action=display;board=2;threadid=7913;start=0#msg64228
The best things in life are free.

chilipepper

  • Guest
Re: mail servers keep getting set to 127.0.0.1
« Reply #6 on: January 19, 2005, 08:13:37 PM »
Oy!! Sorry it takes me so long to get back to you.  I can't always get to the puter.  ANYhooo..... I did as you suggested and opened MS Outlook (It didn't happen before because I never use it.  Always use Express.) and now I can send and receive mail with the Avast settings.  I'm assuming that's possible in part because I put in the correct SMTP settings in the avast settings console.  It is still NOT scanning mail however.  During all my playing around while attempting to  send and receive mail,  I paused the outlook/exchange provider.  The "resume provider" option is non-functional for some reason and for the life of me I can't figure out how to re-activate the thing...can't find anything in the help section either.  This is the free version, btw.  I don't have a special e-mail scanning icon in the system tray...just the little blue " a sphere", which swirls occasionally.

Thanks, btw, for your help so far.  I think you're making progress with this dummy...<rueful grin>.

chilipepper

  • Guest
Re: mail servers keep getting set to 127.0.0.1
« Reply #7 on: January 20, 2005, 12:05:23 AM »
Belay my last.  When I posted that last post, I had sent and received one e-mail (each)which weren't scanned...at least the scan count didn't go up.  Just received and sent another one(each) and apparently my e-mail IS getting scanned now.  Well I'm confused as to why it didn't before and does now but I'm happy enough even though it still shows "The provider is waiting for a subsystem to start" for outlook/exchange.   I'd eventually like to know how to fix that but it isn't critical since I never use exchange.  Thanks again for your help. 
Glide on.....chilipepper

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: mail servers keep getting set to 127.0.0.1
« Reply #8 on: January 20, 2005, 02:25:41 AM »
"The provider is waiting for a subsystem to start" for outlook/exchange.   I'd eventually like to know how to fix that but it isn't critical since I never use exchange. 

This is not a problem... read my post above.
When you do not run (use) Outlook, this plugin will be 'sleeping' into avast. It will only awakes when you 'open' (run) Outlook.
Check your Internet Mail provider settings of avast... You must ask for Inbound and Outbound mail scanning there...
The best things in life are free.