Author Topic: ashbase.dll  (Read 14727 times)

0 Members and 1 Guest are viewing this topic.

Offline Michael312

  • Newbie
  • *
  • Posts: 15
ashbase.dll
« on: September 21, 2012, 12:52:12 PM »
Hi, I recently just moved into a house and set-uped my new computer which I haven't used in like a year.
I downloaded Avast 7 and tried to install it here's the error:

Code: [Select]
06.09.201218:45:18Started: 06.09.2012, 18:45:18
06.09.201218:45:18Operation set to INST_OP_UNKNOWN
06.09.201218:45:18Old version: ffffffff (-1)
06.09.201218:45:18SYNCER: Agent=Syncer/5.00 (ais-1466;p)
06.09.201218:45:18Running SETUP_AIS-5ba (1466)
06.09.201218:45:18Operating system: Windows 7 ver 6.1, build 7601, sp 1.0 [Service Pack 1]
06.09.201218:45:18Memory: 46% load. Phys:1680472/2097151K free, Page:4194303/4194303K free, Virt:2029284/2097024K free
06.09.201218:45:18Computer WinName: MYCOMPUTER-PC
06.09.201218:45:18Windows Net User: MyComputer-PC\Rawr
06.09.201218:45:18Cmdline: /sfx /sfxstorage "C:\Users\Rawr\AppData\Local\Temp\_av_sfx.tm~a05144" /GetEdition:free /brandcode "A" /srcpath "C:\Users\Rawr\DOWNLO~1" /sfxname "avast_free_antivirus_setup"
06.09.201218:45:18DldSrc set to sfx
06.09.201218:45:18Old version: ffffffff (-1)
06.09.201218:45:18Deleted registry: Software\AVAST Software\Avast\UpdateReady
06.09.201218:45:18Install check: SetupVersion does NOT exist
06.09.201218:45:18SGW32AIS::CheckIfInstalled set m_bAlreadyInstalled to 0
06.09.201218:45:20Setup GUI has been successfuly loaded from DLL.
06.09.201218:45:20SYNCER: Agent=Syncer/5.00 (ais-1466;p)
06.09.201218:45:20SYNCER: Type: use IE settings
06.09.201218:45:20SYNCER: Auth: another authentication, use WinInet
06.09.201218:45:20Ignoring cmdline switch: /GetEdition:free
06.09.201218:45:20Get registry: Software\Microsoft\Internet Explorer\Version=8.0.7601.17514
06.09.201218:45:20Operation set to INST_OP_INSTALL
06.09.201218:45:20GUID: eb418ec4-1607-4500-aa7a-9e3377afc377
06.09.201218:45:20SelectCurrent: selected server 'tmp sfx storage' from 'sfx'
06.09.201218:45:20SYNCER: Type: use IE settings
06.09.201218:45:20SYNCER: Auth: another authentication, use WinInet
06.09.201218:45:20Changed Edition=1
06.09.201218:45:20Entered SetupProcessAIS::Do( INST_OP_INSTALL )
06.09.201218:45:20Entered SetupProcessWin32Avast::Do( INST_OP_INSTALL )
06.09.201218:45:20Entered SetupProcessWin32::Do( INST_OP_INSTALL )
06.09.201218:45:20Entered SetupProcess::Do( INST_OP_INSTALL )
06.09.201218:45:20Used server: C:\Users\Rawr\AppData\Local\Temp\_av_sfx.tm~a05144
06.09.201218:45:27LoadPartInfo: jrog = jrog-a7 returned 00000000
06.09.201218:45:27LoadPartInfo: jrog2 = jrog2-5a4 returned 00000000
06.09.201218:45:27LoadPartInfo: program = prg_ais-5ba returned 00000000
06.09.201218:45:27LoadPartInfo: setup = setup_ais-5ba returned 00000000
06.09.201218:45:27LoadPartInfo: vps = vps_win32-12082100 returned 00000000
06.09.201218:45:27Part prg_ais-5ba was set to be installed
06.09.201218:45:27Part vps_win32-12082100 was set to be installed
06.09.201218:45:27Part setup_ais-5ba was set to be installed
06.09.201218:45:27Part jrog-a7 was set to be installed
06.09.201218:45:27Part jrog2-5a4 was set to be installed
06.09.201218:45:54SYNCER: Agent=Syncer/5.00 (ais-1466;p)
06.09.201218:45:54LoadPartInfo: jrog = jrog-a7 returned 00000000
06.09.201218:45:54LoadPartInfo: jrog2 = jrog2-5a4 returned 00000000
06.09.201218:45:54LoadPartInfo: program = prg_ais-5ba returned 00000000
06.09.201218:45:54LoadPartInfo: setup = setup_ais-5ba returned 00000000
06.09.201218:45:54LoadPartInfo: vps = vps_win32-12082100 returned 00000000
06.09.201218:45:54Part prg_ais-5ba was set to be installed
06.09.201218:45:54Part vps_win32-12082100 was set to be installed
06.09.201218:45:54Part setup_ais-5ba was set to be installed
06.09.201218:45:54Part jrog-a7 was set to be installed
06.09.201218:45:54Part jrog2-5a4 was set to be installed
06.09.201218:46:32Uninstalling aswTdi.sys
06.09.201218:46:32Stopping service aswTdi
06.09.201218:46:32OpenSCManager
06.09.201218:46:32OpenService
06.09.201218:46:32OpenService, errcode: 0x00000424
06.09.201218:46:32Service aswTdi stopped, errcode: 0x00000424
06.09.201218:46:32Cannot open reg. key:Software\Microsoft\Windows\CurrentVersion\App Paths\AvastUI.exe
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-18, C:\Windows\system32\config\systemprofile\NtUser.dat)
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-19, C:\Windows\ServiceProfiles\LocalService\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-20, C:\Windows\ServiceProfiles\NetworkService\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-1023, C:\Users\UpdatusUser\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-1024, C:\Users\Rawr\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-501, C:\Users\Guest\NtUser.dat)
06.09.201218:46:32Cannot load registry hive C:\Users\Guest\NtUser.dat, err=3.
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-82-3006700770-424185619-1745488364-794895919-4004696415, C:\Users\DefaultAppPool\NtUser.dat)
06.09.201218:46:32Cannot load registry hive C:\Users\DefaultAppPool\NtUser.dat, err=3.
06.09.201218:46:32Transferred: files 1, bytes 1, time 655 ms
06.09.201218:46:32Retries: total 0, files 0, servers 1
06.09.201218:46:32GetLicNumber: LoadLibrary( C:\Program Files\AVAST Software\Avast\ashBase.dll ) return value: 0x00000000
06.09.201218:46:32Error: ashBase.dll (C:\Program Files\AVAST Software\Avast\ashBase.dll) could not be loaded
06.09.201218:46:32DldSrc set to inet
06.09.201218:46:33Server definition(s) loaded for 'main': 185 (maintenance:0)
06.09.201218:46:33SelectCurrent: selected server 'Download354 AVAST5 Server' from 'main'
06.09.201218:46:33SYNCER: Type: use IE settings
06.09.201218:46:33SYNCER: Auth: another authentication, use WinInet
06.09.201218:46:33Sending stats 'http://stats7.avast.com/cgi-bin/iavs4stats.cgi': 00000000 204
06.09.201218:46:33NeedReboot=false
06.09.201218:46:33Return code: 0x00000005 [Access is denied.]
06.09.201218:46:33Stopped: 06.09.2012, 18:46:33


I've tried using aswclear, I've cleared avast 6 and avast 7. Same error.
I've also tried updating/repairing Microsoft Visual C++ 2008 (http://www.microsoft.com/en-us/download/details.aspx?id=11895) same error.

Please help!

Offline mikaelrask

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1557
Re: ashbase.dll
« Reply #1 on: September 21, 2012, 01:22:23 PM »
hey and welcome to the forum.

we need a bit further information from to be able to help you.

what os are you using?

what was your previous antivirus program before avast and how did uninstall it?
Windows 8.1 amd a10-5700 64 bit
12 GB ram 1 tb hard drive. Avast 18, MBAM

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #2 on: September 21, 2012, 01:55:40 PM »
I'm using windows 7 home premium and my last protection was avast or avg, I'm unsure as it was a year ago.
I've also used the remove avg tool to.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37101
Re: ashbase.dll
« Reply #3 on: September 21, 2012, 02:47:46 PM »
May essexboy can see the problem if you attach a OTL log

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #4 on: September 21, 2012, 03:15:53 PM »
How can I get the otl log? I really need a virus protection asap.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37101
Re: ashbase.dll
« Reply #5 on: September 21, 2012, 03:31:28 PM »

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #6 on: September 21, 2012, 03:41:02 PM »
Here's the log:

http://pastie.org/4772168

Hope we can get this working asap!

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: ashbase.dll
« Reply #7 on: September 21, 2012, 04:30:59 PM »
From the error report it does state access denied, which is unusual

No other AV's are evident.

The programme is not being installed at all, not even creating the directory

Looking at the reg key it is trying to access .. There is not one at that location on my win7

Delete the current setup copy on your desktop and download from the direct link  here

Then retry

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #8 on: September 21, 2012, 05:10:27 PM »
I downloaded the setup file you gave me, same error :||

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85629
  • No support PMs thanks
Re: ashbase.dll
« Reply #9 on: September 21, 2012, 05:35:33 PM »
Can you just post the error displayed to the screen as your copy and paste in the first topic lists more than one error.

06.09.201218:46:32OpenService, errcode: 0x00000424
06.09.201218:46:32Service aswTdi stopped, errcode: 0x00000424
06.09.201218:46:32Cannot open reg. key:Software\Microsoft\Windows\CurrentVersion\App Paths\AvastUI.exe

06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-20, C:\Windows\ServiceProfiles\NetworkService\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-1023, C:\Users\UpdatusUser\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION
06.09.201218:46:32RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-1024, C:\Users\Rawr\NtUser.dat)
06.09.201218:46:32Load registry hive ERROR_SHARING_VIOLATION

06.09.201218:46:32Cannot load registry hive C:\Users\Guest\NtUser.dat, err=3.
06.09.201218:46:32Cannot load registry hive C:\Users\DefaultAppPool\NtUser.dat, err=3.
Error 3 = The system cannot find the path specified.

06.09.201218:46:32GetLicNumber: LoadLibrary( C:\Program Files\AVAST Software\Avast\ashBase.dll ) return value: 0x00000000
06.09.201218:46:32Error: ashBase.dll (C:\Program Files\AVAST Software\Avast\ashBase.dll) could not be loaded

And finally:
06.09.201218:46:33Return code: 0x00000005 [Access is denied.]
06.09.201218:46:33Stopped: 06.09.2012, 18:46:33

####
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #10 on: September 21, 2012, 05:44:51 PM »
Here's the error I get when installing the new link, same error:

06.09.201223:41:06Started: 06.09.2012, 23:41:06
06.09.201223:41:06Operation set to INST_OP_UNKNOWN
06.09.201223:41:06Old version: ffffffff (-1)
06.09.201223:41:06SYNCER: Agent=Syncer/5.00 (ais-1466;p)
06.09.201223:41:06Running SETUP_AIS-5ba (1466)
06.09.201223:41:06Operating system: Windows 7 ver 6.1, build 7601, sp 1.0 [Service Pack 1]
06.09.201223:41:06Memory: 73% load. Phys:831724/2097151K free, Page:1769860/4194303K free, Virt:2029284/2097024K free
06.09.201223:41:06Computer WinName: MYCOMPUTER-PC
06.09.201223:41:06Windows Net User: MyComputer-PC\Rawr
06.09.201223:41:06Cmdline: /sfx /sfxstorage "C:\Users\Rawr\AppData\Local\Temp\_av_sfx.tm~a04908" /GetEdition:free /brandcode "A" /srcpath "C:\Users\Rawr\Desktop" /sfxname "avast_free_antivirus_setup"
06.09.201223:41:06DldSrc set to sfx
06.09.201223:41:06Old version: ffffffff (-1)
06.09.201223:41:06Deleted registry: Software\AVAST Software\Avast\UpdateReady
06.09.201223:41:06Install check: SetupVersion does NOT exist
06.09.201223:41:06SGW32AIS::CheckIfInstalled set m_bAlreadyInstalled to 0
06.09.201223:41:07Setup GUI has been successfuly loaded from DLL.
06.09.201223:41:07SYNCER: Agent=Syncer/5.00 (ais-1466;p)
06.09.201223:41:07SYNCER: Type: use IE settings
06.09.201223:41:07SYNCER: Auth: another authentication, use WinInet
06.09.201223:41:07Ignoring cmdline switch: /GetEdition:free
06.09.201223:41:07Get registry: Software\Microsoft\Internet Explorer\Version=8.0.7601.17514
06.09.201223:41:07Operation set to INST_OP_INSTALL
06.09.201223:41:07GUID: d9c2c085-2898-43ac-86ee-7f94191554e8
06.09.201223:41:07SelectCurrent: selected server 'tmp sfx storage' from 'sfx'
06.09.201223:41:07SYNCER: Type: use IE settings
06.09.201223:41:07SYNCER: Auth: another authentication, use WinInet
06.09.201223:41:07Changed Edition=1
06.09.201223:41:07Entered SetupProcessAIS::Do( INST_OP_INSTALL )
06.09.201223:41:07Entered SetupProcessWin32Avast::Do( INST_OP_INSTALL )
06.09.201223:41:07Entered SetupProcessWin32::Do( INST_OP_INSTALL )
06.09.201223:41:07Entered SetupProcess::Do( INST_OP_INSTALL )
06.09.201223:41:07Used server: C:\Users\Rawr\AppData\Local\Temp\_av_sfx.tm~a04908
06.09.201223:41:12LoadPartInfo: jrog = jrog-a7 returned 00000000
06.09.201223:41:12LoadPartInfo: jrog2 = jrog2-5a4 returned 00000000
06.09.201223:41:12LoadPartInfo: program = prg_ais-5ba returned 00000000
06.09.201223:41:12LoadPartInfo: setup = setup_ais-5ba returned 00000000
06.09.201223:41:12LoadPartInfo: vps = vps_win32-12082100 returned 00000000
06.09.201223:41:12Part prg_ais-5ba was set to be installed
06.09.201223:41:12Part vps_win32-12082100 was set to be installed
06.09.201223:41:12Part setup_ais-5ba was set to be installed
06.09.201223:41:12Part jrog-a7 was set to be installed
06.09.201223:41:12Part jrog2-5a4 was set to be installed
06.09.201223:41:40SYNCER: Agent=Syncer/5.00 (ais-1466;p)
06.09.201223:41:40LoadPartInfo: jrog = jrog-a7 returned 00000000
06.09.201223:41:40LoadPartInfo: jrog2 = jrog2-5a4 returned 00000000
06.09.201223:41:40LoadPartInfo: program = prg_ais-5ba returned 00000000
06.09.201223:41:40LoadPartInfo: setup = setup_ais-5ba returned 00000000
06.09.201223:41:40LoadPartInfo: vps = vps_win32-12082100 returned 00000000
06.09.201223:41:40Part prg_ais-5ba was set to be installed
06.09.201223:41:40Part vps_win32-12082100 was set to be installed
06.09.201223:41:40Part setup_ais-5ba was set to be installed
06.09.201223:41:40Part jrog-a7 was set to be installed
06.09.201223:41:40Part jrog2-5a4 was set to be installed
06.09.201223:42:12Uninstalling aswTdi.sys
06.09.201223:42:12Stopping service aswTdi
06.09.201223:42:12OpenSCManager
06.09.201223:42:12OpenService
06.09.201223:42:12OpenService, errcode: 0x00000424
06.09.201223:42:12Service aswTdi stopped, errcode: 0x00000424
06.09.201223:42:12Cannot open reg. key:Software\Microsoft\Windows\CurrentVersion\App Paths\AvastUI.exe
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-18, C:\Windows\system32\config\systemprofile\NtUser.dat)
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-19, C:\Windows\ServiceProfiles\LocalService\NtUser.dat)
06.09.201223:42:12Load registry hive ERROR_SHARING_VIOLATION
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-20, C:\Windows\ServiceProfiles\NetworkService\NtUser.dat)
06.09.201223:42:12Load registry hive ERROR_SHARING_VIOLATION
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-1023, C:\Users\UpdatusUser\NtUser.dat)
06.09.201223:42:12Load registry hive ERROR_SHARING_VIOLATION
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-1024, C:\Users\Rawr\NtUser.dat)
06.09.201223:42:12Load registry hive ERROR_SHARING_VIOLATION
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-21-2440313476-945273285-359036203-501, C:\Users\Guest\NtUser.dat)
06.09.201223:42:12Cannot load registry hive C:\Users\Guest\NtUser.dat, err=3.
06.09.201223:42:12RegLoadKey(HKEY_USERS, Av_S-1-5-82-3006700770-424185619-1745488364-794895919-4004696415, C:\Users\DefaultAppPool\NtUser.dat)
06.09.201223:42:12Cannot load registry hive C:\Users\DefaultAppPool\NtUser.dat, err=3.
06.09.201223:42:12Transferred: files 1, bytes 1, time 827 ms
06.09.201223:42:12Retries: total 0, files 0, servers 1
06.09.201223:42:12GetLicNumber: LoadLibrary( C:\Program Files\AVAST Software\Avast\ashBase.dll ) return value: 0x00000000
06.09.201223:42:12Error: ashBase.dll (C:\Program Files\AVAST Software\Avast\ashBase.dll) could not be loaded
06.09.201223:42:15DldSrc set to inet
06.09.201223:42:15Server definition(s) loaded for 'main': 185 (maintenance:0)
06.09.201223:42:15SelectCurrent: selected server 'Download351 AVAST5 Server' from 'main'
06.09.201223:42:15SYNCER: Type: use IE settings
06.09.201223:42:15SYNCER: Auth: another authentication, use WinInet
06.09.201223:42:16Sending stats 'http://stats7.avast.com/cgi-bin/iavs4stats.cgi': 00000000 204
06.09.201223:42:16NeedReboot=false
06.09.201223:42:16Return code: 0x00000005 [Access is denied.]
06.09.201223:42:16Stopped: 06.09.2012, 23:42:16

Edit: Sorry didn't read what you said, the error on my screen goes:

Uninstalling progess:
Creating system restore point

[ A BIG RED X IS HERE ]
Setup finished
There was an error while completing the setup process

« Last Edit: September 21, 2012, 06:17:32 PM by Michael312 »

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #11 on: September 21, 2012, 07:23:06 PM »
Any ideas?

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: ashbase.dll
« Reply #12 on: September 21, 2012, 07:39:39 PM »
Currently checking out Load registry hive ERROR_SHARING_VIOLATION


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85629
  • No support PMs thanks
Re: ashbase.dll
« Reply #13 on: September 21, 2012, 07:42:23 PM »
Has any part of avast been installed ?
e.g. is there an avast entries in the Task Manager for avastUI.exe (most likely as the icon would have the Red X) and avastSvc.exe, this is the main scanning engine of avast ?

Did you run the avast setup (installation) file from an administrator account ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Michael312

  • Newbie
  • *
  • Posts: 15
Re: ashbase.dll
« Reply #14 on: September 21, 2012, 08:01:38 PM »
No sign of avast in task manager, and yep I do run as administrator.