Author Topic: SLOW SCANNING  (Read 17169 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83517
  • No support PMs thanks
Re: SLOW SCANNING
« Reply #15 on: October 02, 2012, 12:54:58 AM »
I generally don't bother monitoring the scanning rate MB as that will change as the scan progresses and when it hits different file types and sizes. The only things that I monitor are the overall scan duration and the amount of data scanned (GBs).

So you are seeing a massive change when using the persistent cache, scan duration for what should be the same amount of data scanned.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83517
  • No support PMs thanks
Re: SLOW SCANNING
« Reply #16 on: October 02, 2012, 01:17:40 AM »
That information in isolation is meaningless with no data/information to compare against.

My quick scan only takes around three minutes, that too is meaningless as my system specification is likely to be different to yours, as is the amount of data scanned and if you have made any changes to the default settings in the quick scan.

You can only really compare a scan duration against your own previous scans.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline blowtorch73

  • Sr. Member
  • ****
  • Posts: 238
Re: SLOW SCANNING
« Reply #17 on: October 02, 2012, 11:30:39 AM »
So you are seeing a massive change when using the persistent cache, scan duration for what should be the same amount of data scanned.

All down to you David, thank you so much! :)

Offline blowtorch73

  • Sr. Member
  • ****
  • Posts: 238
Re: SLOW SCANNING
« Reply #18 on: October 02, 2012, 11:37:35 AM »
That information in isolation is meaningless with no data/information to compare against.

My quick scan only takes around three minutes, that too is meaningless as my system specification is likely to be different to yours, as is the amount of data scanned and if you have made any changes to the default settings in the quick scan.

You can only really compare a scan duration against your own previous scans.
You beat me to it david, I was just going to say that :-[ :-[ :-[ :-[

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83517
  • No support PMs thanks
Re: SLOW SCANNING
« Reply #19 on: October 02, 2012, 11:52:40 AM »
So you are seeing a massive change when using the persistent cache, scan duration for what should be the same amount of data scanned.

All down to you David, thank you so much! :)

You're welcome.

<snip quote>
You beat me to it david, I was just going to say that :-[ :-[ :-[ :-[

You have to be fast on the avast forums, they are very active ;D
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline blowtorch73

  • Sr. Member
  • ****
  • Posts: 238
Re: SLOW SCANNING
« Reply #20 on: November 18, 2012, 04:16:53 AM »
Just changed over to Avast Internet Security and the first full scan has been running for well over 2 hours with just 16% scanned. How can I speed this up????

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83517
  • No support PMs thanks
Re: SLOW SCANNING
« Reply #21 on: November 18, 2012, 11:51:24 AM »
You don't say how you changed over to AIS if this was a clean install or possibly even an install over the top ?
There is a possibility that the Persistent Cache (as previously mentioned) has to be built up again. avastUI, Scan Computer, Scan (that you want to do) name, Settings, Performance, Persistent cache (check both options to use and crucially store). You can also increase the Scan priority,but that would have a greater impact on system performance.

You don't mention if you have changed any settings from the defaults ?

You also don't give any idea how long a full scan took previously ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline JohnMWoods

  • Newbie
  • *
  • Posts: 2
Free? Yes. But why such a slow scan?
« Reply #22 on: November 25, 2013, 10:19:20 PM »
Avast pro antivirus free -- REALLY? 3 hours to only get to 6% of the total "QUICK" scan! Why so slow?

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: SLOW SCANNING
« Reply #23 on: November 25, 2013, 10:30:31 PM »
Telling speed/time and such doesn't mean a thing without more details.

John,
don't change the topic of a thread please.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83517
  • No support PMs thanks
Re: SLOW SCANNING
« Reply #24 on: November 25, 2013, 10:46:08 PM »
Avast pro antivirus free -- REALLY? 3 hours to only get to 6% of the total "QUICK" scan! Why so slow?

3 hours is extremely unusual - However, no one can say as we don't know anything about your system, Operating System, CPU, RAM and size of HDD and data to be scanned ?
Did you make any changes to the default settings for the Quick scan ?

Another crucial question is - Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?

Note: There isn't an avast! Pro antivirus program that is 'free', do you mean you are using the avast! Pro antivirus trial version (30 day free trial) ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline JohnMWoods

  • Newbie
  • *
  • Posts: 2
Re: SLOW SCANNING
« Reply #25 on: November 26, 2013, 01:37:05 AM »
Thank you for your response and I am sorry for being vague in my post and for the delay in getting the blanks filled in. This is a very old Dell Inspiron 1200; XP Pro SP3. 1.3GHz, 760MB RAM and the HDD is 40G with a scant 23 percent free space . It is the trial version, yes. Sadly, MS Security Essentials is still installed on the machine. I am helping out my friend who is determined to keep using this computer. As I type this note, the progress is only at 21 percent. And forgive me to the high-on-his-horse creep who cautioned me not to change topics in a single thread, but 21 percent after SO many hours does indeed constitute SLOW SCANNING, ergo, this IS the appropriate thread you self-centered, ill-mannered malcontent. Keep up with those poorly placed admonishments and you will scare people away an creep factor alone.
« Last Edit: November 26, 2013, 01:55:39 AM by JohnMWoods »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83517
  • No support PMs thanks
Re: SLOW SCANNING
« Reply #26 on: November 26, 2013, 01:55:43 AM »
The second resident AV being installed would throw a spanner in the works, duplication of scanning being just one issue.

Having two AVs on an old system which is probably low on system resources (CPU and RAM) is likely to compound this further.

Aside from the above there can be times when they could conflict as they fight for control, a bit like two dogs fighting over a bone. Lets say avast is going to open a file for scanning, the second AV sees this request and its low level driver locks the file and scans it before allowing the first scan to proceed.

A worst case scenario is that the two low level drivers lock up.

PS Eddy is not saying it is the wrong topic or off-topic, but that to even begin to help we need more information (such as I asked). You did change your Posts Subject (from that of the Topic), anyone that responds directly to your post, would retain the subject title that you gave (so it can get confused), which is different to the Topics Title.

Something that you should know, A) most of the people who help in these forums are volunteers and B) many of them don't have English as their first language, so meaning/intent can become confused.

So getting irate and throwing around insults doesn't help keep the topic civil.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Swarm

  • Newbie
  • *
  • Posts: 1
Re: SLOW SCANNING
« Reply #27 on: December 07, 2013, 07:55:55 AM »
Hi guys, also having slow scanning problems since installing Avast 9 Free, upgrading from version 8.  Scanning a small file, 1.6MB, which previously took only seconds with version 8, now taking 15+ minutes to complete.

No other AV installed
No changes to system since installing version 9
System: Toshiba laptop, AMD E350 1.6GHz, 4GB, Win7.

Also, anyone know whats the go with the "????"; for example, if I go to Scan and open the drop down list to select type of scan there are 4/5 scan types and about 20 entries labelled ????.  Also shows up when running file scan, i.e. right click on file select scan with avast, scan window opens, as with version 8, but window remains empty and a taskbar popup appears with the % complete bar and  the msg "???? / Running"

Noticed a few other quirks as well, almost as if version 9 hasn't quite been finished off.

???? is four question marks ? ? ? ?
« Last Edit: December 07, 2013, 07:57:48 AM by Swarm »

Offline COMPUTIAC

  • Jr. Member
  • **
  • Posts: 55
Re: SLOW SCANNING
« Reply #28 on: December 16, 2013, 06:08:40 PM »
I have exactly the same problem, with the exception of the  ???
Whenever I download some thing, I save it to the desktop, then scan with Avast. It used to take seconds to do this. Now it takes several minutes. 
Thank's, COMPUTIAC

ASUS  M5A99X EVO R2.0 - MB, AMD FX-8350 - CPU, 16GB RAM, Win 7 Home Prem.Avast 2014.9.0.2011, MBAM Pro, SAS Pro, SpywareBlaster, Firefox(latest)

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6713
  • Trust only what you test yourself!
Re: SLOW SCANNING
« Reply #29 on: December 16, 2013, 06:24:09 PM »
I have exactly the same problem, with the exception of the  ???
Whenever I download some thing, I save it to the desktop, then scan with Avast. It used to take seconds to do this. Now it takes several minutes.
Your problem is not the same. That said there are many variables to consider.
Size of file, packer settings, etc. One thing you may want to do is to update to
v2014 2010b http://forum.avast.com/index.php?topic=142550.0 "use the custom install option".
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.