Author Topic: Having problems with auto update.  (Read 5962 times)

0 Members and 1 Guest are viewing this topic.

Offline 24k

  • Newbie
  • *
  • Posts: 5
Having problems with auto update.
« on: January 27, 2005, 04:49:51 PM »
Hi all

The problem is, it wont auto update the virus database its saying there is an error connecting the the server.

Last night i was able to manually download the virus database and install it that way.

I have tried changing the proxy settings but its still no good.

I have re installed avast and that never worked either.

Wat should the exact settings be for my proxy??

Is there a problem with the avast server?

Or is something else wrong?

What i cant understand is its been working fine for a couple of months and all of a sudden its like this.

And both my NAV firewall and Windows firewall both recognize avast.

I have really tried everything with my avast home edition..

Please if u could help it would be grate.

Thanks 4 your time

Offline lee20

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2326
  • The only true failure is when you give up
Re: Having problems with auto update.
« Reply #1 on: January 27, 2005, 05:22:19 PM »
Welcome 24k,

You only need the proxy settings set up in avast if you use a proxy, do you?

Quote
Is there a problem with the avast server?

Or is something else wrong?

No and No.

Right click the avast "A" ball in your taskbar (next to your system clock) and select 'program setting's', then choose update (connections), then check the box i have circled red if your on Dial up, and the blue one if your in Broadband. (see below)
Then choose update (basic) and make sure there both on Automatic. (see below)
Also you could check the avast log viewer for any errors to do with updates. Right click the avast "A" ball in your taskbar (next to your system clock) and select 'avast log viewer')

--lee



Then


"Anyone who has never made a mistake has never tried anything new."-Albert Einstein

Comodo Firewall, Avast 4.8, SpywareBlaster, Spybot + superantispyware, PeerGuardian and ALL software patched!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67249
Re: Having problems with auto update.
« Reply #2 on: January 27, 2005, 05:40:29 PM »
I have tried changing the proxy settings but its still no good.
Wat should the exact settings be for my proxy??

Make sure your browser is not set to "Work Offline" (this option is generally in the File menu). If it doesn't help, try switching the proxy settings from "Auto-detect" to "No proxy" (I'm assuming you're not connecting to the Internet via proxy).

Left click the avast icon > Settings
Update (Basic) > Details > Proxy
The best things in life are free.

Offline 24k

  • Newbie
  • *
  • Posts: 5
Re: Having problems with auto update.
« Reply #3 on: January 27, 2005, 05:44:05 PM »
No i dont use a proxy, at home...

Do u hav a screen shot of what my proxy setting's should be set to???

Because for some reason last night i remember going in to it and changing something.

I will be home soon so i will try those suggestions out.

Thanks alot mate hopefully they should work.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67249
Re: Having problems with auto update.
« Reply #4 on: January 27, 2005, 05:48:20 PM »
No i dont use a proxy, at home...

So, set it for 'no proxy' at all...
In other words, change it form 'Automatic detection' to 'No proxy'... Can you do that?
The best things in life are free.

Offline 24k

  • Newbie
  • *
  • Posts: 5
Re: Having problems with auto update.
« Reply #5 on: January 27, 2005, 06:04:33 PM »
I have done all that...

But it still wont auto update..

It shows a message showing

 - you are not connected to the Internet.
 - your firewall does not allow the program "avast*.setup" to access the Internet; you can find details in help or read the FAQ section on avast! website.
 - your HTTP proxy settings are incorrect.
 - the server is inaccessible because of a network error or maintenance.

And in the log view i have these errors

7.01.2005 16:57:49 package: ERROR:HttpGetWinsock, WinsockTcpConnect() returned 0x0000274D

27.01.2005 16:57:54 general: InvalidateCurrent: invalidated server 'Download2 AVAST server' from 'main'

27.01.2005 16:57:54 internet: while trying to get file 'servers.def', error 0x20000004 has occured, try 1

Anything else i can try???

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31303
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Having problems with auto update.
« Reply #6 on: January 27, 2005, 06:11:33 PM »
Remove the firewall and try to update. If that is working, you know where to look. ;)

Offline 24k

  • Newbie
  • *
  • Posts: 5
Re: Having problems with auto update.
« Reply #7 on: January 27, 2005, 06:16:28 PM »
I turned off my firewall

Guess what it worked

So how do i get my Norton Firewall to except Avast auto updates??

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85572
  • No support PMs thanks
Re: Having problems with auto update.
« Reply #8 on: January 27, 2005, 06:17:32 PM »
Try a manual update (of iAVS or Program), your firewall will/should probably ask if avast.setup should be allowed access to the internet, answer yes.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline 24k

  • Newbie
  • *
  • Posts: 5
Re: Having problems with auto update.
« Reply #9 on: January 27, 2005, 06:41:21 PM »
Finally

All done

I went through all the programes that have a permit saying yes...

There where more then 1 for avast.setup there where about 4...

One of those said block....

So i unblocked it, now its fine...

Thanks 4 your help every1...

I know i would get there in the end  ;)