Author Topic: Is Avast causing Explorer to start at W7 startup?  (Read 11650 times)

0 Members and 1 Guest are viewing this topic.

Offline papadiva

  • Jr. Member
  • **
  • Posts: 29
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #15 on: October 18, 2012, 02:23:49 AM »


Check!
Same (= No) result, at the next startup explorer still shows.
 :'(


Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44101
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #16 on: October 18, 2012, 02:53:40 AM »

Thanks Ryan,
My system just restarted and the Libraries Folder didn't pop up.

I followed the outline in the link you had posted:
http://www.techspot.com/vb/topic21035.html
Quote
1.Start>Run>Regedit>ok

2.Now navigate to the following key:-
HKEY_ LOCAL_ MACHINE\SOFTWARE\Microsoft\Win­dows NT\CurrentVersion\Winlogon

3.Look down the list in the Right Hand pane,scroll down to the value Userinit This value should read: C:\WINDOWS\system32\userinit.e­xe, (The comma at the end must also be there)

4.If the value is different from that mentioned above then Right Click on the Userinit value and, from the drop down menu, select Modify. Type in the value C:\WINDOWS\system32\userinit.e­xe,in the Modify dialogue box click OK

5.Exit the Registry.Restart your computer.

Thanks

Ok I think this should finally fix your problem:
http://forum.avast.com/index.php?topic=74950.msg621292#msg621292


It did the trick when I had the problem and I believe it also took care of Igor's problem.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline papadiva

  • Jr. Member
  • **
  • Posts: 29
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #17 on: October 18, 2012, 02:59:35 PM »

Thx bob3160, I appreciate your input, but this didn't work either.

It was already unchecked.


Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44101
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #18 on: October 18, 2012, 03:38:24 PM »

Thx bob3160, I appreciate your input, but this didn't work either.

It was already unchecked.


???  Had nothing to do with unchecking so I don't know what you meant by your answer.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline papadiva

  • Jr. Member
  • **
  • Posts: 29
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #19 on: October 19, 2012, 01:57:06 AM »

I searched the registry and I found out that there are TWO winlogons:

HKEY_ LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
         C:\WINDOWS\system32\userinit.exe,

HKEY_ LOCAL_ MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Winlogon
         userinit.exe

I know that the 1st winlogon is mandatory, while the second seems to be needed when using the 64-bit version, but does it really?

Offline CharleyO

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7085
  • Be alert for error code - ID 10T
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #20 on: October 19, 2012, 04:19:20 AM »
***

If you are running W7 64-bit, then that is a legitimate key.

But, there is also malware related to this key.

I suggest you post this in the "Virus & Worms" section.

Read the sticky post at the top of that section on what to use & what to attach so that help can be given.


***
Self-built desktop (8 years old) - AMD64 3200+_Gigabyte GA-K8NS Ultra-939_4 gb RAM_GeForceFX 5800w/256 ram_XP/SP3_Avast 7_MBAM_ZA Free __and__ Toshiba Satellite Laptop_W7-64bit_ 4 gb Ram_Avast 8_MBAM

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83760
  • No support PMs thanks
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #21 on: October 19, 2012, 12:07:48 PM »

I searched the registry and I found out that there are TWO winlogons:

HKEY_ LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
         C:\WINDOWS\system32\userinit.exe,

HKEY_ LOCAL_ MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Winlogon
         userinit.exe

I know that the 1st winlogon is mandatory, while the second seems to be needed when using the 64-bit version, but does it really?


Based on what has been said before it appears that these these entries require a comma after the path as in your first reference:
Quote
HKEY_ LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
         C:\WINDOWS\system32\userinit.exe,
But your second reference in the Wow6432Node registry key doesn't have the comma after the userinit.exe reference.

Now I don't know if this is just a typo on your part or not ?
If it isn't a typo, then try adding the comma after the path value in the second registry key you posted and see if that makes a difference.

I'm also not sure if the path is correct as it only shows the file name and no full path before it, perhaps that too is required.

####
If there are any other 64bit OS users that can check that same registry key and see what the correct value should be.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11032
  • No support PM's thanks
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #22 on: October 19, 2012, 12:37:35 PM »
This should be the key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Winlogon

and when clicking on Winlogon you should see this

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83760
  • No support PMs thanks
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #23 on: October 19, 2012, 12:40:50 PM »
Thanks for the confirmation Craig.

@ papadiva
Yep as mentioned that userinit.exe must have a comma after the value, so if it wasn't a typo the Userinit value needs to be changed to userinit.exe, and hopefully that will resolve this.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Charyb

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2313
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #24 on: October 19, 2012, 12:56:06 PM »

I searched the registry and I found out that there are TWO winlogons:

HKEY_ LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
         C:\WINDOWS\system32\userinit.exe,

HKEY_ LOCAL_ MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Winlogon
         userinit.exe

I know that the 1st winlogon is mandatory, while the second seems to be needed when using the 64-bit version, but does it really?


My registry looks exactly like what I have quoted from papadiva - no comma after userinit.exe in Wow6432Node registry entry. I have a 64bit system and have no problems.

@papadiva - please make certain you have a plan to start your computer and have your important info backed up before you make any changes to the registry just in case something doesn't go as planned.


***

If you are running W7 64-bit, then that is a legitimate key.

But, there is also malware related to this key.

I suggest you post this in the "Virus & Worms" section.

Read the sticky post at the top of that section on what to use & what to attach so that help can be given.


***

CharleyO made a very good suggestion. Even if it is not malware, the problem may be found by one of the tools used by the malware removal experts.
« Last Edit: October 19, 2012, 01:30:29 PM by Charyb »

Offline papadiva

  • Jr. Member
  • **
  • Posts: 29
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #25 on: October 19, 2012, 02:01:37 PM »
Oh well, what I already expected: the comma after the 2nd userinit in my registry doesn't matter.
In other words, with or without comma, explorer keeps popping up after W7 startup.

But I will have a further look, some guys at the Lenovo and Microsoft forum gave me some interesting suggestions too.
Of course, when either of you had the ultimate and final solution, I will also  inform the other forums (fora?)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83760
  • No support PMs thanks
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #26 on: October 19, 2012, 03:39:02 PM »
If you haven't got the comma, it certainly wouldn't hurt or take long to add/test the theory.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44101
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #27 on: October 20, 2012, 04:41:52 PM »
The information I had posted specifically mentioned that the comma (,) is required following the exe.
We can only post and offer suggestions. We depend on you to follow those suggestions. :)
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline papadiva

  • Jr. Member
  • **
  • Posts: 29
Re: Is Avast causing Explorer to start at W7 startup?
« Reply #28 on: October 22, 2012, 10:19:02 PM »
DavidR, bob3160,

I did add that comma after userinit, but the result is the same: explorer keeps popping up after W7 startup.

Thanks for the input, the search goes on  :)

However, I switched to 'viruses and worms' with this same question (DavidR is there too!) as I don't think anymore that this winlogon thing is causing this issue.
Some are thinking that I removed a certain program that's causing this because of its -uh- residu's.
« Last Edit: October 22, 2012, 10:25:45 PM by papadiva »