Author Topic: Network shield prevents access to router web setup - Avast 1474  (Read 51251 times)

0 Members and 1 Guest are viewing this topic.

Offline Klinker

  • Full Member
  • ***
  • Posts: 100
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #15 on: November 07, 2012, 04:12:52 PM »
Doesn't just effect Win8 because I'm using XP SP3, AIS 7.1474, no third party security, using Netgear WNDR3300. Router page never loads, but everything else seems to working o.k. Unlike a couple of above people, the nshield.log is empty.

Question: What is the safest and correct action I can take with AIS to access my router login page on a temporary basis until this problem is fixed? Thanks.

Offline Broken Hope

  • Jr. Member
  • **
  • Posts: 67
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #16 on: November 07, 2012, 06:18:26 PM »
Hallo..

I'm not able to reproduce the bug here in Avast!, then I can ask you if you can specify the router/modem types where the problem occurs and firmware versions (for example if you are using openwrt etc..)

The slow-down problem occurs only with router pages (all or any specific pages), or on classic web pages too?

Does help if you restart the Avast Service by Service Manager?

Additionally, do you use another third party security software for traffic inspection? Firewall, parental control, etc?

!!! PLEASE, TRY TO REPLY ALL QUESTRIONS !!!

Thank you.

I'm using an Asus RT-N56U router with stock firmware and a cable modem that is provided by my ISP, it's a custom design.

The slowdown only occurs when accessing 192.x.x.x addresses for me so far.

I'm not using any other software that affects network traffic, Windows Firewall is disabled etc.

Does the info from my nshield.log file not shed any light on the issue at all?

Offline lash78

  • Newbie
  • *
  • Posts: 19
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #17 on: November 07, 2012, 07:35:54 PM »
I'm using an ADSL router TPLINK TD-W8960NB and a TL-WA801ND access point. No slowdown, the pages are loading fast, but sometimes (about every 5.-8. attempt) the page never loads or elements are missing. This does not happens with build 1466.

Offline Anarion

  • Jr. Member
  • **
  • Posts: 26
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #18 on: November 07, 2012, 10:16:05 PM »
Same issue here, Telewell TW-EAV510 ADSL2+/VDSL2 modem. Avast internet security and windows 8 pro 64-bit.

(I had to delete a lot of recent errors since it was about 1500KB in size)
« Last Edit: November 07, 2012, 10:21:38 PM by Anarion »
Windows 8.1 Pro with Media Center x64 | Avast IS | MBAM on-demand

Offline Zdenek

  • Avast team
  • Jr. Member
  • *
  • Posts: 38
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #19 on: November 08, 2012, 02:30:45 PM »
Hallo

I have prepared new version of the aswnseng.dll with one fix which may solve the problem.

Please try it, and report results.

How to install the fix:

1. Download it from here http://public.avast.com/~polach/aswnseng_01.zip and unpack it.

2. Disable the Self Defense in the Avast!. Go to the Settings->Troubleshooting and uncheck enable avast! self defense module

3. Stop the Avast! service. Go to the Control Panel->Administrative Tools->Services. Then locate the avast! Antivirus service ans stop it.

4. Replace the aswnseng.dlll in c:\Program Files\AVAST Software\Avast or where you have Avast! installed. You will need adminstrative rights to do that

5. Start the avast! service again in Services list

6. Enable Web Shield if is disabled.

Provide tests and report results.

Thank you.



Offline Klinker

  • Full Member
  • ***
  • Posts: 100
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #20 on: November 08, 2012, 03:46:09 PM »

I have prepared new version of the aswnseng.dll with one fix which may solve the problem.

Please try it, and report results.



Tried new aswnseg.dll as suggested and experienced same failure as before on XP AIS system.

I am re installing the "old" aswnseg.dll to avoid any additional problems.

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1879
    • AVAST Software
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #21 on: November 08, 2012, 03:52:48 PM »


Tried new aswnseg.dll as suggested and experienced same failure as before on XP AIS system.

I am re installing the "old" aswnseg.dll to avoid any additional problems.


Hi Klinker, aswnseng.dll is used on Windows 8 ONLY. Not even loaded on Windows XP.

Offline Klinker

  • Full Member
  • ***
  • Posts: 100
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #22 on: November 08, 2012, 04:26:19 PM »




Hi Klinker, aswnseng.dll is used on Windows 8 ONLY. Not even loaded on Windows XP.


Lukor:

Interesting..... I just rechecked the Avast folder and I'm looking right at it. There is aswnseng.dll File Version 7.0.1474.106 and I'm on an XP machine with AIS.

Whether it's supposed to be in there or not on an XP system, I still can't access the router login page.

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1879
    • AVAST Software
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #23 on: November 08, 2012, 04:31:20 PM »
The DLL is probably copied there as well, to simplify things, but it is really not used and on XP different code is executed. This means that either the nshield.log from other users are not relevant to the problem at all - and it is not connected with any of these network shield changes for Win8 - or, yours is completely different problem.


Could you please try if disabling any particular shield helps? Such as trying with Network Shield and then Web Shield turned off ?


Thanks.

Offline Klinker

  • Full Member
  • ***
  • Posts: 100
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #24 on: November 08, 2012, 04:48:46 PM »
Just tried disabling Network and Web Shields individually as well as simultaneously, but I still can't get the login page.

I only log in to the router around the beginning of each month just to check logs, change passwords and for any router updates, etc., so I know it was working  prior to the latest Avast updates in October. Other than that, I really don't have any clue as to why I can't get the login page to load now.

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1879
    • AVAST Software
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #25 on: November 08, 2012, 05:02:22 PM »
And what about script shield?

Offline lash78

  • Newbie
  • *
  • Posts: 19
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #26 on: November 08, 2012, 05:49:25 PM »
This patch doesn't solved the issue for me.

Offline Klinker

  • Full Member
  • ***
  • Posts: 100
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #27 on: November 08, 2012, 05:53:33 PM »
I appreciate your help, but I'm going to have to put this issue on the back burner for now.

I'm not sure if it was messing with the Avast shields, an issue with my ISP (always a possibility) or if it was just a coincidence, but I spent the last 30 minutes trying to re-establish my internet connection after disabling the shields. Internet seems to be working now and I did a repair of Avast just in case which seemed to smooth things out.

Again thanks for the help, but I can't afford risking losing internet connection right now ....I'll post back when I can to address the router login issue, but will monitor this thread for possible solutions.


Offline Broken Hope

  • Jr. Member
  • **
  • Posts: 67
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #28 on: November 08, 2012, 05:56:32 PM »
The new DLL makes no difference for me, still can't access local router/modem pages properly.

Here's a log of the test.

Code: [Select]
INFO: Call Stop method to the DLL
INFO: By platform is selected Network Stream Filter technology
INFO: Going to load NSF Engine from location: C:\Program Files\AVAST Software\Avast\aswnseng.dll
INFO: By platform is selected Network Stream Filter technology
INFO: Going to load NSF Engine from location: C:\Program Files\AVAST Software\Avast\aswnseng.dll
INFO: By platform is selected Network Stream Filter technology
INFO: Going to load NSF Engine from location: C:\Program Files\AVAST Software\Avast\aswnseng.dll
INFO: Call Start method to the DLL
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36bba (Cn:0x0) [0x0CCB2940] sz: 0, f:3 failed, code 0x80070057
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c05 (Cn:0x0) [0x0CCF2A40] sz: 0, f:3 failed, code 0x80070057
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c31 (Cn:0x0) [0x0CECAD20] sz: 0, f:3 failed, code 0x80070057
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c30 (Cn:0x0) [0x0D8C4F90] sz: 0, f:3 failed, code 0x80070057
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c09 (Cn:0x0) [0x0D7C42E8] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c13 (Cn:0x0) [0x0D7C42E8] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c3a (Cn:0x0) [0x0D7B42A8] sz: 0, f:3 failed, code 0x80070057
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c22 (Cn:0x0) [0x0D7C42E8] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c3f (Cn:0x0) [0x0D8A4F10] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c56 (Cn:0x0) [0x0D8B4F50] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c51 (Cn:0x0) [0x0CD12AC0] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c5f (Cn:0x0) [0x0CCD29C0] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36c7a (Cn:0x0) [0x0CCD29C0] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36ca2 (Cn:0x0) [0x0D8B4F50] sz: 0, f:3 failed, code 0x80070490
AswNsfCompletionPort::InjectGracefulClose: For stream SEND_PUSH: Id: 0x36ca3 (Cn:0x0) [0x0D8A4F10] sz: 0, f:3 failed, code 0x80070490
INFO: Call Stop method to the DLL

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1879
    • AVAST Software
Re: Network shield prevents access to router web setup - Avast 1474
« Reply #29 on: November 08, 2012, 06:33:08 PM »

Hi,
don't know about the nshield.log analysis, we have to wait for Zdenek on this. However, it might be helpful to have a trace of the traffic that is causing the problems.


Could you try to record a packet dump from the session?


There are two options:
1. Wireshark - for those who like it and use it (like me). However, officially not yet supported on Windows8, if you have WireSharp already installed, please record the packet dump with it.
2. Microsoft Network Monitor


Let me describe the steps for NM:
1. download Network Monitor here: http://www.microsoft.com/en-us/download/details.aspx?id=4865
2. select appropriate version based on your os version (32bit or 64bit)
3. download to your PC, and run the installer
4. Confirm YES and NEXT during the installer prompts.
5. The installation has to parts, Network Monitor and Parsers - both should complete easily, ending with a NM shortcut on the desktop
6. After the installation is completed - you have to logout and login again before using the program.
7. Log in again, open Network monitor on the desktop
8. Click "New Capture"
9. New tab opens, click the "Start" button on the taskbar.
10. Do the traffic that causes problems -- such as accessing your router.
11. After the problem manifests itself, click stop to terminate recording.
12. choose save-as and save the capture into file.
13. upload the file or send me a link via e-mail


To uninstall, use control panel/ Program and Features. Uninstall both "Microsoft Network Monitor" and "Microsoft Network Monitor Parsers". Reboot is not needed.


One more question: does the problem vanish after turning Network Shield off? Or do you have to fiddle with other providers as well (such as WebShield).


Thanks.
Lukas.