Author Topic: Problem w/latest release?  (Read 4282 times)

0 Members and 1 Guest are viewing this topic.

Offline Uh_Clem

  • Jr. Member
  • **
  • Posts: 28
Problem w/latest release?
« on: November 02, 2012, 05:32:22 PM »
This report has been amended.  See below.

I'm having a problem and it's pretty clear that avast! is significantly involved.  Subsequent to applying the most recent update (and I can't tell you which one, because I had to remove it to get my system back but it was whichever one was available yesterday, Nov. 1), I got a pop-up message from avast! saying that an Internal Error had occurred ("Start avast! or check the logs", etc.).  After I received the message, I was able to continue working but when I tried to quit applications, they just hung.  After force-quitting them, I couldn't shut down.  After forcing the system down, when I tried to restart, everything proceeded normally until avast! kicked in.  I again got the Internal Error and the boot just hung at that point.  Something was going on in the background because the system temperature started rising dramatically but I noticed that the fans were not increasing speed in response, so I forced another power-off.  Problem repeated on two more attempted restarts.

I can't say, exactly, how much time elapsed after the avast! update before I ran into problems or if I had shut down and restarted successfully any time prior to the incident because I just don't remember.  My impression, though, is that it had been at least several hours -- maybe even a day -- since the update.

The reasons I'm pretty sure that avast! is the source of the problem is that I restarted the Mac with a second partition that had not been updated to try to troubleshoot.  I removed avast! from the first partition, scanned the drive to make sure that no virus was involved, and successfully restarted using the first partition.  I then downloaded a copy of avast! from the c|net download site, installed it, reregistered and rebooted successfully.  I started avast!, clicked the "Update" icon and went through the process of downloading all the virus database patches since the c|net file was created.  I then got the message that a program update was available, so I proceeded to apply it.  I immediately got the "Internal Error" message and all the system problems repeated as before.

So as not to omit anything, during the process -- after the Internal Error message displayed and the restart had hung -- I was able to start avast!.  One of those times it told me that a repair was necessary.  Going through the process did not fix anything.

It has been some time since I reported a significant problem, so you'll have to remind me which files or logs you might need to evaluate the situation.  The System Diagnostic Reports contain about a dozen com.avast.MacAvast.MAD_....._localhost.crash listings from the events (the first of which is attached).

As a start, I'll tell you I'm running a MacBook Pro (mid-2010) with OS X 10.6.8 but (since, once I had a viable system, I went back to see what would happen if I updated avast! on the other partition) the problem also occurs with OS X 10.7.5.

What follows is a list of all the console messages specifically referring to avast from the time of my first start up of the day through my second or third attempt at a restart.

11/1/12 7:49:35 AM   com.apple.launchd[1]   (com.avast.account[70]) Exited with exit code: 2
11/1/12 7:49:44 AM   com.avast.install[227]   info-wrc-safari-installed
11/1/12 7:49:45 AM   com.avast.install[227]   info-wrc-firefox-uninstalled
11/1/12 7:49:45 AM   com.avast.install[227]   info-wrc-chrome-uninstalled
11/1/12 7:54:48 AM   com.avast.helper[228]   Pop socket closed by peer
11/1/12 7:59:51 PM   com.avast.helper[228]   Pop socket closed by peer
11/1/12 10:10:56 PM   com.apple.launchd[1]   (com.avast.account[73]) Exited with exit code: 2
11/1/12 10:10:56 PM   com.apple.launchd[1]   (com.avast.daemon[71]) Exited with exit code: 1
11/1/12 10:10:56 PM   com.apple.launchd[1]   (com.avast.daemon) Throttling respawn: Will start in 9 seconds
11/1/12 10:10:56 PM   com.apple.ReportCrash.Root[177]   2012-11-01 22:10:56.848 ReportCrash[177:2903] Saved crash report for com.avast.MacAvast.MAD[167] version ??? (???) to /Library/Logs/DiagnosticReports/com.avast.MacAvast.MAD_2012-11-01-221056_localhost.crash
11/1/12 10:11:05 PM   com.avast.install[227]   info-wrc-safari-installed
11/1/12 10:11:06 PM   com.avast.helper[228]   Error connecting to master socket: connect(): Connection refused
11/1/12 10:14:40 PM   com.apple.launchd[1]   (com.avast.account[73]) Exited with exit code: 2
11/1/12 10:14:41 PM   com.apple.ReportCrash.Root[195]   2012-11-01 22:14:41.258 ReportCrash[195:2a03] Saved crash report for com.avast.MacAvast.MAD[168] version ??? (???) to /Library/Logs/DiagnosticReports/com.avast.MacAvast.MAD_2012-11-01-221441_localhost.crash
11/1/12 10:14:41 PM   com.apple.launchd[1]   (com.avast.daemon[71]) Exited with exit code: 1
11/1/12 10:14:41 PM   com.apple.launchd[1]   (com.avast.daemon) Throttling respawn: Will start in 9 seconds
11/1/12 10:14:41 PM   com.apple.launchd[1]   (com.avast.proxy[68]) Exited abnormally: Broken pipe
11/1/12 10:14:41 PM   com.apple.launchd[1]   (com.avast.proxy) Throttling respawn: Will start in 9 seconds
11/1/12 10:14:47 PM   com.avast.install[239]   info-wrc-safari-installed
11/1/12 10:14:47 PM   com.avast.helper[240]   Error connecting to master socket: connect(): Connection refused
11/1/12 10:14:47 PM   com.avast.install[239]   info-wrc-firefox-uninstalled
11/1/12 10:14:47 PM   com.avast.install[239]   info-wrc-chrome-uninstalled
11/1/12 10:18:43 PM   com.apple.launchd[1]   (com.avast.account[73]) Exited with exit code: 2
11/1/12 10:18:43 PM   com.apple.launchd[1]   (com.avast.daemon[71]) Exited with exit code: 1
11/1/12 10:18:43 PM   com.apple.launchd[1]   (com.avast.daemon) Throttling respawn: Will start in 9 seconds
11/1/12 10:18:43 PM   com.apple.ReportCrash.Root[210]   2012-11-01 22:18:43.250 ReportCrash[210:1407] Saved crash report for com.avast.MacAvast.MAD[163] version ??? (???) to /Library/Logs/DiagnosticReports/com.avast.MacAvast.MAD_2012-11-01-221843_localhost.crash

--------------------------------------------------------------------

Amended 2012/11/02 10:49 PDT

I was wrong about the update on OS X 10.7.5.  The "Internal Error" appeared after the Program Update Available notification but I declined the update at that time.  The one difference between symptoms on 10.7.5 and 10.6.8 is that, with Lion, the boot continues successfully and I am able to work.

To recap --  The situation on 10.7.5 appears to be:  Application Version 7.0 (37667) and update log shows 37682 downloaded

Performing vpsmac update (repository: http://download.ff.avast.com/mac/vpsmac, filedir: /Library/Application Support/Avast/files/defs/12110200/../../Setup/filedir, workdir: /tmp, instdir: /Library/Application Support/Avast/files/defs/12110200/..)
Resolving download.ff.avast.com...
Resolved as 159.253.143.37
Downloading http://159.253.143.37/mac/vpsmac/vpsmac.lat...
Current: 12110200 Latest: 12110200
Version vpsmac 12110200 already downloaded
Performing progmac update (repository: http://download.ff.avast.com/mac/progmac, filedir: /Library/Application Support/Avast/files/Setup/filedir, workdir: /tmp, instdir: /Library/Application Support/Avast/files/defs/12110200/..)
Resolving download.ff.avast.com...
Resolved as 46.4.28.80
Downloading http://46.4.28.80/mac/progmac/progmac.lat...
Current: 37682-7.0 Latest: 37682-7.0
Version progmac 37682-7.0 already downloaded

Virus definition version 121100200

Applying 37682 did not correct the Internal Error.

The section of the System Log relating to avast! startup on Lion is:

[Had to be attached as separate file (SystemLog.txt) due to length limitations]
« Last Edit: November 02, 2012, 07:07:31 PM by Uh_Clem »

Offline abhayp9

  • Newbie
  • *
  • Posts: 2
Re: Problem w/latest release?
« Reply #1 on: November 02, 2012, 08:42:08 PM »
I am facing the same issue, finally got tired of trying to fix it and uninstalled the program.
I will wait till they fix it before installing again.

I use 10.6.8, but have not faced any hanging issues though.
« Last Edit: November 02, 2012, 08:43:54 PM by abhayp9 »

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: Problem w/latest release?
« Reply #2 on: November 06, 2012, 12:18:24 PM »
I am facing the same issue, finally got tired of trying to fix it and uninstalled the program.
I will wait till they fix it before installing again.

I use 10.6.8, but have not faced any hanging issues though.

Hallo, this problem is known and alreadfy fixed. Please, update the virus database (from menubar).
With VPS younger than 5th Nov the problem is fully gone.

Please make sure that you have internet connectivity, when choosing the update step.
Also, please, confirm that this helped you.

Regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)