Author Topic: Avast shuts down my Network card  (Read 5808 times)

0 Members and 1 Guest are viewing this topic.

Mouser

  • Guest
Avast shuts down my Network card
« on: September 24, 2011, 07:31:47 PM »
Hey all,

I have been having a problem that I have just dealt with for the last 8 months, ever since I upgraded from the Free version of Avast to the Internet Protection version. Here is a description of my issue:

I allow my computer to go to sleep, as opposed to shutting it down, and afterwards when it wakes up there is a caution symbol over the LAN icon in the task bar indicating that there is a problem with connectivity.

I have searched through the settings in Avast to attempt to disable whatever it may be that causes this but to no avail. As mentioned before, I have just dealt with it, but I grow very tired of doing so. I have eliminated anything else from being the root cause of this issue, as it started happening immediately after I upgraded my AV program.

Well, this is my attempt to reach out to the community before I totally give up on Avast. I hope that someone hears my cries  :'( What should I do to alleviate this problem?

Thanks,

p.s.
OS is Windows 7 Pro sp1

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Avast shuts down my Network card
« Reply #1 on: September 24, 2011, 08:30:38 PM »
I have Windows 7 Pro SP1 too. I sleep/wake up my computer several times a day. No problems.
Maybe into avast settings Troubleshooting > Delay avast services... option could help. Can you try?
The best things in life are free.

Mouser

  • Guest
Re: Avast shuts down my Network card
« Reply #2 on: September 24, 2011, 09:04:38 PM »
Well, thanks for your input but I am sad to say that this did not work. I assume that you are talking about "Settings>Troubleshooting>Load Avast services only after loading other services". This was already checked to be enabled.

Just to try it, I disabled that feature, put the computer to sleep, and when I woke it back up the same problem persists. I have come up with my own little work around for this. I created a shortcut to the NIC card and placed it on the desktop so that I can easily disable/enable it to get it to work again. This is how I have been able to put up with it for so long. But it has recently started to cause problems with my Arris cable modem and my Linksys router. Whenever I disable and enable it it is starting to jam up the packets between the two devices and I end up having to reset the modem / router / and NIC card. Huge problem!

Nesivos

  • Guest
Re: Avast shuts down my Network card
« Reply #3 on: September 24, 2011, 09:16:28 PM »
Hey all,

I have been having a problem that I have just dealt with for the last 8 months, ever since I upgraded from the Free version of Avast to the Internet Protection version. Here is a description of my issue:

I allow my computer to go to sleep, as opposed to shutting it down, and afterwards when it wakes up there is a caution symbol over the LAN icon in the task bar indicating that there is a problem with connectivity.

I have searched through the settings in Avast to attempt to disable whatever it may be that causes this but to no avail. As mentioned before, I have just dealt with it, but I grow very tired of doing so. I have eliminated anything else from being the root cause of this issue, as it started happening immediately after I upgraded my AV program.

Well, this is my attempt to reach out to the community before I totally give up on Avast. I hope that someone hears my cries  :'( What should I do to alleviate this problem?

Thanks,

p.s.
OS is Windows 7 Pro sp1



Check the computer's Windows "Event Viewer".  You should be able to identify the source of the problem that way.

Long way to get to it:

Click on Windows World Ball
Type in MSConfig
Click on MSConfig
Click on Tools
Click on Event Viewer

Short Way

Open Computer Icon
Go To C:\Windows\System32\eventvwr.exe
Click on It


ady4um

  • Guest
Re: Avast shuts down my Network card
« Reply #4 on: September 24, 2011, 09:22:51 PM »
I'm going to through some "blind" idea (based on my experience only, and I have no way to know if this is your specific case).

First, delete your firewall rules related to Avast, so they can be rebuilt after reboot.

Double-check your proxy settings (both in IE / Windows, and in Avast). Try testing other settings of the proxy.

Finally, deactivate any "power saving" settings of your network devices (router, network card...). Also, if you have "high performance" settings (either manual or automatic, like 10/100/1000 ethernet for example), disable them too (for example, only 10/100, but don't let the 1000).

After the changes, reboot (and changing the devices properties should request it anyway).

I used to have some little "quirks" with the power saving properties of my network card, and I avoid them by not using those properties.

By no means I mean you shouldn't use them. This is only to try to identify if those properties / settings are somehow related to your problem.

Mouser

  • Guest
Re: Avast shuts down my Network card
« Reply #5 on: September 25, 2011, 08:14:10 PM »
Well, my Firewall was and still is turned off. Just in case, I looked for anything from Avast and I couldn't see any rules at all for them. The event viewer did not help much. It just looked like there was an issue with connecting to the DNS server, which is due to the NIC being shut off.

My fix to re-enable it works, its just annoying and takes about a minute to complete (and I am all about instant gratification). Additionally, I have set the computer to Never Sleep, which sucks because I would like to use that feature (since, again I am all about instant results and powering on from cold takes all of two minutes ;D) At any rate, I certainly am glad to have had the responses from those of you who took some time to help me troubleshoot. A huge thanks to all of you! In the meantime, if you think you have the solution put it down and I will continue to try.

picktown9

  • Guest
Re: Avast shuts down my Network card
« Reply #6 on: May 13, 2013, 03:10:34 PM »
Any fix news ?