Author Topic: Proxy Settings Auto detect not working  (Read 22010 times)

0 Members and 1 Guest are viewing this topic.

Offline olluz

  • Newbie
  • *
  • Posts: 6
Proxy Settings Auto detect not working
« on: November 23, 2012, 02:08:12 PM »
Hello,

the auto detection of proxy settings (taken from Internet explorer 9) are not working.

Is this a known issue ?

When I specify the proxy server in Avast Settings -> Updates -> Specify proxy server
directly the Updates are working otherwise the update server can't be found.

Best regards,
Oliver

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31332
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Proxy Settings Auto detect not working
« Reply #1 on: November 26, 2012, 09:35:54 AM »
Please mention your operating system and version as well as the avast version.

Offline olluz

  • Newbie
  • *
  • Posts: 6
Re: Proxy Settings Auto detect not working
« Reply #2 on: November 26, 2012, 10:10:58 AM »
thnx for the reply.

The OS is Windows 7 Professional 64bit with SP1 (all updates installed)
The Avast Program version is 7.0.1474.

Thnx again.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31332
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Proxy Settings Auto detect not working
« Reply #3 on: November 28, 2012, 09:59:59 AM »
As far as I know, there are no problems with that combination.
It sounds like you did, but just to make sure:
- Have you compared the IE proxy settings with the ones in avast?
- Are they exactly the same?

If you have, try this:
- Set avast to not use a proxy
- Reboot
- Check if avast still is set to not use a proxy
- Set avast to automaticly use a proxy (the IE one)
- Reboot
- 1) Check if avast has detected the proxy settings.
  2) If avast did detect them, check if they are the same as in IE.
  3) Try a update (right click avast icon, choose update)

And le me know why you are using a proxy.
Did your ISP tells you to use one or is there another reason?

Offline olluz

  • Newbie
  • *
  • Posts: 6
Re: Proxy Settings Auto detect not working
« Reply #4 on: November 30, 2012, 12:21:33 PM »
thank you for the answer.

I have tried the steps you have asked me to, but unfortunately it is not working. Here is what I did:
- Set avast to not use a proxy -> Set it to Direct Connection
- Reboot
- Check if avast still is set to not use a proxy
- Set avast to automaticly use a proxy (the IE one) ->
- Reboot
- 1) Check if avast has detected the proxy settings.  -> not sure how to accomplish this, but Avast is still set to AutoDetect (Use IE proxy)
  2) If avast did detect them, check if they are the same as in IE.
  3) Try a update (right click avast icon, choose update)

Tried the update but I still get the error messages:
Downloading file server.def.vpx
Error; Cannot connect to server

Cannot connect to download348.avast.com (62.212.82.99:80)

I then set Avast to manual proxy settings (copied them over from Internet Explorer)
and the update is working immediately (without even rebooting or restarting Avast).

Is there anything else I could try ?
What could be the reason for this ?

I mean I can set the proxy manually and it is working, but using the Automatic detection is just such a neat feature:

When I am in a place where a proxy is needed I just have to set it in IExplorer
and if I am on a networking not requiring a Proxy I disable it in IE only and all other applications work without having to enable/ disable all of them manually.

Thank you again

Offline olluz

  • Newbie
  • *
  • Posts: 6
Re: Proxy Settings Auto detect not working
« Reply #5 on: December 05, 2012, 12:43:41 PM »
The problem still exists. Am I the only one with this problem ?

Should I file a bug report ? Are the Avast developers going to look into this ?

Thank you.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69974
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Proxy Settings Auto detect not working
« Reply #6 on: December 05, 2012, 03:07:55 PM »
When I specify the proxy server in Avast Settings -> Updates -> Specify proxy server
directly the Updates are working otherwise the update server can't be found.

Good, no need to dig deeper here then. ;)
Win 8.1 [x64] - Avast PremSec 21.3.2459.Beta4 [UI.610] - EEK - Firefox ESR 78.9 [NS/uBO/PB] - TB 78.9
Avast-Tools: Secure Browser 89.1 - Cleanup 21.1 - SecureLine 5.11 - Driver Updater 21.1 - CCleaner 5.78
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84772
  • No support PMs thanks
Re: Proxy Settings Auto detect not working
« Reply #7 on: December 05, 2012, 03:39:36 PM »
The problem still exists. Am I the only one with this problem ?

Should I file a bug report ? Are the Avast developers going to look into this ?

I have seen this before in the forums were avast for whatever reason is unable to retrieve the proxy settings from IE (not sure if this is on all versions or just on IE9) and that is even when there is no proxy used or set in IE.

This has normally been for those who don't use a proxy to connect, so the Direct connection (no proxy) option in avast works just fine. But in your case, this wouldn't work if you actually use a proxy to connect. So setting it up manually is the option you require and cuts out the need to try and interrogate IE for the settings.

So I honestly don't know if this is an avast bug or something in IE9 (and or user settings in IE) blocking access to these settings.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.2.2455 (build 21.2.6096.648) UI 1.0.608/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline olluz

  • Newbie
  • *
  • Posts: 6
Re: Proxy Settings Auto detect not working
« Reply #8 on: December 06, 2012, 10:35:25 AM »
Hmm.
Sorry to be picky, but this is clearly a bug in avast.

I'm quite sure that it has nothing to do with IE8 or IE9.

I have checked my registry and IE9 is writing the proxy values in here:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

Not sure about IE8 but I am quite confident it will store the settings in there, too.

So checking for a few Reg entries like
"ProxyEnable"
"AutoConfigURL"
"ProxyServer"
at program start should be enough to get the correct proxy settings.

And it shouldn't be too hard to implement / fix.

Thanks again.


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84772
  • No support PMs thanks
Re: Proxy Settings Auto detect not working
« Reply #9 on: December 06, 2012, 12:25:23 PM »
Well as an avast user like yourself I have no control over how avast implement this, but if you want to report it as a bug then you should do so.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.2.2455 (build 21.2.6096.648) UI 1.0.608/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 905
  • Product manager of Mac AV and Cleanup
Re: Proxy Settings Auto detect not working
« Reply #10 on: December 07, 2012, 06:05:04 PM »
thank you for the report. There might be cases when avast fails with the IE proxy. Could please provide more info about your proxy settings to help us cover your case in fixes for next avast version?

thank you
Quality is also a feature.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84772
  • No support PMs thanks
Re: Proxy Settings Auto detect not working
« Reply #11 on: December 07, 2012, 08:25:59 PM »
It also happens even when a user doesn't have a proxy setup in IE (many such instances in the forums), there appears to be a problem accessing the IE proxy settings.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.2.2455 (build 21.2.6096.648) UI 1.0.608/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline olluz

  • Newbie
  • *
  • Posts: 6
Re: Proxy Settings Auto detect not working
« Reply #12 on: December 18, 2012, 10:28:18 AM »
Hi Lukas,

sorry for the late reply, I was on vacation.

Please let me know what exactly you need to know from my proxy settings.

Thanks for helping.

Best regards,
Oliver

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31332
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Proxy Settings Auto detect not working
« Reply #13 on: January 05, 2013, 02:25:39 AM »
Lukas wants ALL details about your proxy settings.
e.g. proxy server adress, port, if you need a password etc.
If you do need a password give it to Lukas in private and do not post it publicly!

And I am still curious about a thing I asked you in my first reply.
Quote
And let me know why you are using a proxy. Did your ISP tells you to use one or is there another reason?