Author Topic: Avast Free Disabling Internet Browsers  (Read 2846 times)

0 Members and 1 Guest are viewing this topic.

Offline ayria

  • Newbie
  • *
  • Posts: 2
Avast Free Disabling Internet Browsers
« on: December 18, 2012, 08:34:25 PM »
I had Avast Pro, and recently my subscription ran out. I installed Avast Free, but it will not allow me to use my web browsers (ie, ie 64bit, firefox, waterfox) with protection enabled. The only way I can connect to internet via browsers is if I disable Avast.

I've tried uninstalling, rebooting, reinstalling three times now.
I've tried disabling Windows Firewall and Windows Defender - still cannot connect to browser unless Avast is disabled as well.
I tried unchecking the boxes under Avast Cloud Services - cannot connect to internet via browsers unless avast is disabled.

I don't have any other security programs currently running on the comp I installed Avast Free on.

Any suggestions on how I can get Avast Free to work? Otherwise I'll just have to install another internet security program onto that comp.

Thanks.


Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85965
  • No support PMs thanks
Re: Avast Free Disabling Internet Browsers
« Reply #1 on: December 18, 2012, 09:48:30 PM »
Sounds more like something (firewall) blocking avast.

What is your operating system and firewall ?
Does it allow avastSvc.exe internet access ?
- If it does delete the entry for it and reconnect to the internet, this should force the firewall to ask permission again.

Rather than disable avast, stop the web shield as that is the shield that deals with scanning http traffic. That way you aren't totally unprotected, but still not good.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline ayria

  • Newbie
  • *
  • Posts: 2
Re: Avast Free Disabling Internet Browsers
« Reply #2 on: December 19, 2012, 08:57:48 AM »
Thanks for the reply. I got it to play nice, finally!
Installed under Compatibility Mode, and then went to Add/Remove and chose the "change" option to install the full version.

To answer the question, I have Windows 7 64bit, and only using Windows Firewall. I tried a number of times disabling Windows Firewall and Defender while installing and for some reason it just wouldn't work. I'd finish the install, and it would prompt me to register - I'd log in - and then browser down.

Not sure what exactly caused it, but after a day of reinstalls and uninstalls the Compatibility Mode install followed up with a change to full install worked.

Thanks!

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85965
  • No support PMs thanks
Re: Avast Free Disabling Internet Browsers
« Reply #3 on: December 19, 2012, 01:45:41 PM »
You're welcome.

Weird, unless you have the win7 firewall setup to monitor outbound traffic it shouldn't interfere with outbound connections. The win7 firewall isn't particularly friendly, if you enable outbound protections, it is rules based and you have to manually create the rules.

Good that you have managed to resolve the problem, haven't heard of anyone using that compatibility mode and switch to full install mode before.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security