Author Topic: ashWebSv and persistant TCP streams  (Read 2156 times)

0 Members and 1 Guest are viewing this topic.

adrianmarsh

  • Guest
ashWebSv and persistant TCP streams
« on: March 03, 2005, 12:40:52 AM »
All,

I've just notified the support email address of the following problem. If you see the same issue (or dont!) then speak up!

Heres my config:

Win XP Home
AMD 1800 Athlon, 512 Mb, ATI GFX
Net connection is Ethernet -> DSL Router -> ISP
Firewall software is NetPeeker 2.73. Protowall is also installed. I also use Netgrid to graphically show bandwith.

Avast 4.6.603 -- VPS 0509-3

Netpeeker and Netgrid let me see the bandwith a process is pulling. They drew my attention to this bug.

Heres the steps to reproduce:

0) Start PC etc, with ashWebSv running
1) Start Winamp, start downloading a stream from a music station (any)
2) Netpeeker shows the ashWebSv.exe process downloading approx 16KBps
3) Press STOP on Winamp. Not Pause, but STOP.
4) NP still shows ashWebSv downloading approx 16KBps
5) Wait x seconds (in my case 30s later)... still downloading.
6) Start winamp playing again...
7) NP shows a second stream has started, so 16x2 is now downloading.

and so on. I'm able to keep going until I fill up my bandwith.

Streams don't even stop if I end Winamp. Only way for me to stop it is to kill Provider, or use NP to disconnect the TCP session.

This didn't happen on the previous version of Avast (I guess as it didn't have this feature). It also doesn't happen if I stop the ashWebsv  Provider.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: ashWebSv and persistant TCP streams
« Reply #1 on: March 03, 2005, 01:31:49 AM »
I confirm this to be an error in current version of WebShield. The fix is already prepared and should enter beta test phase as soon as possible.

Lukas.