Author Topic: Internet not working after uninstalling Avast  (Read 12728 times)

0 Members and 1 Guest are viewing this topic.

Raven_

  • Guest
Internet not working after uninstalling Avast
« on: February 22, 2013, 11:45:13 AM »
Hi everyone,
I've been having problems with my network connection since yesterday. There was a problem with my network card so I uninstalled it from the device manager and when it couldn't be automatically re-installed (it gave me Code 31 error with the message "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)" I did a system restore and I fixed the problem. After the system restore I was able to connect to the internet but Avast didn't turn on and I couldn't do any upgrades so I uninstalled Avast and after I rebooted my computer I couldn't connect to the internet. I uninstalled Avast from Remove programs section but after that I downloaded the Avast removal utility and removed the rest of the files in safe mode but it didn't work. Actually one problem before uninstalling Avast was when I went to "Wireless network Connections" and right clicked "Properties" I couldn't access TCP/IP settings, I used to get this message "Controls on this property sheet are disabled because one or more other Network property sheets are already open .." After uninstalling Avast that problem got resolved. I actually re-installed Avast again and I can still access and change TCP/IPv6 and TCP/IPv4 settings. They are all set to "Obtain TCP/IP address automatically" now. My wireless can detect connections it says  there is "limited access" but I can't access to the internet at all. I ran the network troubleshooter but it can't find any problems. I have seen others who lost their internet connection after uninstalling Avast but I couldn't find any solutions. I don't have any other virus protection programs on my computer except for Malware Bytes but that never caused any problems so far. Other computers can connect to the internet just fine so the problem is with my computer. There are 158 days to Avast expiration date. I'm using Windows 7 x64. I need help.

Thanks.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37529
  • Not a avast user
Re: Internet not working after uninstalling Avast
« Reply #1 on: February 22, 2013, 11:59:53 AM »
try running avast uninstall tool from safe mode and reboot.  http://www.avast.com/uninstall-utility

any change?


Raven_

  • Guest
Re: Internet not working after uninstalling Avast
« Reply #2 on: February 22, 2013, 01:45:29 PM »
Oh wow that worked! Thanks a lot! :D
I reinstalled Avast and everything is fine. So we shouldn't first go to "Uninstall and change a Program" and uninstall Avast from there. We should directly get to the safe mode and use aswclear.exe but now I have the same problem I had before, I can't access TCP/IP settings, again I get this message "Controls on this property sheet are disabled because one or more other Network property sheets are already open ..". Anyone knows how to fix it?