Author Topic: Missing tray icon & strange registry entry  (Read 14242 times)

0 Members and 1 Guest are viewing this topic.

smolls

  • Guest
Missing tray icon & strange registry entry
« on: February 28, 2005, 02:30:38 PM »
When I boot up (WinXP + SP1) I do not get an icon in my system tray.

Avast seems to be running even without the icon but I can't access the menus or make any changes.

I could use the third-party Avast External Controls program to make the icon show up.  But I don't want to have to run an extra program each time I boot up!  I think all this option of the utility does may be to run AshDisp.exe but I don't really know.

So I took a look in the registry and I saw that this key for Avast had no entry or pathname except for a ''.'. 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

Is this registry entry correct.  Should it point more directly to an Avast executable program?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89249
  • No support PMs thanks
Re: Missing tray icon & strange registry entry
« Reply #1 on: February 28, 2005, 02:52:07 PM »
Any danger you are using spy sweeper? There have been a number of posts relating to false positive lopdotcom being the systray icons.

Quote
I could use the third-party Avast External Controls program to make the icon show up.  But I don't want to have to run an extra program each time I boot up!

You don't have to, it is a one time deal, use it to modify settings, etc. and close it, the end.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Missing tray icon & strange registry entry
« Reply #2 on: March 01, 2005, 03:55:00 AM »
Can you try to repair your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove
Then choose Repair function in the popup window (Repair).
You must be connected to the internet while repairing.

If this does not help, can you uninstall / boot / install / boot again?
The best things in life are free.

smolls

  • Guest
Re: Missing tray icon & strange registry entry
« Reply #3 on: March 04, 2005, 12:28:00 AM »
Can you try to repair your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove
Then choose Repair function in the popup window (Repair).
You must be connected to the internet while repairing.

If this does not help, can you uninstall / boot / install / boot again?

I still have the problem.  After I read your posting this is what I did:

(1)  I ran ADD/REMOVE PROGRAMS but the Avast entry failed to work.  XP said there was a problem and did I want to remove the Avast entry from Add/Remove.   So couldn't do a repair as you suggested.  Nor could I do an uninstall.

(2)  I used standalone removal tool aswclear2.exe which I downloaded from the website.

My aswclear2.exe said: Copyright (C) 2003 Alwil Software;  Description: avast! Removal;  v 1.0.0.1;  197 KB (201,808 bytes)

And these are the results of running aswclear2.exe:
Resident protection - Removed
Mail protection - Removed
Explorer extensions - Removed
Registry - Removed
Program files - Removed
avast!4 was successfully removed

Although it says "Registry - Removed" above I still found several registry keys with "Avast" in them.  But I left them alone.

(3)  I rebooted.

(4)  Then I downloaded a new copy of Avast and installed it.  No icon in system tray.

(5)  I rebooted again.

But I have no system tray icon.

So I ran Avast External Control and selcted the Tweaker option where I made sure Show Tray Icon was selected (and a few other options).  I permitted it to stop and then start Avast.  This got my system tray icon back.

But when I rebooted I had no icon in the system tray.

Can you suggest what to do now?

When I booted I got Windows Explorer showing me the System32 folder.  Microsoft says this is due to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run having an empty entry.  See http://support.microsoft.com/?kbid=170086.

I mentioned in my original post that I have an Avast entry there which is called avast! and its data value is "".  Is this normal?


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89249
  • No support PMs thanks
Re: Missing tray icon & strange registry entry
« Reply #4 on: March 04, 2005, 12:36:28 AM »
A similar thing cropped up elsewhere and Vlk (I think) suggested this.

Quote
Uninstall avast, delete the reg key HKEY_LOCAL_MACHINE\Software\ALWIL Software and reinstall avast.

I doubt that it would hurt to remove the other key you mentioned as it too should get created on installation.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Missing tray icon & strange registry entry
« Reply #5 on: March 04, 2005, 02:26:36 AM »
I mentioned in my original post that I have an Avast entry there which is called avast! and its data value is "".  Is this normal?

No, it's not.
Do what David said and you'll see that you'll have the path to ashDisp.exe into the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
(The value will be named avast!).
The best things in life are free.

smolls

  • Guest
Re: Missing tray icon & strange registry entry
« Reply #6 on: March 04, 2005, 11:06:04 PM »
I mentioned in my original post that I have an Avast entry there which is called avast! and its data value is "".  Is this normal?

No, it's not.
Do what David said and you'll see that you'll have the path to ashDisp.exe into the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
(The value will be named avast!).

I don't get it but that line in the registry is unchanged after I run the Avast External Control and got to Tweaker and check the Tray Icon settings and run it.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89249
  • No support PMs thanks
Re: Missing tray icon & strange registry entry
« Reply #7 on: March 05, 2005, 12:16:41 AM »
The suggestion was uninstall, then manually delete the keys as suggested (and your strange one), reboot then install, did you do that?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

smolls

  • Guest
Re: Missing tray icon & strange registry entry
« Reply #8 on: March 05, 2005, 12:22:00 AM »
The suggestion was uninstall, then manually delete the keys as suggested (and your strange one), reboot then install, did you do that?

I run ADD/REMOVE and selected Avast!  I got a window with the title RUNDLL and it said this:

Quote
Error loading.
The specified module could not be found.

Then I went round this loop again and this time I got an 'Uninstaller Error' message Window which said

Quote
An error occurred while trying to remove avast! Antivirus. It may have already been uninstalled.

Would you like to remove avast! Antivirus from the Add or Remove programs list?

I replied YES and then went and used awsclear.exe which gave me the following info:

Quote
Resident protection - Removed
Mail protection - Removed
Explorer extensions - Removed
Registry - Removed
Program files - Removed
avast!4 was successfully removed

However most of the contents of the Avast folder in Program Files seemed to be intact.

--

I reboot and reinstalled Avast.  At the end of the reinstall my StartupMonitor utility (which watches to see what is being out into the systen for laoding at startup said this:

Quote
The program avast! has registered the executable "" to run at system startup.

Do you wish to allow this change?

I said YES and took a look at the registry where I saw that the following key

Quote
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ 

has Avast entry with a value of "".  This is familiar!

---

I rebooted.  On starup there was no Avast icon in system tray and a blank System32 folder window appears at boot-time which was not appearing in the boots before I started this process.

GRRRR!  What do I do next?  AVG 7?

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\  has Avast entry with a value of ""

----------

I used Avast Tweaker (in Avast Ext Control) to see the two icons.  Then I rebooted.

On relaunch I got no icon(s).

ARGHHHHHHHH !  :-(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89249
  • No support PMs thanks
Re: Missing tray icon & strange registry entry
« Reply #9 on: March 05, 2005, 12:47:13 AM »
I see nowhere that you manually deleted the suggested registry entries.

Having used three different tools to try and uninstall avast I'm not surprised you got the error.
Quote
Error loading.
The specified module could not be found.

Forget the two icons! the empty registry key HKLM\...\...\Run Avast, effectively means avast isn't being run, no avast being run, no icons, you can get the icons back, but the next time you boot, no run avast, no icons.

Quote
GRRRR!  What do I do next?  AVG 7?
That would be your loss and choice, however, there are many ex AVG7 users now using avast.

Please lets try what Vlk suggested in a previous thread, use Add Remove programs to uninstall avast, delete the registry keys manually, reboot, check and see if there are any avast folders remaining if so delete them, then install.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31078
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Missing tray icon & strange registry entry
« Reply #10 on: March 05, 2005, 12:50:23 AM »
Get the uninstall util from the Avast website.
- Use it to uninstall Avast.
- Reboot
- Reinstall Avast

Let's see if that helps/works.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Missing tray icon & strange registry entry
« Reply #11 on: March 05, 2005, 03:28:10 AM »
Smolls, which is the path that you're trying to install avast?


However most of the contents of the Avast folder in Program Files seemed to be intact.

Boot and run awsclear.exe again.
If it does not work, delete the files manually.

My StartupMonitor utility

Turn off this utility while installing avast!
The best things in life are free.

smolls

  • Guest
Re: Missing tray icon & strange registry entry
« Reply #12 on: March 05, 2005, 05:19:18 PM »
I see nowhere that you manually deleted the suggested registry entries.

David & Technical,

I made a mistake when I did not write at what point I deleted that registry key.  I did delete it and I deleted a bit more but I omitted to put this important info in my post to this board! 

To go back to what I did actually do ...  after I found that much of the contents of the Avast folder in program Files was intact, I deleted as many of the entries as possible although there was one DLL which was locked so I had to leave that.

Quote
I also went to the registry and deleted the following entries:

(1)  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run - I deleted the Avast entry

(2) HKEY_LOCAL_MACHINE\Software\ALWIL

(3) This put me in the mood to delete a bit more so I deleted all the keys I could find with "avast" or "alwil" in them.  There were about eight or so of them.  I hadn't done this zealous deleting of registry keys before so I figured that it would not be the sole cause of my current problem.

So in fact I have done what you suggested in your most recent post but it still led to my reinstall not being right.

"Technical" asks me what folder I install Avast to.  He is right to suspect that I change the default ... the very first time I installed Avast it was to "C:\Program Files\Avast".  However I later installed to the very similar named but different folder "C:\Program Files\Avast!" (with the exclamation mark at the end).  I did this deliberately to try and get a new clean install of Avast as I was having icon problems by then.

I have not installed to the default which I recall is "C:\Program Files\Alwil Software\Avast".  And I prefer not to do so as I do not remember supplier's names as well as I remember their software's name.

Furthermore he is uneasy about StartupMonitor.  However it just alerts me whenever a change in the startup locations is attempted.  I usually let the change go ahead but I find it useful to know and remember that something has been altered.

Quote from: DavidR
Having used three different tools to try and uninstall avast I'm not surprised you got the error.
Quote
Error loading.
The specified module could not be found.

Forget the two icons! the empty registry key HKLM\...\...\Run Avast, effectively means avast isn't being run, no avast being run, no icons, you can get the icons back, but the next time you boot, no run avast, no icons.

Quote
GRRRR!  What do I do next?  AVG 7?
That would be your loss and choice, however, there are many ex AVG7 users now using avast.

Please lets try what Vlk suggested in a previous thread, use Add Remove programs to uninstall avast, delete the registry keys manually, reboot, check and see if there are any avast folders remaining if so delete them, then install.

I really don't want to go back to AVG.  I was on version 6 and stripped it out when I heard that support and updates for 6 was being stopped but the word was that version 7 was more bloated.  I like what I have seen of Avast and would much prefer to use Avast.  But of course, I need it to install correctly.

So what do I do now?  I suspect that Avast will have yet other registry keys which I have not touched as I presume that it's registration flags and countdown timer of days used is hidden somewhere in the registry.

Rgds, Smolls

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Missing tray icon & strange registry entry
« Reply #13 on: March 05, 2005, 06:40:15 PM »
Honestly, it's difficult to imagine the next step.
Maybe uninstalling both with Control Panel and awsclear.exe (uninstaller) (download at avast website).
Booting all the times required.
Delete the files under the avast and avast! folders.
Installing again.

By the way, why don't you update to SP2?
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89249
  • No support PMs thanks
Re: Missing tray icon & strange registry entry
« Reply #14 on: March 05, 2005, 07:40:03 PM »
I'm not sure either.

Quote
So in fact I have done what you suggested in your most recent post but it still led to my reinstall not being right.
Are there any error messages, can you give us any more information?

However, I would guess because you have installed avast in a non-standard folder, awsclear.exe and RejZor's External Control Tool may have difficulty not finding the avast installation where expected, especially if avast has been partially uninstalled so the uninstall information is not available,so defaults may be used (incorrectly in this case).

This may well be the reason files were left behind as you mentioned, though I can't say for certain.

Quote
I have not installed to the default which I recall is "C:\Program Files\Alwil Software\Avast".  And I prefer not to do so as I do not remember supplier's names as well as I remember their software's name.
This could be a contributory factor, there could possibly be multiple registry entries for avast.

I too am running out of ideas, but running a registry cleaner looking for registry keys that have bad/missing links may get rid of any invalid avast registry entries.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security