Author Topic: Listening POP to 2 ports simultaneously ?  (Read 18790 times)

0 Members and 1 Guest are viewing this topic.

Offline wanidoob

  • Jr. Member
  • **
  • Posts: 21
  • Uggly Bob !
Re: Listening POP to 2 ports simultaneously ?
« Reply #15 on: March 07, 2005, 09:17:59 AM »
a little more precisions...

Avast automatically monitors all connections to port 110, eg. pop.myisp.com:110, but in your case there is no connection to port 110, instead 11110 is being used. So firstly you'll have to add PopRedirectPort=110,11110. Now avast will redirect (monitor) both 110 and 11110 ports.

OK, that's fine... I didn't understand what "PopRedirectPort" meant. Now I do. But it isn't so easy to understand that Avast support two scan modes :
- "Listen" which is needing a login as "nick#pop.server.com" (and Avast log itself to "pop.server.com" with the login "nick" / maileur send "nick#pop.server.com" to "127.0.0.1:110")
- "Redirect" which simply catch the stream from normal maileurs configuration (maileur send "nick" directly to "pop.server.com")

Your connections are directed to localhost:11110, but under standard setup localhost is ignored and not monitored. So secondly you need to add IgnoreLocalhost=0.

But for the "Redirect" method I had to uncheck "ignore local communications". And the "Listen" method needs this to be checked.

There is no need to force avast listen on two ports for whatever reason - as you are suggesting in your original post.

But in my mind, Avast do it (what I wanted) finally : it scans more than one ports with the "redirect" method.

And in fact, it could be nice to force Avast to "listen" to 2 (or more) ports : because with the "Redirect" method, if Avast doesn't work (for any reason : not lauched, crashed, blocked...), the maileur does pop emails, but without Avast scan !

And it seems to be impossible to use "Listen" and "Redirect" simultaneously (or am I a stupid boy ?, that's a 50% / 50% :-)

Finally, if you have problems starting the SSL Tunnel service, please use Control Panel / Administrative Tools / Services, there you can change the status from stopped to started.

That was an artefact of my silly mind. When windows start up, stunnel do error like "Error resolving 'pop.gmail.com': Neither nodename nor servname known (EAI_NONAME) / Cannot resolve 'pop.gmail.com:995' - delaying DNS lookup". And when connected, it doesn't show any "OK messages", but it works fine !


If any is interresting in, I can post here my 3 confs files (thunderbird, avast, stunnel)
« Last Edit: March 07, 2005, 09:22:58 AM by wanidoob »
english newbie ::) + network newbie :-\ ... ... ... so please be patient :-*

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Listening POP to 2 ports simultaneously ?
« Reply #16 on: March 07, 2005, 04:51:44 PM »
If any is interresting in, I can post here my 3 confs files (thunderbird, avast, stunnel)

I am... Thanks  8)
The best things in life are free.

Offline wanidoob

  • Jr. Member
  • **
  • Posts: 21
  • Uggly Bob !
Re: Listening POP to 2 ports simultaneously ?
« Reply #17 on: March 09, 2005, 12:40:17 PM »
I am... ThanksĀ  8)

So here are my *secret* conf filesĀ  8)

How to use Thunderbird + Stunnel + Avast...
and How to support Gmail and others accounts simultaneously

My Thunderbird normal account :
* POP
- login "nick1@provider1.com"
- server "pop.provider1.com"
- port "110"
- security protocol : none ("secure connection (SSL)" unchecked and "secure authenticate" unchecked)
* SMTP
- login "nick1@provider1.com" (if necessary, ie if "use with login and password" checked)
- server "smtp.provider1.com"
- port "25"
- security protocol : none ("secure connection (SSL)" unchecked and "secure authenticate" unchecked)

Code: [Select]
user_pref("mail.account.account1.identities", "id1");
user_pref("mail.account.account1.server", "server1");

user_pref("mail.identity.id1.fullName", "My Nick1");
user_pref("mail.identity.id1.identityName", "Nick1");
user_pref("mail.identity.id1.smtpServer", "smtp1");
user_pref("mail.identity.id1.useremail", "nick1@provider1.com");

user_pref("mail.server.server1.hostname", "pop.provider1.com");
user_pref("mail.server.server1.name", "My Nick1 account (normal)");
user_pref("mail.server.server1.port", 110);
user_pref("mail.server.server1.type", "pop3");
user_pref("mail.server.server1.userName", "nick1@provider1.com");

// user_pref("mail.server.server1.useSecAuth", 0);
// I don't know if this line with another value than 0 or false is supported through Avast (??). I think it is, but I did not test.

user_pref("mail.smtpserver.smtp1.hostname", "smtp.provider1.com");
user_pref("mail.smtpserver.smtp1.port", 25);
user_pref("mail.smtpserver.smtp1.try_ssl", 0);

user_pref("mail.smtpserver.smtp1.username", "nick1@provider1.com");
// this last line could be unnecessary, according to provider1


My Thunderbird gmail account :
* POP
- login "nick2@gmail.com"
- server "127.0.0.1"
- port "11110"
- security protocol : none ("secure connection (SSL)" unchecked and "secure authenticate" unchecked)
* SMTP
- login "nick2@gmail.com" (don't forget it, in addition to pop login)
- server "127.0.0.1"
- port "11025"
- security protocol : none ("secure connection" : "none" checked)

Code: [Select]
user_pref("mail.account.account2.identities", "id2");
user_pref("mail.account.account2.server", "server2");

user_pref("mail.identity.id2.fullName", "My Nick2");
user_pref("mail.identity.id2.identityName", "Nick2");
user_pref("mail.identity.id2.smtpServer", "smtp2");
user_pref("mail.identity.id2.useremail", "nick2@gmail.com");

user_pref("mail.server.server2.hostname", "127.0.0.1");
user_pref("mail.server.server2.name", "My Nick2 account (Gmail)");
user_pref("mail.server.server2.port", 11110);
user_pref("mail.server.server2.type", "pop3");
user_pref("mail.server.server2.userName", "nick2@gmail.com");

// user_pref("mail.server.server2.useSecAuth", 0);
// this line does not appears, but it doesn't exists with another value than 0 or false

user_pref("mail.server.server2.realhostname", "127.0.0.1");
// I don't know if this line is usefull. it is the only one "realhostname" line of all my "prefs.js"

user_pref("mail.smtpserver.smtp2.hostname", "127.0.0.1");
user_pref("mail.smtpserver.smtp2.port", 11025);
user_pref("mail.smtpserver.smtp2.try_ssl", 0);

user_pref("mail.smtpserver.smtp2.username", "nick2@gmail.com");
// this last line is really necessary


My stunnel conf :
Code: [Select]
# We're running as a client to SSLify the GMail POP/SMTP connections
client=yes

# POP3 service, listens on localhost:11110
[gmail-pop3s]
accept=127.0.0.1:11110
connect=pop.gmail.com:995
#or the SSL port of your Secure POP server if you use another service.

# SMTP service, listens on localhost:11025
[gmail-smtps]
accept=127.0.0.1:11025
connect=smtp.gmail.com:587
protocol=smtp
#or the SSL port of your Secure SMTP server if you use another service.
I'm not sure that "protocol=smtp" is really usefull (?), but "protocol=pop(3)" in [gmail-pop3s] seems pop scan to unwork


My Avast conf :
Code: [Select]
[MailScanner]
Log=20
ShowTrayIcon=1
AutoSetProtection=0
PassThrough=1
Trust=127.0.0.1
AutoRedirect=1
StartSmtp=1
StartPop=1
StartImap=1
StartNntp=1
PopRedirectPort=110,11110
SmtpRedirectPort=25,11025
ImapRedirectPort=143
NntpRedirectPort=119
IgnoreLocalhost=0
IgnoreAddress=

Now everything works together !
It remains to add a anti-Spam if need be
« Last Edit: November 21, 2005, 04:13:55 PM by wanidoob »
english newbie ::) + network newbie :-\ ... ... ... so please be patient :-*

Offline yoramdavid

  • Newbie
  • *
  • Posts: 1
Re: Listening POP to 2 ports simultaneously ?
« Reply #18 on: March 11, 2006, 09:18:44 PM »
Hello, I did all this and it worked fine for a while.
Then all the sudden thuinderbird would check for new e-mail, sends login information and says: Downloading message 1/3 and does not download anything.

Can anyone help with this, please?
I run stunnel 4.10

regards,

yoram