Author Topic: Avast! 8 doesn't work on my PC  (Read 13983 times)

0 Members and 1 Guest are viewing this topic.

Offline Sebay

  • Newbie
  • *
  • Posts: 1
Re: Avast! 8 doesn't work on my PC
« Reply #30 on: March 14, 2013, 03:53:33 PM »
We have purchased a license for a number of computers. It's worked everywhere in the office. Now, wanted to install Avast! Pro Antivirus on another computer - and there's a huge issue.

The computer is running on XP SP3. No other antivirus installed, no Microsoft Security Essentials etc.

What's happening?

Avast Pro Antivirus install goes smoothly. The problem occurs when the process is done and I want to provide the license file of our subscription. It recognizes the license is valid till 2014 but then a famous "AAVM detected an RPC error" is shown. As a result Avast simply doesn't work.

But that's not everything. After rebooting there's another issue. After very first pressing of any key on the keyboard - both keyboard and touch pad freeze. The only possible way to uninstall Avast! (or do anything else) is to use touch pad only without pressing any key on keyboard while Windows is running. I found that Avast (after restarting Windows) somehow gets into keyboard drivers and... And I don't know what. I'm not a technician, I'm a customer and I just want the product to work.

I tried uninstalling Avast with the uninstall utility. Reinstalling didn't show any difference.

What else can be done?

Offline grtguyintx

  • Newbie
  • *
  • Posts: 4
Re: Avast! 8 doesn't work on my PC
« Reply #31 on: March 14, 2013, 05:08:27 PM »
I got same problem ad you all. To begin with downloading and installing Avast 8 was painfully slow and that was just the start of my problems. When i finally got it installed, it started to hog my CPU memory, slowed down my pc down badly and not to mention that it completely freezes my PC especially when i try to register Avast.

By the way, i don't have corrupt files, no other antivirus software, no firewall yet, and no other programs running that were mentioned on here that seem to cause problems.

My third PC still have version 7 and that is working fine but the other to PC's are not. On one PC i have windows XP and on the other one i have windows 7.

I hope they get a fix on this soon or i will have to go back to AVG.
« Last Edit: March 14, 2013, 06:30:26 PM by grtguyintx »

Offline pocaloca30

  • Newbie
  • *
  • Posts: 7
Re: Avast! 8 doesn't work on my PC
« Reply #32 on: March 14, 2013, 05:30:19 PM »
I run windows vista. I have Avast!Pro. When the popup prompted me to download the new version 8, I did and the computer locked up on reboot. I had to start the computer with the boot disk and then ran system restore. The older version of Avast! would not activate. I run into endless loops when I try to restart Avast! Not computer savvy. Very angry and frustrated. The good folks at Avast! should never have released version 8 until all the bugs were straightened out. :-[

Update: I first ran CCleaner64 to clean up the mess in my registry. Then I noticed that Microsoft wanted to install an update and so I let it. I then ran the Avast! clean uninstall ap in safe mode. I then double clicked on the Avast! Pro install short cut on my desktop and the dialog box that opened said that my Avast! version needed updating and so I let it using my existing license. But lo and behold after the successful download and installation, it turns out that I re-installed version 7 not 8.  Works fine now.
« Last Edit: March 14, 2013, 10:10:12 PM by pocaloca30 »

Offline True Indian

  • Malware Hunter
  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 710
  • A Good Old Indian!
Re: Avast! 8 doesn't work on my PC
« Reply #33 on: March 14, 2013, 06:09:29 PM »
I guess if anyone here is experiencing black screen issues they should report their PC specs and the other security software running beside avast here: http://forum.avast.com/index.php?topic=117895.0