Author Topic: Exclusion doesn't work 100%  (Read 4554 times)

0 Members and 1 Guest are viewing this topic.

Offline WebMaximus

  • Jr. Member
  • **
  • Posts: 63
Exclusion doesn't work 100%
« on: March 22, 2013, 06:42:44 PM »
I have trouble with a password-protected archive. I have the same archive on two disks in my computer, the main disk and a second disk where I keep backups of much of the content on the first disk.

I've tried adding an exclusion for the password-protected archive and strange enough it works just fine for the first disk but not for the second disk although the path is exactly the same on both disks except for the drive letter.

My first disk where the exclusion works just fine looks like this...

D:\Install\MSFS\FSX\Payware\NOT USED\REX\*

...and the second disk where the exclusion for some reason I don't understand looks like this...

E:\Install\MSFS\FSX\Payware\NOT USED\REX\*

Might also mention that I've tried entering the exclusion both directly in the settings for Full System Scan and also in Global Exclusions but the result is the same, it will only work for the D disk and not for the E disk.

Is this some kind of bug or what am I missing here...?

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85144
  • No support PMs thanks
Re: Exclusion doesn't work 100%
« Reply #1 on: March 22, 2013, 06:50:49 PM »
Try ?:\Install\MSFS\FSX\Payware\NOT USED\REX\* the ? is a single character wildcard, so should work on both D and E drives.

Though I would suggest that you limit the exclusion to the password protected archive file, change the \* to\filename.zip etc. or you could be exposing your system through this hole in security.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11798
    • AVAST Software
Re: Exclusion doesn't work 100%
« Reply #2 on: March 22, 2013, 07:11:18 PM »
Could you post a screenshot both of the exclusions window, and of the results of the scan (on the E: drive)?

Offline WebMaximus

  • Jr. Member
  • **
  • Posts: 63
Re: Exclusion doesn't work 100%
« Reply #3 on: March 22, 2013, 10:25:34 PM »
This is what the exclusions look like



And this is what the result look like



Will try replacing the drive letters with ? as a wildcard, that will be interesting really!

Offline WebMaximus

  • Jr. Member
  • **
  • Posts: 63
Re: Exclusion doesn't work 100%
« Reply #4 on: March 22, 2013, 11:40:37 PM »
Just tried another full scan after adding ?:\Install\MSFS\FSX\Payware\NOT USED\REX\* to the exclusion list and that did the trick, thanks for the tip!

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11798
    • AVAST Software
Re: Exclusion doesn't work 100%
« Reply #5 on: March 23, 2013, 12:12:12 AM »
On the first screenshot, is there an accent ("umlaut") over the E drive letter?

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85144
  • No support PMs thanks
Re: Exclusion doesn't work 100%
« Reply #6 on: March 23, 2013, 12:16:16 AM »
You're welcome.

Well, that tip was really to prevent having to have lots of essentially duplicate entries in exclusions. But it is a mystery why the individual entries didn't work for both, but the wildcard does.

Edit: Ah seems like Igor spotted why.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline WebMaximus

  • Jr. Member
  • **
  • Posts: 63
Re: Exclusion doesn't work 100%
« Reply #7 on: March 23, 2013, 11:58:23 AM »
Well spotted there Igor and don't ask me how that ¨ended up there on the E, must have stumbled on my keyboard somehow  ;)

Will continue to make use of the wildcard (?) but just for testing purposes I again added an exclusion using the E drive letter and performed another full scan and this time it completed just fine with no warning messages so all is good!

Thanks again guys to both of you  :)

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85144
  • No support PMs thanks
Re: Exclusion doesn't work 100%
« Reply #8 on: March 23, 2013, 04:15:49 PM »
No problem, glad I could help.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security