Author Topic: Help! AhAScr.dll problem  (Read 5987 times)

0 Members and 1 Guest are viewing this topic.

Offline zero_cool

  • Newbie
  • *
  • Posts: 4
Help! AhAScr.dll problem
« on: March 03, 2005, 06:09:26 PM »
Hi!
I have a big problem I can not solve. When I right-click on an image and want to see the properties I get an error message saying IE must close because of an error in the component; JScript Language - AhAScr.dll
I have tryed to look thrue all the help topics but can not find any solution, maybe because I am not an expert in either english or computers, please help!
I am running Avast pro on Xp

Best regards and thank in advance

Offline Darren

  • Jr. Member
  • **
  • Posts: 55
Re: Help! AhAScr.dll problem
« Reply #1 on: March 03, 2005, 06:20:28 PM »
Quote
If you have avast Pro, it's probably some problem in the Script Blocker installation. ...

 Try to run

regsvr32 /u <avast-path>ahascr.dll

This will unregister the script blocker and all scripts should be OK.
Now, you can try to re-enable the Script Blocker by issuing the command

regsvr32 <avast-path>ahascr.dll

Thanks
Vlk

Offline zero_cool

  • Newbie
  • *
  • Posts: 4
Re: Help! AhAScr.dll problem
« Reply #2 on: March 03, 2005, 06:34:33 PM »
Thank you for such a fast reply!  :)
Unfortunatly it does not work (if I understand you correct I should copy & past the line: "regsvr32 /u <avast-path>ahascr.dll", into "run").
I then get a message saying:
REGSVR32
Load Library ("<avast-path> ahascr.dll") failed - can not find the modul.

Please be more precise on what to do - I am such a moron on these things...  :-[

I would be so happy if I could get rid of this problem - sooo irritating!

Thanks again!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Help! AhAScr.dll problem
« Reply #3 on: March 03, 2005, 06:42:04 PM »
I suppose you changed the <avast-path> by the correct path of avast in your computer...  ::)
The best things in life are free.

Offline zero_cool

  • Newbie
  • *
  • Posts: 4
Re: Help! AhAScr.dll problem
« Reply #4 on: March 03, 2005, 08:09:44 PM »
Ok...  :-\ Do you mean it should like this;
regsvr32 <C:\Program\Alwil Software\Avast4>ahascr.dll

Or...? I said I am totally lost here....  :-[

Anyway I tried that but no succes...
Anyone else that could please help to explain!?

Offline zero_cool

  • Newbie
  • *
  • Posts: 4
Re: Help! AhAScr.dll problem
« Reply #5 on: March 03, 2005, 09:05:04 PM »
Puh, finally (thx to another site!) I managed to get it right!
I appr. your help but it is a bit strange that you seem to think everyone here is a computer geek...  :(
The right command to write was:
regsvr32 /u "C:\Program\Alwil Software\Avast4\ahascr.dll"

...would have saved me hours if I got that info straight away!

Well, thx anyway for your answers!  :)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Help! AhAScr.dll problem
« Reply #6 on: March 03, 2005, 09:43:38 PM »
...would have saved me hours if I got that info straight away!

Sorry  :-[  :-[
The best things in life are free.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11765
    • AVAST Software
Re: Help! AhAScr.dll problem
« Reply #7 on: March 03, 2005, 10:28:14 PM »
It would be really helpful if you could provide is with details about the error (such as the exact error message, if it concerns all images or just some, etc.). If there's any problem there, we would certainly like to fix it.

(The same way you unregistered it, it can be registered again - when running
regsvr32 "C:\Program\Alwil Software\Avast4\ahascr.dll"
- i.e. ithout the /u argument.)
And of course, you already know how to unregister it ;)