Author Topic: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears  (Read 33076 times)

0 Members and 1 Guest are viewing this topic.

Peachead

  • Guest
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #15 on: March 14, 2013, 06:09:30 PM »
Beginning to think Avast has well passed it's use by date

MASS RESIGNATIONS NOW IMPERATIVE

Offline glnz

  • Sr. Member
  • ****
  • Posts: 300
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #16 on: March 15, 2013, 12:40:54 AM »
Peachead:  I do not agree with you.  But AVAST SHOULD RESPOND TO THIS ISSUE PRONTO.  Right now, AVAST IS NOT RELIABLY SCANNING INCOMING SSL EMAILS.
Various Dell Optiplexes running XP Pro SP3 32-bit, Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit.  Firefox with security add-ons.

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #17 on: March 15, 2013, 03:30:29 AM »
Could not send this morning and was greeted by this.
printed on 100% recycled bytes

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #18 on: March 15, 2013, 03:32:14 AM »
And these
printed on 100% recycled bytes

ecomlearning

  • Guest
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #19 on: March 15, 2013, 12:39:54 PM »
Registered just to add to this thread.

Recently upgraded from Avast Free 7 to 8.
I have used the Avast removal tool as instructed (Safe Mode etc etc)

The problem I have is with a program called Syncrify, it's backup software, all the rest of my email is done on webmail so is not affected. Every night when my backup completes it sends an email with the log file to me. I have it configured with Gmail using smtp.gmail.com and TLS port 587.
This all worked fine with Avast 7.
Now with 8, the only way I can get it to work is either disable the mail shield, or a slightly less drastic approach is Settings>Troubleshooting>Redirect Settings>SMTP Ports and delete 587.
I tried putting smtp.gmail.com in the Ignored Addresses but it makes no difference.

If it helps I have Win7 Pro 64bit, all up to date (according to the new Avast feature) and the backup software I believe is implemented using Java.

When Avast does scan 587 the backup software reports:
Error: Unable to connect to remote SMTP server. Can't send command to SMTP host

I have also tried SSL with port 465 but have even less success with this, where as I know it worked before.

Comment and/or fix from Avast would be appreciated.
(this may sound cheeky to expect support on the free version, I mean it is free after all, but my excuse is I do have other PCs using the paid version)

Offline glnz

  • Sr. Member
  • ****
  • Posts: 300
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #20 on: March 15, 2013, 01:36:09 PM »
Update:  Two items to note - one good and one bad

FIRST - I have now checked four and a half days of emails received on my two email accounts (one SSL @verizon.net and one NOT SSL @[wife's company name.com via Network Solutions].  My incoming email app is Outlook Express 6, and my PC is a Dell with WinXPPro SP3 and plenty of RAM.

All are now being checked by Avast.  When I started this thread, four incoming emails on Tuesday, March 12, from 9:32pm to 10:09pm EDT were NOT checked by Avast.  (Their "Properties - Details" LACK the lines
   X-Antivirus: avast! (VPS 130314-2, 03/14/2013), Inbound message
   X-Antivirus-Status: Clean
that I now find on my other incoming emails.)

So, it looks better.  But why did four NOT get checked?

SECOND - Avast has blessed a BAD incoming email.  Troubling.
On Thursday, March 14, 2013 8:50 AM EDT, I received a fake email on my SSL verizon.net email account saying it was from Experian with the legend "A Key Change Has Been Posted to One of Your Credit Reports" and a zip attachment.  It was an obvious ambush from bad guys (which I have just confirmed with Experian tech support), and I forwarded it to spamdetector.notcaught@verizon.net.  However, this bad email HAS the two lines
   X-Antivirus: avast! (VPS 130313-1, 03/13/2013), Inbound message
   X-Antivirus-Status: Clean
WHY DID AVAST BLESS THIS EMAIL?

AVAST - IS AVAST 8 REALLY OK?
« Last Edit: March 15, 2013, 01:38:01 PM by glnz »
Various Dell Optiplexes running XP Pro SP3 32-bit, Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit.  Firefox with security add-ons.

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #21 on: March 15, 2013, 06:13:59 PM »
So, it looks better.  But why did four NOT get checked?

SECOND - Avast has blessed a BAD incoming email.  Troubling.
On Thursday, March 14, 2013 8:50 AM EDT, I received a fake email on my SSL verizon.net email account saying it was from Experian with the legend "A Key Change Has Been Posted to One of Your Credit Reports" and a zip attachment.  It was an obvious ambush from bad guys (which I have just confirmed with Experian tech support), and I forwarded it to spamdetector.notcaught@verizon.net.  However, this bad email HAS the two lines
   X-Antivirus: avast! (VPS 130313-1, 03/13/2013), Inbound message
   X-Antivirus-Status: Clean
WHY DID AVAST BLESS THIS EMAIL?

AVAST - IS AVAST 8 REALLY OK?

Were the 4 not scanned downloaded before you got the SSL issue sorted?  Or were they downloaded from the non-SSL account?

The bad incoming message likely wasn't infected.  Do you have the AntiSpam module running?  It would have likely marked it as Phishing.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline glnz

  • Sr. Member
  • ****
  • Posts: 300
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #22 on: March 16, 2013, 01:01:50 AM »
Dear Gopher John: 

Thanks.

Is there an anti-spam module in AV 8 Free?  If yes, where do I go to turn it on?
Various Dell Optiplexes running XP Pro SP3 32-bit, Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit.  Firefox with security add-ons.

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #23 on: March 16, 2013, 01:20:01 AM »
Dear Gopher John: 

Thanks.

Is there an anti-spam module in AV 8 Free?  If yes, where do I go to turn it on?

I'm sorry.  The AntiSpam module is only in AIS and Avast Premier.  However, Thunderbird, Pegasus Mail and several other email clients do have built-in antispam capabilities.  I use Pegasus Mail, and it's SpamHalter does a fine job for me.  SpamHalter use Bayesian logic, so the user has to train it at least at first.  I get very little spam since dumping my old MyRealBox account, so SpamHalter's training is likely stale by now.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

eBatch

  • Guest
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #24 on: March 23, 2013, 07:57:45 PM »
If your SSL emails are not being scanned after following the "official" instructions that came with Avast 8,  I suggest that you check Avast's emailshield.ini settings. emailshield.ini can be found at something like C:\Documents and Settings\All Users\Application Data\AVAST Software\Avast\EmailShield.ini (XP location) or C:\ProgramData\AVAST Software\Avast\EmailShield.ini (Vista, Win7). Note these folders may be hidden. If you have updated to Avast8 from earlier versions the details of the folder names may vary slightly - e.g. C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\EmailShield.ini

Under the [EmailScanner] section, there should be:    ScanSSL=1

If this parameter is not there (or set to 0), you can try changing this to 1, as above. Then save the changes, the avast! Self-Defence Module will ask for confirmation, answer Yes.

You will then need to reboot to get the changes to be picked up by Avast.




Offline glnz

  • Sr. Member
  • ****
  • Posts: 300
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #25 on: March 23, 2013, 08:03:39 PM »
eBatch:  Thanks.  But, as I noted above, after the brief period of NON-scanning, Avast seems to be scanning my SSL emails.  My incoming emails now have the following in Properties:
X-Antivirus: avast! (VPS 130323-1, 03/23/2013), Inbound message
X-Antivirus-Status: Clean

I do not know why four were not scanned, and I deleted the phish from fake Experian.
Various Dell Optiplexes running XP Pro SP3 32-bit, Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit.  Firefox with security add-ons.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86518
  • No support PMs thanks
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #26 on: March 23, 2013, 08:55:30 PM »
There is no need to go through that hassle, all it is saying it Scan SSL or Don't scan SSL emails and that option it there in the interface - avastUI, Mail Shield, Settings, SSL Scanning - Scan SSL connections. Check or Uncheck that option toggles that emailshield.ini between 1 and 0 on/off.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

eBatch

  • Guest
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #27 on: March 23, 2013, 09:40:46 PM »
The whole point of my suggestion is in case using the avastUI doesn't take effect in the emailshield.ini file (as has happened to me on at least one occasion). Bods can therefore "manually" enforce the necessary change to see if that makes any difference.

njcarlos

  • Guest
After looking around the web for answers to this problem, none of them helped.

The solution I did find, however, seemed to solve my problem perfectly well.

My problem: hotmail/live e-mail accounts were unable to connect to pop3.live.com (i.e. you could see in Thunderbird status bar "Connected to pop3.live.com" but, nothing would actually happen).

To solve this problem, I took the following steps...

1. Right click on the e-mail address in the left-most addresses/accounts pane that's having issues.
2. Click "Settings"
3. Click on "Security" for the security sub-section of settings for this account
4. Click "View Certificates"
5. Click on the "Others" tab
6. You should see an avast! certificate there for the particular pop3 mailserver.
7. Delete it.
8. Close Thunderbird completely
9. Open avast!
10. Click on the "Security" tab
11. Click on the "Mail Shield" icon
12. Click "Settings" (next to Stop)
13. Go to "SSL Scanning" in the navigation menu
14. Uncheck "Scan SSL connections"
15. Click "OK"
16. Click "Settings" again (next to Stop)
17. Go to "SSL Scanning" in the navigation menu
18. Check "Scan SSL connections"
19. Click "OK"
20. You should get a warning you'll need to restart your e-mail client. If you haven't already closed it, restart it now.
21. When Thunderbird attempts to retrieve your e-mails, you should get warnings about certificates. Accept them all (make sure permanently). These are just avast! generated, you can check by clicking "View" and you will see the publisher/creator is avast! Mail Scanner.
22. Enjoy your e-mail (hopefully)

By deleting the certification, and what seems to force avast! to re-generate their SSL certificates, it should now be working fine and scanning your e-mails downloaded over SSL.

IMPORTANT: There is a lot of misinformation about removing ports from the Redirect Settings in the Troubleshooting section. Do not do this. If you have done this, replace them with the following:

HTTP port(s): 80,8080,8091,8081,8008,8888,3124,3127,3128
Check "Ignore local communication"

SMTP port(s): 25,587
POP port(s): 110
IMAP port(s): 143
NNTP port(s): 119
Check "Ignore local communication"

Hope this helps someone. If it does, please post and let others know.
« Last Edit: June 08, 2013, 07:49:10 AM by njcarlos »

Curly Richardt

  • Guest
Here is a workaround that worked for me with Seamonkey (and might work also with the rest of the Mozilla-family):
Check that "SSL on" is activated in the avast settings menu. I did add the respective used ports, but don't know whether that is necessary, it didn't harm the results, though.
For outgoing mail: Make sure that old certificates for Avast in your e-mail program are deleted; compose and send an e-mail to your own address, then (only!) you will get the prompt for an "exception to a certificate" - this prompt may be hidden underneath other windows, don't close them, just minimize! Save the certificate, and note the valid time - some were only to 2014, others to 2018; at that point you might have to repeat the procedure again.
For incoming mail: Just check for new mails, you will also get the "exception to certificate", check and save as above.
Repeat this for every other possible account.
This procedure was easier on Avast7, and the upgrade to 8 migrated this settings. After having to reinstall Windows and Software the new installation of Avast8 did not accept the old certificates, that were still stored in the Seamonkey settings; that's why it is important to delete the old avast certificates, especially when installing avast8 new.
P.S.: I've been using avast for 3 years now, and yes: the layout of the 7 Version I liked better, too!
P.P.S.: I did not go into details about the certificates, since NJCarlos did that explicitly already in his post above
« Last Edit: June 16, 2013, 07:26:33 PM by Curly Richardt »