Author Topic: Avast 8.0 and Thunderbird 17 with Gmail  (Read 8088 times)

0 Members and 1 Guest are viewing this topic.

Offline bazsihuhu

  • Newbie
  • *
  • Posts: 4
Avast 8.0 and Thunderbird 17 with Gmail
« on: March 17, 2013, 04:14:47 PM »
Hi everybody,

I am using Gmail with IMAP.
I can not send and receive e-mails when I turn on in Avast 8 the "SSL Accounts check", it works fine when I turn it off. It worked in Avast 7 as well.
I had Thunderbird and Avast 8 reinstalled and my e-mail account reconfigured too. Result is negative.
How can I configure my Avast 8?

my system:
Win XP SP3
Avast free 8.0.1484
Comodo 6.0.264710.2708
Thunderbird 17.0.4

imap.gmail.com - SSL/TLS - 993
smtp.gmail.com - STARTTLS - 587

Please help me.
Thanks in advance.


« Last Edit: March 17, 2013, 04:30:26 PM by bazsihuhu »

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3921
  • When you think you know, Think Again
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #1 on: March 17, 2013, 05:10:45 PM »
Hi everybody,

I am using Gmail with IMAP.
I can not send and receive e-mails when I turn on in Avast 8 the "SSL Accounts check", it works fine when I turn it off. It worked in Avast 7 as well.
I had Thunderbird and Avast 8 reinstalled and my e-mail account reconfigured too. Result is negative.
How can I configure my Avast 8?

my system:
Win XP SP3
Avast free 8.0.1484
Comodo 6.0.264710.2708
Thunderbird 17.0.4

imap.gmail.com - SSL/TLS - 993
smtp.gmail.com - STARTTLS - 587

Please help me.
Thanks in advance.

Hi and Welcome:
Possibly this will help>http://www.avast.com/faq.php?article=AVKB91#artTitle :)
***HP ENVY 15K LT  W10 Pro 64Bit/750GB HD/ 16GB Ram/Avast Secureline
**HP Compaq Buisness LT W8.1 Pro 64Bit/1TB HD/ 8GB Ram/Avast Secureline     
*Dell Inspiron  xpSP4 PRO 32 Bit/Avast Premier 2015.10.2.2218
Layered Security Protection on all OS's       Backup & Recovery> WD 500GB HD/Macrium Reflect
Do not confuse Kindness for Weakness

Offline bazsihuhu

  • Newbie
  • *
  • Posts: 4
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #2 on: March 17, 2013, 05:51:29 PM »
Hi everybody,

I am using Gmail with IMAP.
I can not send and receive e-mails when I turn on in Avast 8 the "SSL Accounts check", it works fine when I turn it off. It worked in Avast 7 as well.
I had Thunderbird and Avast 8 reinstalled and my e-mail account reconfigured too. Result is negative.
How can I configure my Avast 8?

my system:
Win XP SP3
Avast free 8.0.1484
Comodo 6.0.264710.2708
Thunderbird 17.0.4

imap.gmail.com - SSL/TLS - 993
smtp.gmail.com - STARTTLS - 587

Please help me.
Thanks in advance.

Hi and Welcome:
Possibly this will help>http://www.avast.com/faq.php?article=AVKB91#artTitle :)

Thank You, but it did not solve the problem.

The Windows Certificate Manager listed two avast certificat. Why have I two certificates?

Offline pdoug44

  • Newbie
  • *
  • Posts: 7
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #3 on: March 17, 2013, 06:24:35 PM »
Holy cow, I went through the steps for Mozilla mail, I use gmail also and it started working!  This has been a much discussed problem and I had almost given up.....

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3921
  • When you think you know, Think Again
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #4 on: March 17, 2013, 06:57:58 PM »
Holy cow, I went through the steps for Mozilla mail, I use gmail also and it started working!  This has been a much discussed problem and I had almost given up.....

Glad to hear things worked out for you. I use Thunderbird with 3 accounts: Windows Live, Gmail and Yahoo and no problems here at all. ;) 8)
***HP ENVY 15K LT  W10 Pro 64Bit/750GB HD/ 16GB Ram/Avast Secureline
**HP Compaq Buisness LT W8.1 Pro 64Bit/1TB HD/ 8GB Ram/Avast Secureline     
*Dell Inspiron  xpSP4 PRO 32 Bit/Avast Premier 2015.10.2.2218
Layered Security Protection on all OS's       Backup & Recovery> WD 500GB HD/Macrium Reflect
Do not confuse Kindness for Weakness

Offline bazsihuhu

  • Newbie
  • *
  • Posts: 4
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #5 on: March 17, 2013, 09:31:14 PM »
Does anyone have a good idea for this problem?

Offline stduc

  • Jr. Member
  • **
  • Posts: 40
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #6 on: March 19, 2013, 01:48:20 AM »
I can only get it to work if I turn SSL checking off.

Furthermore I appear to have the correct certificates installed but get this message when I start Thunderbird

This is beating me at the moment - where can I download Avast 7?


Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 925
    • ALWIL Software
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #7 on: March 20, 2013, 11:13:19 AM »
Does anyone have a good idea for this problem?

Please enable debug logging in avast Settings/Maintenance, simulate the problem and then send me the log file C:\ProgramData\AVAST Software\Avast\log\Mail.log by mail.

Offline breppo

  • Newbie
  • *
  • Posts: 8
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #8 on: April 25, 2013, 09:22:50 AM »
I have the same problem, but it only started a week ago.
POP3 works OK for incoming mail, but not outgoing mail.
IMAP doesn't work at all.
I've tried exporting, deleting and importing the Avast certificate etc.
That didn't work.
Disabling SSL didn't work either.
I've disabled scanning outgoing mail, so I can at least use my POP3 accounts as normal.

The only way that everything works fine is when I disable the Mail shield. But that's inconvenient, to say the least.

Windows 8 Pro 64-bit.
Latest Thunderbird, Avast 8.0.1483.
Latest Comodo firewall.

I've enabled debug logging. If you want the log I can send it to you.

Offline mikaelrask

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1431
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #9 on: April 25, 2013, 09:28:14 AM »
hey and welcome to the forum breppo. yes please send the file to vojtech he/she will look into that and see if there i a problem with avast when using Thunderbird.   
Windows 8.1 amd a10-5700 64 bit
12 GB ram i tb hard drive. Avast 10, MBAM

Offline breppo

  • Newbie
  • *
  • Posts: 8
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #10 on: April 25, 2013, 10:01:11 AM »
I've sent the log to vojtech.

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 925
    • ALWIL Software
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #11 on: April 25, 2013, 10:48:34 AM »
Hello,

you can download the fixed Mail Shield here:
http://public.avast.com/~peterka/8.0.1483/ashMaiSv.dll

1) Disable the self-defense in avast! settings/Troubleshooting and stop the Mail Shield
2) Put the new ashMaiSv.dll to the program folder (C:\Program Files\AVAST Software\Avast)
3) Enable the self-defense and start the Mail Shield

Offline breppo

  • Newbie
  • *
  • Posts: 8
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #12 on: April 25, 2013, 11:07:13 AM »
Alas the fixed dll didn't work.
Problems still the same.

Offline Neil Parks

  • Jr. Member
  • **
  • Posts: 28
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #13 on: April 25, 2013, 10:00:16 PM »
Alas the fixed dll didn't work.
Problems still the same.
Go back into Troubleshooting,  and select the option to reset factory defaults.  Then reboot when prompted.

That might--might--do it.

(I'm hoping).


Offline breppo

  • Newbie
  • *
  • Posts: 8
Re: Avast 8.0 and Thunderbird 17 with Gmail
« Reply #14 on: April 26, 2013, 08:11:12 AM »
It's all working now!!

This is what I did:

1 Restore to factory settings
2 Disabled the self-defense
3 Disabled the Mail shield
4 Copied the fixed Mail shield to the Avast program folder
5 Enabled the self-defense
6 Enabled the Mail shield
7 Followed the procedure to replace the Avast certificate in TB (explained elsewhere)
8 Enabled the SSL/TLS on the Gmail accounts in TB (I still had that disabled and that didn't work!)

I'm not quite sure if all the steps are really necessary, but this is how it worked for me.

Thanks for the quick replies!!