Author Topic: Avast! causes system crash [Win98]  (Read 33721 times)

0 Members and 1 Guest are viewing this topic.

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #15 on: March 14, 2005, 08:56:45 AM »
I removed the icon using the .ini file. The menu item works fine once the icon was removed.

The computer still seems to be having some shut down problems even with the Database=XML setting. Now it doesn't happen every time but it still seems to happen. Any ideas on that one?

Thanks guys!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: Avast! causes system crash [Win98]
« Reply #16 on: March 14, 2005, 03:01:11 PM »
Are you using a firewall? Which one?
Which programs (or processes) are opened when you start shutting down?
The best things in life are free.

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #17 on: March 16, 2005, 05:30:51 AM »
I'm not using a software firewall. I have a router and a dynamic IP and for now I'm relying on that (yes I know it's probably not enough).

The programs running on my system at any given time including shutdown as listed in Task Manager (Ctl-Alt-Del version) are as follows:

Winfax MOD - USR 56k ..... (The part of Winfax that monitors the modem for incoming calls)
Explorer
Hotsync (For my Palm Pilot)
wfxctl32 (The Winfax controller)
Cliptrack (A clipboard utility that saves your last 20 text clipboard entries so you can use them again)
Rsrcmtr
Point32
Loadqm
Mswheel
Rundll
Mixghost (a utility from my soundcard)
Stimon
Systray
Upsd (My UPS monitoring software)
E_S10ic2 (Printer software)
Ashmaisv
Ashwebsv

The only thing that's different here from before I installed Avast! is that now Avast! is running instead of EZ-AV. Nothing else has changed.

The shutdown now is unpredictable. It sometimes works and sometimes doesn't. With the Database=ODBC setting I don't think it ever worked. Before installing Avast! it always worked.

What's next to try?

Thank!
« Last Edit: March 16, 2005, 05:32:43 AM by YSB »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: Avast! causes system crash [Win98]
« Reply #18 on: March 16, 2005, 08:37:25 PM »
The only thing that's different here from before I installed Avast! is that now Avast! is running instead of EZ-AV. Nothing else has changed.

Are you sure that you remove completely EZ antivirus?
Do it have a 'external' removal (uninstall) stronger than the Control Panel Add/Remove applet?
In fact, it's beyond my imagination what is going on in your system...  ::)
The best things in life are free.

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #19 on: March 17, 2005, 09:42:17 AM »
Well let's put it this way. I recognize everything in the Ctl-Alt-Del list and none of those files are EZ-AV related. The uninstall from control panel started the EZ-AV uninstall utility which removed all the files from the EZ-AV folder. (I checked. Nothing is there.) If anything was left behind it can't be doing much.

Like I said before, the only thing that has changed on the system that I am aware of is the anti-virus. If you want I can uninstall Avast! and test the shutdown but since the problem doesn't happen every time it may be hard to prove anything that way and that would mean running without virus protection for a short time. I don't know what else to tell you. I would surmise that something in Avast! is not shutting down correctly or is preventing something else from shutting down but I'm not sure how to even test that.

If there is any other info that you think could be helpful I'll do my best to supply it. Aside from that I'm afraid that the ball is in your court now. If I am going to keep Avast! the problems will have to be solved somehow. You did a good job on the crashing problem. If you can solve this one you'll have one very happy guy here.

Thanks for your help!

frankzen

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #20 on: March 17, 2005, 10:23:35 PM »

I still have to update you on the shutdown issue. Changing the Database entry to XML may have helped but I'm not sure yet. It also won't help if I go Pro and if I keep Avast! that would be my intention.



I just uninstalled Avast for the exact same reason - my system with Win98 never shutdown and I have never had this problem before with any software.
Too bad - I liked the scan speed although I could do without the overkill skins.

Aenea

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #21 on: March 18, 2005, 01:10:35 AM »
I am using Windows98SE and for a very long time I have been experiencing shutdown freeze problems.  Someone said that it was a memory related problem, yet increasing my RAM to 256Mb did not help.  Installing the microsoft patch that delays shutdown by a few seconds also didn't help - so I thought perhaps my system needed more than just a few seconds. So I started waiting for a full minute before clicking on the final shutdown button and find that 9 out of 10 times, my pc shuts down fine.  It may also help closing down as many programs as possible before final shutdown. 

I realize the above is not the answer to your problem, but offer it in the hope that it may prove a temporary remedy, till the solution is found.

Regards - Aenea

joeloucyn

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #22 on: March 18, 2005, 04:05:42 AM »
I am using Win 98 second edition and have shutdown problems since I installed Avast!
If I start up with my printer (on parallel port) turned off (and leave it off), my computer shutdown perfectly everytime, but if I start up with my printer on then I have shutdown problems !
I think Avast! must be scanning my parallel port causing the shutdown problems ! And yes I do have all the shutdown patches installed ......

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #23 on: March 18, 2005, 07:27:40 AM »
I guess it's good to hear I'm not the only one with this problem. That doesn't help me directly but at least it shows that there is something of a pattern that could hopefully be addressed. For the record, I tried waiting for the computer to shut down. I came back after an hour and it was still frozen so that doesn't seem to be the answer.

The shutdown problems happen now about 9 times out of 10 so this is becoming a real issue. I sometimes work from remote and it's important for me to be able to reliably restart my computer when no one is around to do a hard reset.

Guys, keep working on this one. You can do it! We're counting on you.  8)

Aenea

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #24 on: March 18, 2005, 01:45:48 PM »
  "For the record, I tried waiting for the computer to shut down. I
   came back after an hour and it was still frozen so that doesn't
   seem to be the answer".

After clicking START and then SHUT DOWN, you are presented with the small SHUT DOWN WINDOW with options to SHUT DOWN, RESTART, etc - the additional waiting I suggested in my previous posting is to be done between the first SHUT DOWN and 2nd (and final) SHUT DOWN click.  I do hope this helps, as I know too well the frustration of shutdown freezes. 

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #25 on: March 20, 2005, 05:39:29 AM »
Tried that, no dice. I waited over 5 minutes before clicking the second shutdown and it still froze.

Technical, have you come up with anything yet? Eddy? Igor?

Thanks again!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: Avast! causes system crash [Win98]
« Reply #26 on: March 20, 2005, 04:43:38 PM »
Technical, have you come up with anything yet?

No... I had few problems at shutdown, very very rare... I didn't even troubleshoot them because they went away...
Besides, I use XP. Igor will be the man for this.
The best things in life are free.

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #27 on: March 21, 2005, 06:41:28 AM »
Maybe this piece of info will help. If I disable Avast protection before shutting down then it shuts down fine. Could it be that Avast is trying to scan files as they are shutting down and locking them in the proccess causing the big freeze? :-\

Thanks guys. Keep trying. You can do it!


YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #28 on: March 21, 2005, 06:50:38 AM »
At least I thought that helped. It did yesterday. I just tried shutting down right after that last post. I shut down Avast! On-Access scanning and it froze anyway. Now I'm REALLY confused.  ???

Any more ideas? Should I try to uninstall Avast! and see what happens?

Thanks again guys!

YSB

  • Guest
Re: Avast! causes system crash [Win98]
« Reply #29 on: March 22, 2005, 09:33:13 AM »
Any news? I'm just bringing this one back to the top.

Thanks!