Author Topic: 16-bit program not working correctly  (Read 7648 times)

0 Members and 1 Guest are viewing this topic.

backman

  • Guest
16-bit program not working correctly
« on: September 18, 2003, 06:09:05 PM »
Hi

I have a 16-bit program that accesses data from a CD with some sort of copy protection program in between. Copy protection program is called c-dilla. My problem is as soon as I install Avast the program returns a error message that stats that my cd data is too old and I need to replace it with a new CD. uninstall Avast and everything works fine. Tried to rem the avast line in config.nt plus disable 16-bit and dos protection in the gui to no avail. Please help me!!!

whocares

  • Guest
Re:16-bit program not working correctly
« Reply #1 on: September 18, 2003, 10:30:19 PM »
Hi, you have WIN XP ?

use the board-search above: imho there was way back a similar problem ;)

backman

  • Guest
Re:16-bit program not working correctly
« Reply #2 on: September 19, 2003, 09:04:59 AM »
Yes, I have Win XP but the problem you refer to was related to Norton and I have never had Norton on this machine,,,,

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:16-bit program not working correctly
« Reply #3 on: September 19, 2003, 12:44:00 PM »
What if you remove the reference to avast from HKLM\System\CurrentControlSet\Control\VirtualDeviceDrivers, value called VDD...?

Vlk
If at first you don't succeed, then skydiving's not for you.

backman

  • Guest
Re:16-bit program not working correctly
« Reply #4 on: September 19, 2003, 01:07:16 PM »
If I do that I can't even start command.com

backman

  • Guest
Re:16-bit program not working correctly
« Reply #5 on: September 19, 2003, 01:10:53 PM »
If I should clarify my original problem. The program starts fine but complains of my data-CD beeing to old and need to be replaced. The CD is copyrighted and protected by C-Dilla or Macrovision Safecast technology. If i disable avast services and reboot my system the program works fine. I have tried to exclude c:\windows\system\cdilla*.* as well as the program files.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:16-bit program not working correctly
« Reply #6 on: September 19, 2003, 01:26:01 PM »
You need do to the registry hack together with the config.nt hack - otherwise you indeed won't be able to even start command.com
If at first you don't succeed, then skydiving's not for you.

backman

  • Guest
Re:16-bit program not working correctly
« Reply #7 on: September 19, 2003, 01:44:52 PM »
I still think it is a different issue. I did the registry hack and rem:ed the line in config.nt. Now command.com works (as it always has) but i still get the error message from my program.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:16-bit program not working correctly
« Reply #8 on: September 19, 2003, 01:56:59 PM »
OK in this case it can't be related to the Win16 scanning - it must be just a coincidence that it's a 16bit program... Copy protections sometimes suck as they tend to dislike low-level (but perfectly legal) programs... All I can advise is to try to fiddle with the Standard Shield settings - e.g. does it suffice to pause the provider?
If at first you don't succeed, then skydiving's not for you.

backman

  • Guest
Re:16-bit program not working correctly
« Reply #9 on: September 19, 2003, 03:21:43 PM »
Nope, I have to disable the services and stop them of course