Author Topic: AEA Fails to Generate Reports  (Read 4426 times)

0 Members and 1 Guest are viewing this topic.

Offline cmabie

  • Newbie
  • *
  • Posts: 5
AEA Fails to Generate Reports
« on: April 03, 2013, 09:12:26 PM »
The problem is the AEA console always fails to generate reports, with session status "failed unknown error".

Hunting down this problem I have found a previous topic, that didn't solve the problem yet seems very close.
http://forum.avast.com/index.php?topic=114937.0

Error logs show:

Avast Error log:
COM error in repGenerate(): Crystal Reports ActiveX Designer-Logon failed.

EntServer log:
[2013/04/03 14:59:29.761,3156] Going to generate report 6
[2013/04/03 14:59:30.073,3156] Error -2147189176 in repGenerate: Crystal Reports ActiveX Designer-Logon failed.
[2013/04/03 14:59:30.073,3156] repGenerate() failed with error 0x00000000
[2013/04/03 14:59:30.073,3156] sqlFreeConnection with fReturnToPool=false (error handler)
[2013/04/03 14:59:30.073,3156] SQL Server connection has been destroyed...
[2013/04/03 14:59:30.073,3156] pThis->GenerateReports() failed with 0x0000A410 error

Sql log:
Login failed for user 'sa'. Reason: Password did not match that for the login provided. [CLIENT: <named pipe>]

Avast Setup log:
15:34:36 vrb/sys  instSQL(SQL_MSDE) returned 0x00000000
15:34:36 vrb/sys  Starting service SQLAgent$avast
15:34:36 vrb/sys  Service SQLAgent$avast started, errcode: 0x00000422
15:34:36 vrb/reg  Set registry: System\CurrentControlSet\Services\SQLAgent$avast\Start=2
15:34:36 vrb/sys  Going to create database of avast! on MS SQL server "SCM-ANTIVIRUS\avast", using user "sa"...
15:34:46 vrb/sys  Database was successfully created...
15:34:46 vrb/sys  instSQL(SQL_DATABASE) returned 0x00000000


This install is a fresh install of 2008 R2 x64, fresh install of Avast Enterprise suite, with Sql express and custom "sa" password.  Both installed on the same virtual server, and firewalls completely turned off.

Theory:
For some reason it seems like the crystal reports is not using the custom "sa" password, that or I also noticed the sql express doesn't have named pipes enabled.  Though enabling doesn't solve the problem.  Is there a seperate config.ini for crystal reports, that can be changed?

Thanks!

Offline cmabie

  • Newbie
  • *
  • Posts: 5
Re: AEA Fails to Generate Reports
« Reply #1 on: April 08, 2013, 03:33:53 PM »
Any feedback on this at all?

Offline cmabie

  • Newbie
  • *
  • Posts: 5
Re: AEA Fails to Generate Reports
« Reply #2 on: April 08, 2013, 08:27:01 PM »
I installed on a fresh install of 2008 r2 x64, added the .net 3.5.1 feature (required by sql express 2008 r2), and then installed the Avast Enterprise Suite for Education.

Everything inside the AEA console worked, finding computers, making installs etc..   except reports would always fail.  All the logs show it to be some kind of password issues with the "sa" account. 

My solution:
1. Open the EAS Maintenance with hidden command line switch "-pwdreset"
2. reset console password
3. test sql connection and restart sql service from EAS Maint tool

Not sure why this worked, but it did.  The strange thing in all my testing was, I had to use the EAS Maint tool to restart sql, not the services, or through sql server configuration manager.  There has to be another service or something else this EAS Maint tool is doing!

Good luck!  And I'm curious if this solves anyone else's problem.