Author Topic: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked  (Read 21152 times)

0 Members and 1 Guest are viewing this topic.

Offline AManCalledFlint

  • Newbie
  • *
  • Posts: 3
Hi, I have wrestled with this one for some time now. Thunderbird mail worked ok when Avast was at v7. Now that I have upgraded to AVAST 8 It seems that Avast mail scanner in blocking i/c and o/g mail when the SSL scanning check box is ticked. If it is unticked or if the Mail Scanner is shutdown, then Thunderbird works fine.
I have tried exporting the Avast cert from the root store and importing it into thunderbird. I have also deleted the Avast cert from thunderbird and uninstalled and reinstalled Avast. Thunderbird prompted me to accept Avasts certificate when I subsequently invoked it, which I did. Still it did not work. I then uninstalled Avast using Avasts removal tool, then reinstalled Avast. Thunderbird emails still being blocked when SSL scanning ticked in AVAST mail scanner. I am not sure where to go from here.

I am running a HP laptop with Windows 7 Home Premium 64bit.
Any help would be gratefully received.
Thanks in advance

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36730
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #1 on: April 04, 2013, 11:30:22 AM »
check you mail account settings in thunderbird....
with avast8 they should be default and not changed as you had to do with avast7


Offline avastrich

  • Newbie
  • *
  • Posts: 1
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #2 on: April 04, 2013, 02:04:48 PM »
This worked when Avast 8 first came out a few weeks ago, but stopped working yesterday (April 3, 2013). Avast re-issued certificates and Thunderbird asked me to accept the new certificate. I accepted it and was not able to connect to my mail server after that. I had to disable Avast mail shield, accept my real mail server's certificates in Thunderbird, and then I could get mail again.

Offline AManCalledFlint

  • Newbie
  • *
  • Posts: 3
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #3 on: April 04, 2013, 09:28:42 PM »
Thanks for the replies....

Pondus:  The account settings for the POP and SMTP servers on my 2 original accounts appear correct. The only thing that had changed which was in any case changed back was enabling SSL in those Thunderbird accounts. As I say the accounts work with Avast mail shield disabled or with the mail shield enabled but with SSL scanning disabled.
To further check that it is nothing to do with default account settings as you described this time I let Thunderbird set up an IMAP account to another email address that I have.
Again it I can send and receive mail to and from this account when Avast SSL scanning is unticked or with the Avast mail scanner disabled,  but blocks o/g and i/c mail when SSL scanning is ticked.

avastrich:  From what you described it seems you have disabled Avasts Mail Shield. This would not be acceptable in my case since I want Avast to scan my emails which utilize SSL.


Does anyone else have a similar problem???
Thanks in advance



Offline TerraX

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6468
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #4 on: April 05, 2013, 01:36:52 AM »
Hi,

look here --> http://www.avast.com/faq.php?article=AVKB91#artTitle
Maybe this will help further. ;)
Win10 64bit / Avast Premium Security 20.6.2420 / MBAM Free / Firefox ESR 68.11 [NS/uBO] / Thunderbird 68.10 / AOS/ASB

Offline AManCalledFlint

  • Newbie
  • *
  • Posts: 3
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #5 on: April 05, 2013, 09:57:23 AM »
Hi TerraX,

Thanks for the link. I had already tried exporting the certificate from the root store and importing into Thunderbird using Thunderbirds certification manager as described your link. What I did not do was delete the AVAST certificate entries in Thunderbird certification Manager under the server tab. So I went through the procedure again to be sure and sadly I still have the same result, mail is still being blocked with SSL ticked in Avast.  :(

Offline sscheffler58

  • Newbie
  • *
  • Posts: 1
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #6 on: April 06, 2013, 07:39:18 PM »
Last month, I had the problem after avast was updates Thunderbird said is was updating and nothing happened, no errors.  I could only download emails by disabling the shields.  I verified that I has SSL turned on per AT&T email.  After an update the problem went away and I was happy.  I update frequently and let avast auto update whenever I need to.  In the last 2 days, it broke again.  My emails do not come down automatically.  I try manually and it just shows it is trying to connect.  I turn the shields off and I can get emails.  That is kinda defeating the purpose of avast.  Last month, I checked the settings per all of the information but I also have to set so it will work with AT&T parameters.  I tried turning 1 shield off at a time and still would not work.  I tried turning relevant shields off together and then firewall and spam shields and I could only get it to work with turning all off.  I am not a dummy about this.  I have done tech support for over 25 years.  I have all of my customers on Avast.  I have always said it is a solid product.  What broke again.  I have tried changing some of the settings on thunderbird but then at&T shopped working.

Offline RockabillyHog

  • Newbie
  • *
  • Posts: 2
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #7 on: April 08, 2013, 07:24:30 PM »
Same problem here. Avast, please help.

Offline dyfdd

  • Newbie
  • *
  • Posts: 2
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #8 on: April 08, 2013, 09:12:04 PM »
Exactly the same problem here. Using Thunderbird and have attempted the same fixes listed in this forum, with no success. Please provide a fix Avast.

Offline RockabillyHog

  • Newbie
  • *
  • Posts: 2
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #9 on: April 10, 2013, 05:04:09 PM »
I opened a support ticket and the response helped. My system is running correctly now.

Try this article ... http://www.avast.com/faq.php?article=AVKB91#artTitle

... one correction, make sure that the Avast shields are running before launching the cert manager. If you launch it when Avast is not running, the Avast cert entry will not show in the list.

Hope this helps.

Offline Katdarling

  • Newbie
  • *
  • Posts: 1
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #10 on: April 28, 2013, 11:30:26 PM »
I, too, am having this exact same problem.  Sadly tho, the instructions and fix from the article below did NOTHING to change the situation.

I can only access email (via Thunderbird) by disabling the mail shield altogether.

If anyone has any other suggestions, I'd be greatly appreciative!


Thanks~


I opened a support ticket and the response helped. My system is running correctly now.

Try this article ... http://www.avast.com/faq.php?article=AVKB91#artTitle

... one correction, make sure that the Avast shields are running before launching the cert manager. If you launch it when Avast is not running, the Avast cert entry will not show in the list.

Hope this helps.

Offline gopinathms2012

  • Newbie
  • *
  • Posts: 2
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #11 on: May 04, 2013, 05:55:49 PM »
I tried this and this worked
*switch off your avast!mail shield and open up your thunderbird.
*when thunderbird  starts downloading the messages ( this is the case ie when mailshield is off ,thunderbird works) switch on your mail shield back to normal
*This may seem stupid but this trick worked for me

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 66030
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #12 on: May 04, 2013, 06:00:51 PM »
Updating to 1488 will work as well. ;)
Win 8.1 [x64] - Avast PremSec 20.7.2421.B#1 [UI.544] - CC 5.70 - EEK - FF ESR 68.11 [NS/AOS/uBO/PB] - TB 68.11 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline copyfitz3

  • Newbie
  • *
  • Posts: 1
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #13 on: May 06, 2013, 03:49:32 PM »
I finally got thunderbird working again by following the  instructions in the same link, http://www.avast.com/faq.php?article=AVKB91#idt_0301, but it took me two tries.
the only difference was the second time through i did a better job of deleting the avast!mail scanner entry under the servers tab, the step shown in figures V. C and VI. C.
first time i highlighted the main entry and hit delete, and even though nothing visibly happened i decided that was good enough.  nope.
when Tbird still wouldn't work with avast running, i decided to run through the process again.
but this time, when i got to the servers tab i highlighted the avast  entry and then clicked on its subfiles.  when i hit delete on each individual file, i got a dialog  box asking to verify its removal, and after the second deletion the avast! mail scanner entry disappeared from the list.
after i finished the rest of the process, thunderbird started working normally.
 

Offline Pekhlet

  • Newbie
  • *
  • Posts: 1
Re: Thunderbird Mail being blocked by AVAST Mail Scanner with SSL ticked
« Reply #14 on: May 15, 2013, 09:04:38 PM »
Problen discription: when upgrade to Avast 8 from previous versions, Mozila Thunderbird stops working (not asking for password, checking for email forever and do not receive or send it).
Here is how to get things working in a good manner without compromising your protection:
1. Download and Save Avast remover program (remember where you are saving it; also check wich version of Avast you presently have: for this right click on Avast in your running programs and choose About avast!)
aswclear.exe
from
http://www.avast.com/uninstall-utility
2. Reboot in safe mode for this go to start;
type: msconfig
press Enter
go to Boot tab
check Safe boot / minimal
press OK
Confirm
3. Go to directory, where you saved aswclear.exe
4. Mouse-right click on aswclear.exe and choose Run as administrator (Window 7)
5. Confirm and uninstall the right version of Avast (should be 8).
6. Agree for Restart when prompted.
7. Download Avast 8 from http://www.avast.com/en-ca/index
8. Install it.
9. The Thunderbird should work without problems now.