Author Topic: XP32 service STOPs after upgrade virus database  (Read 2915 times)

0 Members and 1 Guest are viewing this topic.

Offline flyguille

  • Newbie
  • *
  • Posts: 12
XP32 service STOPs after upgrade virus database
« on: April 10, 2013, 05:54:56 PM »
The service stops, it can't upgrade anymore, the UI shows that the service crashed..
I have VS2008 installed and the VS2008 DEBUG windows appear, AvastSvc.exe Exeption one time and again and again....

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11796
    • AVAST Software
Re: XP32 service STOPs after upgrade virus database
« Reply #1 on: April 10, 2013, 05:58:05 PM »
Is there any information regarding the exception? (module, address, ...)

Offline flyguille

  • Newbie
  • *
  • Posts: 12
Re: XP32 service STOPs after upgrade virus database
« Reply #2 on: April 10, 2013, 05:58:33 PM »
If you rerun the service from AVAST UI it crashes again..... , it happens just after the upgrade database virus message.

I was just programming from hours and hours, this is my Dev machine, no viruses, clean XP32 sp3 professional full path.

Software include, VB6 , VS2008, DDK SDK etc.

I am 100% sure there is nothing attacking the avast, I use AVAST since years as my main protection.

Offline flyguille

  • Newbie
  • *
  • Posts: 12
Re: XP32 service STOPs after upgrade virus database
« Reply #3 on: April 10, 2013, 06:02:22 PM »
the VS2008 can't open/show the AvastSvc.exe, in way to do step by step debuging.

.... :S



Offline flyguille

  • Newbie
  • *
  • Posts: 12
Re: XP32 service STOPs after upgrade virus database
« Reply #4 on: April 10, 2013, 06:06:42 PM »
the AVAST version is 6.0.1466, it don't let me to upgrade the program aswell.

Offline kazai

  • Newbie
  • *
  • Posts: 4
Re: XP32 service STOPs after upgrade virus database
« Reply #5 on: April 10, 2013, 06:41:33 PM »
Seems like that virus database 130410 caused it

Offline flyguille

  • Newbie
  • *
  • Posts: 12
Re: XP32 service STOPs after upgrade virus database
« Reply #6 on: April 10, 2013, 06:44:21 PM »
yes seems that

please AVAST publish a patch quick!!!!!!

Offline strummer

  • Newbie
  • *
  • Posts: 1
Re: XP32 service STOPs after upgrade virus database
« Reply #7 on: April 10, 2013, 07:56:33 PM »
Hello,

today I got the same failure after updating definitions.

The service AvastSvc.exe was running but "could not be started" seconds after finishing with "successfully" installing 130410-0.
Avast was completely dead, even after reboot.


The error.log started complaining:

Wed Apr 10 16:41:32 2013
 -> topLevelExceptionFilter addr=7858ccd5 code=c0000417
Wed Apr 10 16:41:32 2013
 -> Calling generateExceptionReport
Wed Apr 10 16:41:34 2013
 -> Returning EXCEPTION_CONTINUE_SEARCH.
 
 
I booted in protected mode and edited the file "aswdefs.ini" from "Latest=13041000" to "Latest=13040900". Fortunately this directory was still present. After reboot, Avast is now running again with Definitions 13040900, complaining 13041000 are available.


Please, can someone explain what is exactly going on?
When is it save to update the definitions?

Hopefully my post can be helful to someone.

Regards.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.