Author Topic: VPS mirror up-to-date but clients not updating  (Read 5679 times)

0 Members and 1 Guest are viewing this topic.

Offline DelBert

  • Newbie
  • *
  • Posts: 14
VPS mirror up-to-date but clients not updating
« on: April 11, 2013, 04:57:52 PM »
Hi,

I've got the same issue as was discussed in the thread http://forum.avast.com/index.php?topic=118701.0 in that my mirrored VPS is up to date but the clients are not updating (and appear to be running whatever the latest VPS was when the client was installed).

I've checked that access to port 16135 is open on the Avast server and tested that client machines are able to connect, all looks good.

Additionally I've also noted that I can run an 'Update VPS' task from the server and the client updates correctly.

I've had a look through the various log files on the client machines and I can't see anything that suggests what the problem might be.

Can anyone make any further suggestions on where I might look to fix this?

Thanks,

DelBert


Offline DelBert

  • Newbie
  • *
  • Posts: 14
Re: VPS mirror up-to-date but clients not updating
« Reply #1 on: April 12, 2013, 04:58:54 PM »
We've just had an Avast support session and after a lot of head scratching the technician did something to help us. Essentially he's taken advantage of the fact that we can run a manual client-side task to update the clients and he's set up a twice daily schedule to update them. This doesn't seem right to me, although it does get us out of a hole for now, but I was intrigued to know if anyone else has a scheduled 'Update VPS' client side task (I thought the clients were already configured to make regular checks for updates)?

Thanks,

DelBert

Offline sandersui

  • Newbie
  • *
  • Posts: 1
Re: VPS mirror up-to-date but clients not updating
« Reply #2 on: May 26, 2013, 02:13:43 PM »
We're having the same issue, were you able to fully solve it?

Offline turitopa

  • Jr. Member
  • **
  • Posts: 36
Re: VPS mirror up-to-date but clients not updating
« Reply #3 on: August 07, 2014, 02:57:14 AM »
Sorry to bump this old topic.

I have a brand-new Win7 x64 desktop.
Avast is trying to update direct from the internet instead of my SOA mirror.

any resolution for this??

I have a proxy server setup at work, I don't want my client PC's trying to connect direct, they should be going to the internal mirror. 


Offline turitopa

  • Jr. Member
  • **
  • Posts: 36
Re: VPS mirror up-to-date but clients not updating
« Reply #4 on: August 07, 2014, 03:08:36 AM »
Below is an extract from the client log.
The client PC is going direct to the Internet for an update, it's not even looking for my internal Mirror???

Please provide a solution to this!!

Also my SOA mirror downloads over 100MB daily - this adds up i have had to disable daily updates becuase we only have 8GB monthly limit over here.
 >:(



06.08.201414:57:53Old version: 643 (1603)
06.08.201414:57:53Debug: Windows Server registry key not retrieved.
06.08.201414:57:54SetExistingFilesBitmap: 1282->643->642
06.08.201414:57:54GUID: 9d22424a-81ae-48c3-9264-99dcee3122d6
06.08.201414:57:54Server definition(s) loaded for 'main': 29 (maintenance:0)
06.08.201414:57:54SelectCurrent: selected server 'Download h0540049 AVAST5 Server' from 'main'
06.08.201414:57:54SYNCER: Type: no proxy
06.08.201414:57:54SYNCER: Auth: no authentication
06.08.201414:57:54Debug: Windows Server registry key not retrieved.
06.08.201414:58:07HttpGetWinsock(http://h0540049.iavs5x.u.avast.com/iavs5x/servers.def.vpx)
06.08.201414:58:28ERROR:HttpGetWinsock, WinsockTcpConnect() returned 0x0000274C
06.08.201414:58:28InvalidateCurrent: invalidated server 'Download h0540049 AVAST5 Server' from 'main'
06.08.201414:58:28SelectCurrent: selected server 'Download j3038667 AVAST5 Server' from 'main'
06.08.201414:58:28SYNCER: Type: no proxy
06.08.201414:58:28SYNCER: Auth: no authentication
06.08.201414:58:28while trying to get file 'servers.def.vpx', error 0x20000004 has occured, try 1
06.08.201414:58:28HttpGetWinsock(http://j3038667.iavs5x.u.avast.com/iavs5x/servers.def.vpx)
06.08.201414:58:49ERROR:HttpGetWinsock, WinsockTcpConnect() returned 0x0000274C
06.08.201414:58:49InvalidateCurrent: invalidated server 'Download j3038667 AVAST5 Server' from 'main'
06.08.201414:58:49SelectCurrent: selected server 'Download s3970148 AVAST5 Server' from 'main'
06.08.201414:58:49SYNCER: Type: no proxy
06.08.201414:58:49SYNCER: Auth: no authentication
06.08.201414:58:49while trying to get file 'servers.def.vpx', error 0x20000004 has occured, try 2
06.08.201414:58:51HttpGetWinsock(http://s3970148.iavs5x.u.avast.com/iavs5x/servers.def.vpx)
06.08.201414:59:12ERROR:HttpGetWinsock, WinsockTcpConnect() returned 0x0000274C
06.08.201414:59:12InvalidateCurrent: invalidated server 'Download s3970148 AVAST5 Server' from 'main'
06.08.201414:59:12SelectCurrent: selected server 'Download h9830843 AVAST5 Server' from 'main'
06.08.201414:59:12SYNCER: Type: no proxy
06.08.201414:59:12SYNCER: Auth: no authentication
06.08.201414:59:12while trying to get file 'servers.def.vpx', error 0x20000004 has occured, try 3
06.08.201414:59:14HttpGetWinsock(http://h9830843.iavs5x.u.avast.com/iavs5x/servers.def.vpx)
06.08.201414:59:36ERROR:HttpGetWinsock, WinsockTcpConnect() returned 0x0000274C
06.08.201414:59:36InvalidateCurrent: invalidated server 'Download h9830843 AVAST5 Server' from 'main'
06.08.201414:59:36SelectCurrent: selected server 'Download v2095808 AVAST5 Server' from 'main'
06.08.201414:59:36SYNCER: Type: no proxy
06.08.201414:59:36SYNCER: Auth: no authentication
06.08.201414:59:36while trying to get file 'servers.def.vpx', error 0x20000004 has occured, try 4
06.08.201414:59:38tried 4 servers to get file 'servers.def.vpx', but failed (0x000004C7)
06.08.201414:59:38servers.def.vpx not changed, 1392734275
06.08.201414:59:38Download servers.def, servers.def.vpx failed with error 0x000004C7.
06.08.201414:59:38servers.def not changed, 1392734275
06.08.201414:59:38Tried to download servers.def but failed with error 0x000004C7.
06.08.201415:00:05SYNCER: Type: no proxy
06.08.201415:00:05SYNCER: Auth: no authentication

Offline turitopa

  • Jr. Member
  • **
  • Posts: 36
Re: VPS mirror up-to-date but clients not updating SOLVED
« Reply #5 on: August 07, 2014, 04:30:25 AM »
i resolved myself.

 ;D

thanks for nothing Avast forums.


Offline mfoucault

  • Newbie
  • *
  • Posts: 10
Re: VPS mirror up-to-date but clients not updating
« Reply #6 on: March 05, 2015, 02:35:40 PM »
Please can you share the solution you used, we are in the same situation than you.

hope you read this message

Offline ChazMo

  • Newbie
  • *
  • Posts: 3
Re: VPS mirror up-to-date but clients not updating
« Reply #7 on: May 08, 2015, 03:55:49 PM »
@Turitopa

Can you enlighten us with your fix? I am having same issues here. Or if anybody else wants to chime in, that would be great!

Thanks!