Author Topic: Administration Console Service Wont Start  (Read 6215 times)

0 Members and 1 Guest are viewing this topic.

aweissenegger

  • Guest
Administration Console Service Wont Start
« on: April 12, 2013, 01:47:14 AM »
Hello all, my first post, when I try to access the administration console from the local machine, I get a page cannot be displayed error. I am running this on a VM of Windows Server 2008 R2 Standard x64. To troubleshoot, I uninstalled and reinstalled the Administration console to no avail. Then I checked to see if the services were running and I found that the avast! Administration Console service was stopped. When I try to start the service, I get a notification stating;

The avast! Administration Console service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

The avast! Administration Console Monitor is running.
The World Wide Web Publishing Service is running.

Any help on this would be greatly appreciated.

jx

  • Guest
Re: Administration Console Service Wont Start
« Reply #1 on: April 12, 2013, 06:55:05 AM »
Hello Awissenegger,

there are many possible causes for this to happen, most of them are configuration related.

Please go to your avast admin console logs folder (typically, this will be something like "c:\ProgramData\AVAST Software\Administration Console\Logs\"). Please bear in mind that ProgramData is a "hidden folder" and will not be visible by default. To enable seeing hidden folders, follow the following advice: http://windows.microsoft.com/en-us/windows-vista/show-hidden-files (you may need to search for specific settings to the version of your OS).

In the above logs folder you will see bunch of files, you are interested in the files named avast.sbc.service_XXXXX.log (where XXXXX is a numeric...). Sort these files by date and open the newest one (in a notepad or similar application). The content of the file should provide you with a hint of what is failing during the start. If you are unable to determine the cause of the failed service starts from this file, please post the content of the file (the at least the "ERROR" line and 3-5 lines before and after that).

Cheers

jx

aweissenegger

  • Guest
Re: Administration Console Service Wont Start
« Reply #2 on: April 13, 2013, 01:12:46 AM »
Thanx for your reply Jx. Here are the contents of my most recent avast.sbc.service log:

[Header - Application started at 12-Apr-2013 00:25:09,903 local/00:25:09,903 UTC]
04-11 20:25:10,887 [1] INFO  Program - avast! Administration Console service (version: 1.1.132.15)
04-11 20:25:13,074 [4] INFO  SbcCoreService - Service starting. Loading configuration
04-11 20:25:13,090 [4] INFO  ConnectionStringFactory - Connection string loaded from input stream (Data Source=(local)\AVASTSBC;Initial Catalog=avast_sbc_db;Integrated Security=True;MultipleActiveResultSets=True;Connect Timeout=60).
04-11 20:25:13,590 [4] INFO  DatabaseFactory - Performing initial connection to the database (Data Source=(local)\AVASTSBC;Initial Catalog=avast_sbc_db;Integrated Security=True;MultipleActiveResultSets=True;Connect Timeout=60).
04-11 20:25:22,231 [4] INFO  DatabaseFactory - Successfully connected.
04-11 20:25:22,231 [4] INFO  DatabaseFactory - Performing initialization.
04-11 20:25:52,309 [SchedulerCacheMediator] INFO  CacheMediator - Starting scheduler cache thread.
04-11 20:25:54,153 [7] INFO  ComputerCatalog - Computer is not in AD domain (An operations error occurred.
).
04-11 20:25:55,340 [4] INFO  SbcCoreService - Starting core.
04-11 20:25:56,512 [4] INFO  FileLicenceProvider - Loading license file from path C:\ProgramData\AVAST Software\Administration Console\license.avastlic
04-11 20:25:57,481 [4] INFO  FileLicenceProvider - Loaded license file for BP edition.
04-11 20:25:57,621 [MessageQueueThread] INFO  EngineProxyVisitor - Message queue thread started.
04-11 20:26:06,028 [SchedulerWorker0] INFO  Scheduler - Starting scheduler worker thread
04-11 20:26:06,028 [SchedulerWorker3] INFO  Scheduler - Starting scheduler worker thread
04-11 20:26:06,028 [SchedulerWorker4] INFO  Scheduler - Starting scheduler worker thread
04-11 20:26:06,028 [SchedulerWorker1] INFO  Scheduler - Starting scheduler worker thread
04-11 20:26:06,028 [SchedulerWorker2] INFO  Scheduler - Starting scheduler worker thread
04-11 20:26:06,028 [Scheduler] INFO  Scheduler - Scheduler thread has been started.
04-11 20:26:06,059 [4] WARN  ServiceConfigurationMarkerFile - File already exists. Will try to delete...
04-11 20:26:06,090 [4] WARN  ServiceConfigurationMarkerFile - File load problem: Could not find file 'C:\ProgramData\AVAST Software\Administration Console\service.txt'.
04-11 20:26:06,387 [4] INFO  SbcCoreService - Binding WCF services to:
 (http://localhost:8731/Design_Time_Addresses/Avast.Sbc.Service.Core/SbcConnectionPoint/, https://localhost:8732/Design_Time_Addresses/Avast.Sbc.Service.Core/SbcConnectionPoint/)
04-11 20:26:07,278 [4] INFO  SbcCoreService - Starting HttpDomainAccessPolicyRequestListener.
04-11 20:26:07,293 [4] INFO  ServiceHttpRequestListener - Initializing HTTP domain access policy request listener: (http://+:8731/, https://+:8732/)
04-11 20:26:07,340 [4] WARN  ServiceHttpRequestListener - 1. attempt failed (Access is denied,5,5) - waiting for 5 seconds.
04-11 20:26:12,340 [4] FATAL SbcCoreService - Service could not be started.
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'System.Net.HttpListener'.
   at System.Net.HttpListener.Start()
   at Avast.Sbc.Service.Core.ServiceHttpRequestListener.Start()
   at Avast.Sbc.Service.SbcCoreService.OnStart(String[] args)
04-11 20:26:19,309 [SystemMonitor] INFO  ProviderStatusMonitor - Issuing new provider status cleanup operation.

Again, thank you for your time and assistance.