Author Topic: Avast will not run after update (more)  (Read 2710 times)

0 Members and 1 Guest are viewing this topic.

Offline horszowski

  • Newbie
  • *
  • Posts: 4
Avast will not run after update (more)
« on: September 19, 2003, 03:13:17 AM »
Earlier  I posted a problem which arose after the program update which caused:
Unknown error.
Program cannot set property into main Storage.

You replied with a link to a similar problem other person was having where you recommend to delete/rename/move the file avast4.mdb

The problem is hapening with my mother's computer (win98) and she is in Venezuela, 82 years old and completely computer ileterate.
I'm in Brazil and just had a long conversation over the phone with her trying to solve the problem.  The problem is that it is not possible to delete/rename/move that file because it is in use.

Could you send me intructions for Win98 on how to prevent avast from starting at startup so that it is then possible to perform this action.
Remember that we are dealing with a very old person.  I could do it if I was there, but unfortunately I am not and it is very dificult to explain things like that to an old person over the phone.  The problem is compunded by the fact that we have different operating systems on our computers.

One simple solution that I can think of is to restart the computer in MSDOS mode and then use the "DEL" command followed by the path to the avast4.mdb file, however I'm unable to figure out  the (DOS) path because I'm running WinXP and the DOS prompt window in XP uses full names just like windows.  

Could you send me the DOS path? or maybe you have a better idea.?

Thanks a million in advance.  You have a great product.

Luis

Offline whocares

  • Super Poster
  • ***
  • Posts: 1698
  • I'm not a llama! :-)
Re:Avast will not run after update (more)
« Reply #1 on: September 19, 2003, 07:23:51 AM »
so that the alwil Expert's know what you're talking about:
http://www.avast.com/forum/index.php?board=2;action=display;threadid=1197;start=msg6512#msg6512

IF !! my link is indeed the solution to this, she could start the PC in SafeMode (press F8 repeatedly when booting), but wait for somebody else to confirm this..

hast luego.. ;)

Offline Hornus Continuum

  • Full Member
  • ***
  • Posts: 119
  • If you only remember one thing, it's this ...
Re:Avast will not run after update (more)
« Reply #2 on: September 25, 2003, 11:47:20 AM »
horzowski,

To disable the avast! services:

1)   Start the Services Manager.  You'll find it on the Start Menu listed as Services.  I can't say with certainty where, but I think it's on a submenu called System Tools.

2)   Look for avast! Antivirus and avast! iAVS4 Control Service in the list of services.  You probably only need to bother with the former, but disabling both won't hurt.

3)   Double-click on the name to bring up its Properties Box.

4)   Click on the down arrow for the Startup type list box, select Disabled, click on the OK command button, and close the window.  After rebooting, the service will not be running.

5)   After the problem is solved, restore the service's startup type to Automatic.

6)   If it isn't listed, avast! is not running as a service, and it's probably running as an application listed in the Start Menu's Startup submenu.  Move the shortcut to the desktop.

6a)   It will probably be easier for her to rename the shortcut, although this will cause an error message during the reboot, but she won't have to edit the Start Menu to restore the shortcut afterward.  Right-click on the name to bring up the Context Menu, select Rename, press the End key, the Backspace and the Enter keys to delete the last letter of the name.

If you want to boot in Safe Mode and delete the file, you can use the /x switch with the DIR command.  This causes it to display the path and filename in the 8.3 format.

Regards,
Hornus

"Quote me as saying I was misquoted." -- Groucho Marx  ;D