Author Topic: I used the Uninstall Utility, yet Avast says I've a previous version  (Read 10550 times)

0 Members and 1 Guest are viewing this topic.

bigspanner

  • Guest
Well, I used the Uninstall Utility to remove all Avast versions on my PC, and install the Avast Free latest.

Yet, it has given me problem today. It is unable to update the virus definitions. So, I went to Remove Program and did the update there and was successful. (you guys should try that too, instead of updating it at the Avast Control Panel).

Before the successful update, my Windows Security Center flagged my anti-virus is not installed, but Avast was running fine with all the Shields running, except the Firewall (which asked for payment to activate it).

Now that I've successfully updated the Avast virus definitions, the Windows Security Center red alert icon is no more there. Good.

So, my question is that Avast flagged me telling that I've a previous version on my PC and I should uninstall it so that Avast can perform it its best.

But I'm sure I've uninstall all versions.

I really hate going to safe mode to uninstall Avast with the Uninstall Utility all over again, as it screwed up my network connection the previous time I did that. I had to reset my PC to get my network connection back.

Is this a bug or did Avast keep remnents of its software on my PC that even the Uninstall Utility tool cannot uninstall completely?

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #1 on: April 16, 2013, 06:39:12 AM »
I also like to refer to this post....

http://en.community.dell.com/support-forums/virus-spyware/f/3522/t/19492768.aspx

I like to find out if Avast is trying to tell me to remove Emsisoft Anti-malware, which I've installed since its previous name a-squared anti-malware.

Is Emsisoft anti malware posing as an anti-virus software and conflicting with Avast?

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #2 on: April 16, 2013, 06:59:41 AM »
« Last Edit: April 16, 2013, 09:02:06 PM by bigspanner »

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9404
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #3 on: April 16, 2013, 07:33:12 AM »
It doesn't say it detected AVAST. It says it detected previous (another) antivirus product. Were you using any other antivirus before avast! ?
Visit my webpage Angry Sheep Blog

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #4 on: April 16, 2013, 07:47:36 AM »
That's what I'm trying to ask.

If it is talking about emsisoft anti malware, yes, I've it installed and it is still there, but had expired its licence.
I'm just wondering if the Avast notification is saying there is a conflict with emsisoft and that I should removed it, or is the message saying I've a previous version of AVAST?

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9404
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #5 on: April 16, 2013, 08:34:22 AM »
It's probably detecting Emsisoft. If you don't have any problems, then don't worry. They just display this to avoid as much problems as possible. But if it works for you, why not. I've used many combinations in the past and most of them worked perfectly fine.
Visit my webpage Angry Sheep Blog

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #6 on: April 16, 2013, 08:59:20 AM »
I've uninstalled Emsisoft and the notification is off. :)

However, I'm not able to update both virus definitions or program, through the Avast Control Panel....
What is wrong here?




« Last Edit: April 16, 2013, 09:01:09 PM by bigspanner »

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6710
  • Trust only what you test yourself!
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #7 on: April 16, 2013, 07:19:49 PM »
@ bigspanner Please use smaller screenshots (png or jpeg) as some users are on dial-up or have small monitors.  :)
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #8 on: April 16, 2013, 09:04:25 PM »
Screenshots sized changed.

So, who has the answer for the problem of "cannot connect to server" to update?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86803
  • No support PMs thanks
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #9 on: April 16, 2013, 09:16:20 PM »
This I take it was a manual update check ?
If so this is normally an indication that something is blocking avast from updating.

What is your operating system and firewall ?
Does it allow avast.setup internet access ?
- If it does delete the entry for it and do a manual update, this should force the firewall to ask permission again.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #10 on: April 16, 2013, 10:41:01 PM »
Operating System: XP Pro
Firewall: Windows Firewall

No exception was made in Windows Firewall to allow access to any Avast dll or exe.

As I said, if I go to Windows Remove Program under Control Panel and instead of doing Repairing, Uninstalling, etc, I do an Update. It works in updating Avast this way. However, when at Avast Control Panel, under Maintenance, click on Update, it will not update, giving the "cannot connect to server" alert.

« Last Edit: April 16, 2013, 10:44:10 PM by bigspanner »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86803
  • No support PMs thanks
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #11 on: April 16, 2013, 11:07:05 PM »
OK the XP firewall shouldn't be an Issue as it has zero outbound checking or protection (something you should consider for the future).

Whilst the Control Panel and instead of doing Repairing, Uninstalling, etc, I do an Update, has a higher permission level, that really shouldn't be an issue as the virus definitions update should work even on a limited user account.

So this is somewhat strange and I'm wondering if emsisoft anti malware hasn't left some remnants that may be in conflict.
- Uninstall possible remnants of previously installed AVs see, http://singularlabs.com/uninstallers/security-software/, this has a collection of manufactures removal tools, so that should remove any remnants, registry, etc.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #12 on: April 16, 2013, 11:19:21 PM »
Emsisoft is totally removed. After uninstalling it, I've rebooted and then I've gone to its website and downloaded its removal utility EMSIClean.exe and run it and it says nothing left of Emsisoft.


bigspanner

  • Guest
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #13 on: April 16, 2013, 11:26:48 PM »
I like to mention that I've used Avast Free for a few years and upgraded from 4 to 5 to 6 to 7 to 8.
However, this is a fresh installation of Avast, as I've used the trial version for Internet Security 8 for 30 days and after the trial expired, I decided to uninstall everything and start afresh.

After installing a fresh Avast, I was able to update and only faced this problem now, like all of a sudden.

I am hoping that my problem has a precedent here, so I can resolve this asap with some help and advice.

:(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86803
  • No support PMs thanks
Re: I used the Uninstall Utility, yet Avast says I've a previous version
« Reply #14 on: April 16, 2013, 11:33:59 PM »
1st reply:
I'm out of ideas as to why the Update via the Control panel, add remove programs, avast Update works, yet the normal one doesn't.

Is the ordinary auto update function (not manual check) working or are you getting errors on that ?

2nd reply:
When you say this was a fresh install do you mean a clean reinstall running the aswClear.exe uninstall utility for previous versions of avast that you had installed ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security