Author Topic: Avast 8 slows boot time.  (Read 15726 times)

0 Members and 1 Guest are viewing this topic.

Offline n01clueless

  • Jr. Member
  • **
  • Posts: 89
Avast 8 slows boot time.
« on: April 18, 2013, 10:32:54 AM »
I've noticed that boot time (Vista) is noticeably longer with Avast 8 than Avast 7. According to Soluto Avast takes around 40 seconds to load, much longer than anything else.

I just wondered if others have found this. If it's normal, that's fine.

Offline Link.

  • Sr. Member
  • ****
  • Posts: 200
Re: Avast 8 slows boot time.
« Reply #1 on: April 18, 2013, 12:16:04 PM »
I use vista 32 bit, boot time no longer here.
Intel Pentium Dual Cpu 1.60 Ghz. / 2GB Ram / Windows Vista Home Premium SP2 / avast! Internet Security Version 2014.9.0.2013 / Comodo Firewall with Defense+ Version 5.12.256249.2599 / Google Chrome Version 29.0.1547.76 / Mozilla Firefox 26.0 / CCleaner

Offline =SKY=

  • Super Poster
  • ***
  • Posts: 1614
  • *2010* - Thanks for 10 years!!!
Re: Avast 8 slows boot time.
« Reply #2 on: April 19, 2013, 01:32:49 AM »
I've noticed that boot time (Vista) is noticeably longer with Avast 8 than Avast 7.

Sorry, I can't say anything to the boot time of Vista, but the boot time of W2000 is longer since avast!8, too!

Some members of the forum could make the boot time faster with a clean install.

What was your way of installation: over the UI or did you make a clean install?
Win10 Home [x64] 21H1 @ Windows Defender | FF ESR |
My oldest darling: W2k Pro SP4 & UR1 @ avast! Free Antivirus 8.0.1497 | Palemoon & K-Meleon [BOTH MODIFIED for W2k] |

Offline n01clueless

  • Jr. Member
  • **
  • Posts: 89
Re: Avast 8 slows boot time.
« Reply #3 on: April 19, 2013, 11:24:33 AM »
Thanks for the reply Sky. Clean install to answer your question. I also made sure there were no remnants by using rezjor's cleanup tool.  In fact, the 40 sec I gave above was relatively good. The average Avast load time according to Soluto tends to be over 50 seconds.

Any other suggestions would really be appreciated.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Avast 8 slows boot time.
« Reply #4 on: April 19, 2013, 01:25:34 PM »
Try delaying the Auto Update check - In avast8 you need to edit (using notepad) avast5.ini the [InetWD] section of the, C:\ProgramData\AVAST Software\Avast\avast5.ini.  Win7, Vista location, this folder may be hidden.

- Broadband connections, add this line:
AlwaysConnectedWaitSeconds=120 and
AssumeAlwaysConnected=1 if not present (or edit AssumeAlwaysConnected=0 to AssumeAlwaysConnected=1)
Quote
[InetWD]
AssumeAlwaysConnected=1
AlwaysConnectedWaitSeconds=120
When complete save the changes, avast's self-defence module will ask for confirmation, etc. answer Yes. You can extend this duration if required.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline =SKY=

  • Super Poster
  • ***
  • Posts: 1614
  • *2010* - Thanks for 10 years!!!
Re: Avast 8 slows boot time.
« Reply #5 on: April 19, 2013, 03:17:40 PM »
Thanks for the reply Sky. Clean install to answer your question.

Oh, ok. I thought, this could be the reason. I updated via UI.

@David,

do you know, if these settings will be included in the next/new version of avast!8?

Or do you think, a slower boot time is an individual problem of a few users?
Win10 Home [x64] 21H1 @ Windows Defender | FF ESR |
My oldest darling: W2k Pro SP4 & UR1 @ avast! Free Antivirus 8.0.1497 | Palemoon & K-Meleon [BOTH MODIFIED for W2k] |

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Avast 8 slows boot time.
« Reply #6 on: April 19, 2013, 04:48:08 PM »
These settings have been available via the avast5.ini file for some considerable time, so I rather doubt they will be incorporated within the UI or default within the program. Since we are already on avast8 I can't see this coming in an incremental update, when this isn't a massive issue effecting lots of users.

I can't speculate on what a users system/problem might be to cause a slower boot; that would require detailed information on that users system (spec, programs running, especially security based ones).
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline n01clueless

  • Jr. Member
  • **
  • Posts: 89
Re: Avast 8 slows boot time.
« Reply #7 on: April 19, 2013, 08:43:10 PM »
Try delaying the Auto Update check - In avast8 you need to edit (using notepad) avast5.ini the [InetWD] section of the, C:\ProgramData\AVAST Software\Avast\avast5.ini.  Win7, Vista location, this folder may be hidden.

- Broadband connections, add this line:
AlwaysConnectedWaitSeconds=120 and
AssumeAlwaysConnected=1 if not present (or edit AssumeAlwaysConnected=0 to AssumeAlwaysConnected=1)
Quote
[InetWD]
AssumeAlwaysConnected=1
AlwaysConnectedWaitSeconds=120
When complete save the changes, avast's self-defence module will ask for confirmation, etc. answer Yes. You can extend this duration if required.

In Avast5 notepad I couldn't find InetWD or Broadband connections (Vista).

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Avast 8 slows boot time.
« Reply #8 on: April 19, 2013, 10:04:05 PM »
There is no Broadband connections as such, that is my paragraph title to show what switches/parameters are used (the bold text).

The InetWD is a section heading and will have [square brackets] around it.

If that isn't there you can't be looking at the right file as that has to be there as should be the AssumeAlwaysConnected parameter.

Can you post the full path and the file you are looking at ?
Check the attached image it is what is in mine, you have to scan a long way down that file to get to the [InetWD] section.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline n01clueless

  • Jr. Member
  • **
  • Posts: 89
Re: Avast 8 slows boot time.
« Reply #9 on: April 19, 2013, 10:33:20 PM »
Thanks for the help.  I've got the path as far as C:\ProgramData\AVAST Software\Avast\ but then all I've got is Avast5, which looks nothing like yours. I can't see Avast5.ini. anywhere.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Avast 8 slows boot time.
« Reply #10 on: April 20, 2013, 12:12:30 AM »
Windows is probably hiding the .ini file type after the avast5 name, in the file 'Type' column it is a configuration settings file. It is in that location in my win7 system, which should be the same as for Vista (which I don't have).

It is quite a large file for a text file, 20KB on mine, so you really have to find the section either scroll down or use the search in notepad looking for [InetWD] in the avast5.ini (configuration settings) file.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline n01clueless

  • Jr. Member
  • **
  • Posts: 89
Re: Avast 8 slows boot time.
« Reply #11 on: April 20, 2013, 10:42:24 AM »
Under Avast 5 properties it says name: avast5.ini and Type: Configuration Settings, so this is the Vista equivalent of what you've got but, having searched, there is definitely no [InetWD]. It's also a much smaller file than yours, only 9 KB.

Offline de redder

  • Jr. Member
  • **
  • Posts: 29
Re: Avast 8 slows boot time.
« Reply #12 on: April 20, 2013, 11:10:22 AM »
I had to add that line in the avast5.ini file.

Don`t know if that worked.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Avast 8 slows boot time.
« Reply #13 on: April 20, 2013, 11:49:02 AM »
Whilst a smaller file size isn't an issue, as a recently installed version of avast and little or no changes to the avast default settings wouldn't result in many changes to the avast5.ini.

I honestly don't know what is going on with your avast5.ini file, but I believe that [InetWD] section has to be there, though if no changes are made to the avast defaults it may not be required, but I do find it strange. I have given out this instruction many times and you are the first to report that the [InetWD] section isn't present.

Some changes you can make in the avastUI > Settings > Updates tab:
- Update Parameters, set that to 'My computer is permanently connected to the internet.
- Scroll further down to the Details section and expand that, reduce the 'Auto-update interval to say 180 (3 hours).
- Scroll down to the Proxy Settings (expand that) and change that to 'Direct connection (no proxy).

These change should be reflected in the avast5.ini [InetWD] section.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline n01clueless

  • Jr. Member
  • **
  • Posts: 89
Re: Avast 8 slows boot time.
« Reply #14 on: April 20, 2013, 12:25:28 PM »
Good. Those UI changes have now added the [InetWD] section at the bottom of avast5.ini (believe me, it wasn't there before). It shows AssumeAlwaysConnected=1, reflecting, as you said, the UI changes, but not AlwaysConnectedWaitSeconds=120. So, presumably if I add this manually as per your first post this should hopefully reduce load time?