Author Topic: Strange problem with Internet Explorer  (Read 15252 times)

0 Members and 1 Guest are viewing this topic.

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1843
    • AVAST Software
Re: Strange problem with Internet Explorer
« Reply #30 on: March 24, 2005, 04:11:02 PM »
Same here. I am currently without webshield. With the webshield on, I am no longer able to access Internet, mainly because Zone Alarm blocks the Internet access.

Well, if Zone Alarm is blocking it then the obvious solution is to unblock Web Shield (process ashWebSv.exe) in your firewall configuration. Does it makes any difference?

Sorry, I don't mean to be rude, but no application should be accessing the internet unless it is allowed in the firewall. That's after all the reason why you installed the whole Zone Alarm thing, isn't it?

Lukas.

Offline punkybouy

  • Newbie
  • *
  • Posts: 2
Re: Strange problem with Internet Explorer
« Reply #31 on: March 25, 2005, 02:14:00 AM »
I disabled web shield for several days.  What the heck the message said it was waiting anyway for something or other to start.   Without it I was able to surf just fine.  Tonight after being on the computer for several hours I went in and re-enabled it.  The provider started right up and it is working just fine and not waiting for anything to start.  Still think the problem is with the provider. Maybe Zone Alarm is preventing the provider/service from starting as quickly as it should?

Offline rika

  • Newbie
  • *
  • Posts: 5
  • Soy la llama que arde!
Re: Strange problem with Internet Explorer
« Reply #32 on: March 26, 2005, 01:01:36 AM »

Well, if Zone Alarm is blocking it then the obvious solution is to unblock Web Shield (process ashWebSv.exe) in your firewall configuration. Does it makes any difference?

Sorry, I don't mean to be rude, but no application should be accessing the internet unless it is allowed in the firewall. That's after all the reason why you installed the whole Zone Alarm thing, isn't it?

Lukas.
Quote

 
Hello Lukas, and thank you for your help!

But this was my problem, the configuration of ZA wouldn't help.
"process ashWebSv.exe" was infact unblocked in ZoneAlarm, so it should have been able to work. The weird thing was that even though I gave these programs the permission to access the internet, once they did, ZA blocked all internet access from my computer, not only that program.

 At times, ZA announced to have blocked Internet access immediately after start-up. I don't know if this had something to do with the fact that Avast starts up before ZA...just a wild guess.

The good news is that for one reason or another, everything seems to be working ok now!

(And sorry for the bothering, I AM a real newbie in these matters, so it might have just as well a problem with something I did, but surprisingly many people were having the similar problems with the new updated version...)

At least I got to test this Support Forum, which is a great support, by the way, I'm learning new things all the time!  :)


Offline Hervé @ BONN

  • Newbie
  • *
  • Posts: 1
  • Failure is not an option.
Problem solved: AVAST Internet Explorer Windows Firewall
« Reply #33 on: June 10, 2006, 01:12:27 PM »
Hi guys,
I just got the same problem but found its origin and a solution.
my recent problem is as for you: no more internet access via internet explorer, except when I disable the web shield of AVAST.   ???

I found that it is not caused by AVAST update:   :o
- same problem with an older AVAST version that worked previously on my PC
- no problem with the latest AVAST  on another PC

the difference between the 2 PC is just that I recently updated windows XP on line on the PC that has now the problem.
when I disable the (updated by Windows) Windows Firewall and leave AVAST Web Shield operational the result is....Internet access is working back OK !  ::)

Conclusion: the Windows Firewall updated by Win XP update online is blocking internet acess when AVAST Web Shield is running !!      :)

Now here is the solution:
Open Windows Security Center
click on Windows Firewall
click on the EXCEPTION tab
click on ADD PROGRAMS
select AVAST
valid with OK
valid the Windows Firewall with OK
and that's it: now Windows Firewall is no more blocking internet connection with AVAST running.

 :D

Thanks a lot to all of you guys: your exchange of info on this forum helped me a lot to analyse and fixed this problem.
I hope that it can be helpful to other too....


 ;)
Herve @Bonn
(French)

Offline bearmstead

  • Jr. Member
  • **
  • Posts: 28
Re: Strange problem with Internet Explorer
« Reply #34 on: June 10, 2006, 07:42:09 PM »
I had the same problem, no Internet surfing. Had email though. I have kerio firewall & left the block everything rule open. Found that Avast web scanner needed UDP rule(both directions) to function. Now I have web surfing ability back as normal. Don't understand why I had to add a UDP rule though. My local IP is the only one accessing this rule.

Offline bearmstead

  • Jr. Member
  • **
  • Posts: 28
Re: Strange problem with Internet Explorer
« Reply #35 on: June 10, 2006, 07:51:00 PM »
I log the block outgoing rule & found that I also needed to add "allow UDP outgoing" to email scanner rule. Already have had the allow incoming UDP rule. Don't know if this behavior is due to Avast or my local IP. My local IP is the one that requested UDP out.

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1843
    • AVAST Software
Re: Strange problem with Internet Explorer
« Reply #36 on: June 22, 2006, 07:39:22 PM »
The UDP traffic is probably due to name resolution (DNS) that both services perform during their operation.

Offline martosurf

  • Full Member
  • ***
  • Posts: 182
  • www.supportkevin.com - Support Kevin Kjonnas SHAC7
Re: Strange problem with Internet Explorer
« Reply #37 on: June 22, 2006, 08:11:49 PM »
Hi, I haven't any problems way down too but, why don't you update avast! to latest version [4.7.844] ? Maybe issues can be resolved that way.

Buena suerte!
"Emancipate yourself from mental slavery / none but ourselves can free our mind" - Bob Marley