Author Topic: Redirecting multiple SSL accounts  (Read 4676 times)

0 Members and 1 Guest are viewing this topic.

sded

  • Guest
Redirecting multiple SSL accounts
« on: March 23, 2005, 07:05:45 PM »
Currently have SSL email working fine to my ISP using avast! and stunnel.  Decided to see if I could add gmail account to be scanned by avast! also.  Set up avast4.ini, stunnel.conf, and TB as before, using port 11111 instead of 11110, but get the error message shown.  Nothing appears in stunnel log.

avast,ini looks like
[MailScanner]
StartPop=1
StartSmtp=1
StartImap=0
StartNntp=1
PopRedirectPort=11110,11111
SmtpRedirectPort=11025,11026
ImapRedirectPort=143
NntpRedirectPort=119
IgnoreAddress=
IgnoreLocalhost=0
AutoRedirect=1
ShowTrayIcon=1

stunnel.conf looks like
# We're running as a client to SSLify the POP connection
client=yes

# POP3 service, listens on localhost:11110
[dslx-pop3s]
accept=localhost:11110
connect=mail.dslextreme.com:995


# SMTP service, listens on localhost:11025
[dslx-smtps]
protocol=smtp
accept=localhost:11025
connect=smtp.dslextreme.com:25

;client=yes (removed in edit)

# POP3 service, listens on localhost:11111
[gmail-pop3s]
accept=localhost:11111
connect=pop.gmail.com:995

# SMTP service, listens on localhost:11026
[gmail-smtps]
protocol=smtp
accept=localhost:11026
connect=smtp.gmail.com:587

TB server setup is as shown

Is the current avast! unable to redirect multiple ports like this or is there an error in the setup?  Firewall log shows things deadend at avast! and never get to stunnel.

« Last Edit: March 23, 2005, 08:07:43 PM by sded »

sded

  • Guest
Re: Redirecting two SSL accounts
« Reply #1 on: March 23, 2005, 07:37:52 PM »
Found the problem.  Need to terminate and restart stunnel to get the new configuration accepted.  And the second "client=yes" is improper syntax and needs to be removed.  Another note for the FAQ.

Corrected stunnel.conf above

« Last Edit: March 23, 2005, 08:07:02 PM by sded »