Author Topic: Plugin for the bat stops working?!  (Read 10301 times)

0 Members and 1 Guest are viewing this topic.

Offline trigger

  • Sr. Member
  • ****
  • Posts: 205
  • To air is human, to scuba divine
    • My website on cichlids and diving
Re:Plugin for the bat stops working?!
« Reply #15 on: February 26, 2004, 07:40:54 PM »
Hi Pavel,

I just sent new logs. The account log from The Bat! and the AvBatEx.log file from the last couple of days. The parts where files do get scanned are from saving attachments, not from receiving them.

Is there any software that can monitor what is happening when The Bat! calls the plugin???

I am going to quit using the plugin and start using the internet mail provider again... I really hope you guys can find the problem.

Peter

Offline trigger

  • Sr. Member
  • ****
  • Posts: 205
  • To air is human, to scuba divine
    • My website on cichlids and diving
Re:Plugin for the bat stops working?!
« Reply #16 on: March 03, 2004, 06:35:44 PM »
PROBLEM SOLVED!!!

Thanks to debugging versions of the plugin, Pavel supplied, we found out that The Bat!  for some ideotic reason left over 38000 (Thirty-eight-thousand) temp files in the temp directory. 0 bytes big, so no overhead there, but the plugin could not find any nonexisting temp file names to create...

After deleting all those files, everything got back to normal again.

Thanks Pavel! (And all the other guys involved off-course)

Peter

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Plugin for the bat stops working?!
« Reply #17 on: March 03, 2004, 06:40:00 PM »
Well the question is whether these files were actually not created by the plugin itself (let's hope that not).
If at first you don't succeed, then skydiving's not for you.

Offline trigger

  • Sr. Member
  • ****
  • Posts: 205
  • To air is human, to scuba divine
    • My website on cichlids and diving
Re:Plugin for the bat stops working?!
« Reply #18 on: March 03, 2004, 06:44:01 PM »
It could be. The plugin gives the error not beeing able to create, so... I sent Pavel the latest logs, so he can have a look at it.

If I can do anything to help you guys find out anymore, let me know.

Peter

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Plugin for the bat stops working?!
« Reply #19 on: March 03, 2004, 09:34:10 PM »
Just keep monitoring the temp folder. It would be interesting to know whether the files are created by the avast plugin or not.

Thanks for your help.
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline sedina

  • Avast team
  • Sr. Member
  • *
  • Posts: 237
Re:Plugin for the bat stops working?!
« Reply #20 on: March 04, 2004, 09:55:56 AM »
I checked the code and I think that all temp files that plugin creates are deleted. (and on my system there is not batxxx.xxx files in temp directory) But maybe I missed something ;-( ....

Offline trigger

  • Sr. Member
  • ****
  • Posts: 205
  • To air is human, to scuba divine
    • My website on cichlids and diving
Re:Plugin for the bat stops working?!
« Reply #21 on: March 09, 2004, 07:30:05 PM »
Sorry, but in my case, they stay... There are 3005 batxxx.tmp files allready. They are stored in the c:\Documents and settings\[user] and the names are the same as the names found in the AvBatEx.log file  :-[ So please have a look again...

Peter

Offline Goner

  • Jr. Member
  • **
  • Posts: 81
  • I'm a llama!
Re: Plugin for the bat stops working?!
« Reply #22 on: April 15, 2005, 12:02:06 AM »
on my system there are only 4 bat???.tmp files from a couple of days ago ... all the new ones are deleted after use.

running TheBat! 2.11 on Windows 2000 SP4.