Author Topic: Avast 8 won't install on Vista SP2  (Read 3729 times)

0 Members and 1 Guest are viewing this topic.

Offline tcw

  • Newbie
  • *
  • Posts: 7
Avast 8 won't install on Vista SP2
« on: May 08, 2013, 05:50:02 AM »
Avast Free version 8 install fails. It had Avast on it a while ago, but the End User put a lot of other crap on this unit since the last time I touched it last year, including other antivirus and security crap which I cleaned out before trying to reinstall Avast.

The Avast install log mentions this:

26.04.201321:19:19Return code: 0x000036B1 [The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail.]

Event Log (Windows):

Log Name:      Application
Source:        SideBySide
Date:          4/26/2013 9:32:06 PM
Event ID:      59
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxx
Description:
Activation context generation failed for "C:\Program Files\AVAST Software\Avast\ashBase.dll".Error in manifest or policy file "C:\Windows\WinSxS\manifests\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57.manifest" on line 0. Invalid Xml syntax.


Did an sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of th
em.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log

The system file repair changes will take effect after the next reboot.


Any ideas how to fix this, short of a nuke and pave of the hard drive?

I've run the Avast cleaner, reinstalled all of the MS C++ packages to no avail...

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31350
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast 8 won't install on Vista SP2
« Reply #1 on: May 08, 2013, 10:53:52 AM »
It normally is a issue with visual c++.
Since (as you say) the user had a lot of crap on it and you "cleaned" the system....
It can be a lot (and really mean a lot!) of things causing the problem.
I would say, don't make it hard on yourself and just install Windows-7 (if the system can handle it)
If not, install Windows-XP (ofcourse with all available updates)

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6713
  • Trust only what you test yourself!
Re: Avast 8 won't install on Vista SP2
« Reply #2 on: May 08, 2013, 07:19:29 PM »
I would be wary of installing XP as support will end in less than a year.  :)
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast 8 won't install on Vista SP2
« Reply #3 on: May 08, 2013, 07:41:37 PM »
As mentioned the Side-By-Side Configuration is Incorrect Error in avast is usually related to C++ normally it means the required version isn't present - You need to install MS Visual C++ 2008 Redistributable.

You need 2008 SP1 - this is the one:
Microsoft Visual C++ 2008 SP1 Redistributable Package ATL Security Update
Note this link there are 64bit versions there (IA64, x64) ensure you get the correct one for your OS (x86 32bit OS, x64 64bit OS)
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro