Author Topic: [Bug] Wrong-way scrolling  (Read 7930 times)

0 Members and 1 Guest are viewing this topic.

Musaran

  • Guest
[Bug] Wrong-way scrolling
« on: April 08, 2005, 04:30:04 PM »
The resident protection manager has a service list.

Scrolling it page-down by cliking in the scroll bar scrolls content down to the right position by warp-around.

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: [Bug] Wrong-way scrolling
« Reply #1 on: April 08, 2005, 04:35:12 PM »
I've lost you there completely... it scrolls exactly as it should scroll. If you roll your mouse wheel down, providers scrolls down as they should... if you scroll your mouse wheel up, they scroll up. Nothing weird in that IMHO. Same thing with Page Up and Page Down or cursor (arrows) keys. I don't see any wrap-around on my copy of avast!, everything scrolls to the end and start point in providers part of the panel.

Basic or enhanced interface ? Or, you meant, avast! On-Access-Scanner ?
 ???
« Last Edit: April 08, 2005, 04:37:20 PM by S.Z.Craftec »
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: [Bug] Wrong-way scrolling
« Reply #2 on: April 08, 2005, 04:36:10 PM »
Working perfectly here... No problems at all  8)
The best things in life are free.

Musaran

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #3 on: April 08, 2005, 04:51:03 PM »
Basic interface, window that spawns with a normal systray click.

Exclusively by cliking in the scroll bar under the cursor (wich scrolls it a "page" at a time).
Scrolling up also warps-around (one cycle to many) to the right position.

avast is v4.6.623 home free, automatically updated.

But maybe it is just an OS bug (Windows XP SP2 Fr). :-[

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11818
    • AVAST Software
Re: [Bug] Wrong-way scrolling
« Reply #4 on: April 08, 2005, 04:54:16 PM »
And how do you judge that it "warps"?

techie101

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #5 on: April 08, 2005, 04:59:41 PM »
I think what is happening is that you end up back at the starting point (page), therefore you consider it wrapping.  In actuality, the mouse has "reset" itself to the start.  It is a little quirt with mouse operation that can even happen on other pages or programs using the scroll bar.

It really is not a problem.  Sometimes the mouse "lags" a second or so behind movement.  Naturally, when we see that it does not move accordingly....What do we do?.....move it some more.  The mouse (system) retains the original path and ultimately we may find ourselves "wrapped" back at the preceeding page or the top/bottom limits of scroll.

Happens with any OS if conditions are right.

kamulko

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #6 on: April 08, 2005, 05:08:26 PM »
mmm... I see Avast! is the MOST flawed software of the world...  ;D... Alwil Team, help us!!!... need a complete demolition of the code!!!
(ironic, obvious)
Italian Proverb:<When you see too many lacks in your love,  love is named "hate">

Musaran

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #7 on: April 08, 2005, 05:31:41 PM »
And how do you judge that it "warps"?
Select an icon that stays visible whatever the scrolling position of the list: 'Web shied" and "Instant Messenging".
Scroll the list as said, and instead of moving 2 spaces, the selected item scrolls past border and comes back through the other boder, to settle at the correct position.

It is just a graphical glitch on the scroll effect, end result is fine.

(I Just thought of testing this)
It happens only when "smooth scrolling" is activated in Windows, normal setting jumps without scrolling effect.
Most certainly an OS glitch in fact, don't bother.


Techie101 :
-Goes to the correct position.
-A mouse has no start and doesn't reset. Mouse pointer either.
-There is no lag, no drag operation, a single clic, no mouse move after.

Kamulko!
Last week I sent around 40 bug reports about a forum engine, so don't you complain ! ;D
« Last Edit: April 08, 2005, 05:34:19 PM by Musaran »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: [Bug] Wrong-way scrolling
« Reply #8 on: April 08, 2005, 05:39:55 PM »
You must have a very slow graphics card... ;) On my machine, it scrolls faster than I'm able to examine, I tried about 20 times and couldn't recognize the icons while they were moving... :)
If at first you don't succeed, then skydiving's not for you.

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: [Bug] Wrong-way scrolling
« Reply #9 on: April 08, 2005, 05:41:20 PM »
Yes, people he is right... only when Smooth scrolling feature is enabled in Windows. Actually, it's not the bug in OS, most likely it's somewhere in avast! code, something that fights with Smooth scrolling feature in Windows. Similar problems we had before with mouse pointers and stuff like that, remember ? Maybe it's something we haven't noticed before...

Edit: Yes Vlk, it scrolls so fast it's almost impossible to see what are those icons that passes by... but the problem is, it looks like it makes circles, like it runs wrap-around... but only one time...
When Smooth-Scroll List Boxes option is disabled, everything is OK, but as soon as you enable it, problem starts to show in avast! provider list...
« Last Edit: April 08, 2005, 05:46:14 PM by S.Z.Craftec »
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

kamulko

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #10 on: April 08, 2005, 05:56:43 PM »
Thanks for reply, Musaran.
I say only this: most of your observations aren't "bugs". I'm not an experienced user and I see - learning and tryng - how many strange things are only hidden parameters.
So, please, consider that is not a wasted time to read and search deep-inside the program.
Is true: you really can find some interface's bug. I think this isn't important. I think how Avast! is easier to use also for the customers who want a light graphical panel: SZCraftec's work are perfect for this.
Cheers! ;)

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: [Bug] Wrong-way scrolling
« Reply #11 on: April 08, 2005, 06:03:19 PM »
Thanks for reply, Musaran.
I say only this: most of your observations aren't "bugs". I'm not an experienced user and I see - learning and tryng - how many strange things are only hidden parameters.
So, please, consider that is not a wasted time to read and search deep-inside the program.
Is true: you really can find some interface's bug. I think this isn't important. I think how Avast! is easier to use also for the customers who want a light graphical panel: SZCraftec's work are perfect for this.
Cheers! ;)

Thanks for your opinion Kamulko, but avast! On-Access Scanner GUI uses standard, actually your current Windows visual style. Skins that we (Martin, RejZor, Darren and myself) make only affects avast! On-demand scanner and few windows (explorer extension)...
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

kamulko

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #12 on: April 08, 2005, 06:15:06 PM »
Hi, SZCraftec,
I know you've reason... but Musaran's point-of-view (as he said also in other parts of Forum) is that Avast! should be more user-friendly with some repairs at interface's look. I think so: if an user appreciate only a self-configuring program, who work without inputs, don't need to open the additional panels. Is different for other customers who put the hands in personal configuration options.

For Musaran: I use XP SP2, smooth scrolling enabled... and I have a low level graphic card: I don't have any problems 'cause the icons you say are very fast in scrolling. Maybe TOO fast for human's eyes  ;D

kamulko

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #13 on: April 08, 2005, 06:26:43 PM »
image:

Musaran

  • Guest
Re: [Bug] Wrong-way scrolling
« Reply #14 on: April 08, 2005, 06:59:39 PM »
This setting is available through:
-System properties (Windows+Pause Keys shorctut)
-Advanced tab
-(Performance) Parameters button.
-Visual effects tab.

I think I have seen this glitch in other programs too, but I am not sure.

You must have a very slow graphics card... ;) On my machine, it scrolls faster than I'm able to examine, I tried about 20 times and couldn't recognize the icons while they were moving... :)
Same for me.
Select one and concentrate on the hilight.
Anyway it is easy to notice they do move way to much for a 2 space jump, and do move the wrong way for down scrolling, it ruins the intended smooth scroll effect.


Note that fiting all services in the window (as I suggested elsewhere) would "solve" the bug. ;D