Author Topic: Avast and Email Clients  (Read 2410 times)

0 Members and 1 Guest are viewing this topic.

Offline LilSquiggle

  • Newbie
  • *
  • Posts: 1
Avast and Email Clients
« on: June 14, 2013, 11:25:28 PM »
So, first off, I apologise, I'm not the most technically minded person. I can cope with the basics, but when it comes to all these SMTP/IMAP/SSL acronyms. I have no clue what they mean or what they are for, so if I miss out important information the first time around, its because I didn't realise it was important. I think it is Avast causing these problems, but I'm not certain, so if it seems Im in the wrong place, feel free to direct me to a more appropriate support forum.

Anyways. I have a website with tsohost.co.uk and that gives me an email address. I use Thunderbird (17.0.6) to access the emails and send stuff etc. My server place has a page that gives me all the settings for my email client to make my emails work. Their "preferred" settings don't work on my Thunderbird (but do on Microsoft Outlook which I tested about five minutes ago and I have no idea why) so I use a less encrypted bunch of settings that don't use SSL. Anyway, I am using IMAP for incoming and it uses port 143 and does not use SSL. The outgoing is SMTP, uses port 25 and also does not use SSL.

So, now on to the weird things I have managed to make happen. Up until today everything was working fine. I still receive emails to Thunderbird without an issue, but I can no longer send them from this particular email address. I can however, send emails through Thunderbird on the gmail account I also have set up.


If I have all the default Avast settings turned on, the error message I get reads like this:

Code: [Select]
An error occurred sending mail: The mail server sent an incorrect greeting:  .
The email actually turns up in the sent folder of my webmail client for this email address but it never turns up in the recipients inbox.

However, if I then go into the Mail Shield settings and untick Scan Outbound Mail (SMTP) then this is the error I get:

Code: [Select]
Sending of message failed.
The message could not be sent because the connection to SMTP server mail.lilsquiggle.co.uk timed out. Try again or contact your network administrator.

In this instance, the mail never gets sent and when I go to the webmail page there is no sign of it having been sent.


I have also tested sending emails straight from the webmail page and this works fine, so I'm pretty sure the mail server is working fine at sending emails.



I mentioned above that I tried setting up Outlook. I got as far as putting in the various account settings and hitting the test button. Outlook was able to login to the incoming mail thing, but failed when trying to send a test email, so I guess this problem isn't just affecting Thunderbird.


I have also read this thread and followed the instructions concerning saving a new security certificate thing and installing the new mailshield.dll thing

http://forum.avast.com/index.php?topic=118325.0


Any help/ideas would be greatly appreciated :)


EDIT: I forgot to mention I also tried just turning off all shields on avast so that theoretically it was doing nothing. It still fails to connect to the server. I find it very strange that turning Avast off is causing it to timeout, but with everything on, it sends it to the webclient sent folder, but doesn't send it to the recipient.

SECOND EDIT: Ok. I just uninstalled Avast. Emails now send fine, so its definitely something Avast is doing. Also, the more secure SSL settings now work on Thunderbird. (I thoguht I would test them on the off chance). However, obviously I do not want to be without a virus protection so I have reinstalled and... everything still works. I have no idea. Ho hum. At least it's fixed for now. Fingers crossed it doesn't happen again :/

ALL OF THE EDITS: Yeah >.> So, briefly, everything worked. However, I have had to return Thunderbird back to the non SSL state since it wasn't working properly. It was sending emails, and they were turning it up, but it was unable to save them in the sent folder. Anyway, returning it back to how I had it before it is all working smoothly.
« Last Edit: June 15, 2013, 01:09:54 AM by LilSquiggle »